Problem with continuous spinning PROBLEM SOLVED!

General discussions about the games by Egosoft including X-BTF, XT, X², X³: Reunion, X³: Terran Conflict and X³: Albion Prelude.

Moderator: Moderators for English X Forum

Post Reply
Bill Huntington
Posts: 2488
Joined: Mon, 2. Feb 09, 18:34

Problem with continuous spinning PROBLEM SOLVED!

Post by Bill Huntington » Thu, 3. May 18, 06:50

Help! I've had a mystery problem for a while. The personal ship I'm in spins continuously but maintains the same point that it's aimed at. The world spins counter-clockwise, the same as if the 'q' key is pressed continuously. The world doesn't spin when I'm docked. The world doesn't spin faster if I press 'q'. It spins clockwise if I press
'e' and reverts to counter-clockwise if I release the 'e' key.

I bought a new joystick and mouse and the problem persists. I swapped out the keyboard and the problem remains. It happens in both AP and TC. I checked that 'automatic level out' is 'Yes' under the game controls, even toggled it back and forth. It's set on 'Yes' now.

I have no clue what the problem is or a possible solution. Any ideas?
Last edited by Bill Huntington on Thu, 3. May 18, 09:51, edited 1 time in total.
Bill in S.F., enjoying the game

Posts: 431
Joined: Sat, 15. Mar 08, 00:00

Post by Hemmingfish » Thu, 3. May 18, 07:08

The most likely thing I can think of is a mis-zeroed joystick. My old joystick had little sliders on each axis that were used to adjust the neutral position. If you set them all the way to one side it would be like constantly pulling the joystick in that direction. That was back in '96, so I don't know if they use a different system now.

The other things I could think of were
- A stuck key, but that would have been fixed with a keyboard swap
- A stuck input, which would have been fixed when you pressed Q again

I'm pretty certain it's a joystick problem. Try playing the game with no joystick attached at all, if it's normal then the problem is definitely in your joystick.

Posts: 3189
Joined: Thu, 22. Jan 09, 18:49

Post by Timsup2nothin » Thu, 3. May 18, 07:17

I would try starting a game with the default profile, just for information sake. Also, do you have any other HID installed? I have a volume control on a USB sound system that does wonky things to a USB game controller.
Trapper Tim's Guide to CLS 2

On Her Majesty's Secret Service-Dead is Dead, and he is DEAD

Not a DiD, so I guess it's a DiDn't, the story of my first try at AP
Part One, in progress

HEY! AP!! That's new!!!

Bill Huntington
Posts: 2488
Joined: Mon, 2. Feb 09, 18:34

Thank you!

Post by Bill Huntington » Thu, 3. May 18, 09:31

Thank you, Hemmingfish. Disconnecting the joystick does indeed stop the problem. I just got a new joystick; actually it's the same one but new. It's the Logitech Extreme 3D Pro, old but trusty over time. There's no sliders to adjust. It helps immensely to identify that much. I'll check out some things. Thanks again.

I set the AP opening to Default as you suggested, Tim. I found that I activated the 'Rudder' choice. 'Speed' was okay, but 'Rudder' causes the spinning. FOUND IT! Thanks Tim !!
Bill in S.F., enjoying the game

Martin Head
Posts: 127
Joined: Wed, 5. May 04, 14:31

Post by Martin Head » Thu, 3. May 18, 11:37

Have you looked at the joystick in Control panel, and tried to test/recalibrate it.

Maybe the the drivers got screwed up and needs to be removed and reinstalled again.

You say that you bought a new joystick the same as the old one. Just swapping it over the joystick driver might not have noticed it as a new joystick.

Posts: 7201
Joined: Tue, 29. Dec 09, 03:15

Post by Triaxx2 » Thu, 3. May 18, 13:31

Does it have a Hat Switch? And is that set to control the roll? I had a joystick that had a broken hat switch and would be picked up and cause weirdness. It was tied to lateral thrusters in another game and would push me up and left constantly.
A Pirate's Revenge Completed Now in PDF by _Zap_
APR Book 2: Best Served Cold Updated 8/5/2016

The Tale of Ea't s'Quid Completed

Dovie'andi se tovya sagain

Posts: 1249
Joined: Wed, 16. Nov 05, 14:33

Post by NewtSoup » Thu, 3. May 18, 15:26

The control system can get a bit messed up. - on the launcher click the button control device and see what axis is assigned to which function - this is in addition to the in game axis settings and controls.

I'm using linux and I too initially had the spinning problem and found when I throttled up it stopped! [ This was on a Thrustmaster HOTAS system - now retired due to a dead rudder potentiometer ]
I am a rock in the wind, watch how I plummet!
Mistress of Heavy Landings since 1984 (BBC-B Elite)

Corei5 3570k, 16GB Ram, Z77X-UD3H, ASUS GTX660 TI, Sidewinder FFB2, Linux Mint 19

Post Reply

Return to “X Trilogy Universe”