Linux support thread

Ask here if you experience technical problems with X Rebirth.

Moderator: Moderators for English X Forum

Post Reply
pete910
Posts: 8
Joined: Sun, 10. May 09, 16:18

Post by pete910 » Sat, 14. Mar 15, 13:09

It's libbzip2 that you need aspbazi

hhr
Posts: 61
Joined: Fri, 6. Oct 06, 15:18
x4

Post by hhr » Sat, 14. Mar 15, 13:35

mission "A Healthy Enthusiasm" (30119, 301), texture bug:

Image

Draak145
Posts: 1
Joined: Sat, 14. Mar 15, 14:12
xr

Post by Draak145 » Sat, 14. Mar 15, 14:27

The game seem to be running fine globally, I'm on high settings with a gtx760 on ubuntu 14.04. I played a bit through the main campaign and noticed a few issues :
- when in stations, lighting seems to alternate between bright and dark depending on which direction I look at.
- subtitles do not display correctly, I only seem to get the first line on each dialogue, voice is fine however.
- when I got to twilight sentinel through the gate, everything got pink, it lasted until I got to the next sector (the navigation was quite hazardous without seeing any objects)

link to twilight zone save :
https://drive.google.com/file/d/0B8Z0Qv ... sp=sharing[/url]

User avatar
aspbazi
Posts: 11
Joined: Sat, 7. Nov 09, 02:18
x4

Post by aspbazi » Sat, 14. Mar 15, 17:01

@timon37

afaik steam-rt should have libbz2 but you won't see it with ldd since the LD_LIBRARY_PATH isn't set

***

Thank you

OK, steam-rt has libbz2.
System package libbz2-1.rpm

Links are not installed, ln -s for libbz2>libbz2-1.
IT-Service «Crimea-Karro» .

fallenwizard
Posts: 616
Joined: Tue, 13. Apr 10, 20:03
x4

Post by fallenwizard » Sat, 14. Mar 15, 17:13

It seems like weapons overheat much faster in the Linux version. Can anyone else confirm this?

4k1r4
Posts: 1
Joined: Tue, 18. Dec 07, 00:10

Post by 4k1r4 » Sat, 14. Mar 15, 18:47

Hello pilots,
Quick question, do I have to own the game to betatest it?

User avatar
X2-Illuminatus
Moderator (Deutsch)
Moderator (Deutsch)
Posts: 22739
Joined: Sun, 2. Apr 06, 16:38
x4

Post by X2-Illuminatus » Sat, 14. Mar 15, 18:49

Yes, you do.
Nun verfügbar! X3: Farnham's Legacy - Ein neues Kapitel für einen alten Favoriten

Die komplette X-Roman-Reihe jetzt als Kindle E-Books! (Farnhams Legende, Nopileos, X3: Yoshiko, X3: Hüter der Tore, X3: Wächter der Erde)

Neuauflage der fünf X-Romane als Taschenbuch

The official X-novels Farnham's Legend, Nopileos, X3: Yoshiko as Kindle e-books!

Individuum 4742
Posts: 1
Joined: Tue, 8. Nov 05, 20:29
x4

Post by Individuum 4742 » Sat, 14. Mar 15, 20:15

Hi,

I've got the same problem as xarses here, except that I'm using Intel HD Graphics with the i915 driver. OS is OpenSUSE 13.2.

Here's my steam log:

Code: Select all

======================================

===

===
Shader::Compile(tag.v) Compile 10: 0:2(10): error: GLSL 3.30 is not supported. Supported versions are: 1.10, 1.20, 1.30, 1.00 ES, and 3.00 ES


======================================
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
======================================
FATAL ERROR (version 3.50 - Code revision: 192864): A fatal error has occurred and X cannot recover:
RenderDevice::CreateDefaultDeviceResources('shadergl\high\xu_downsample', handle=1:0) could not find/compile DownSample-shader!
Version: 3.50 - Code revision: 192864

Please inform EGOSOFT GmbH technical support.
======================================
Game removed: AppID 2870 "X Rebirth", ProcID 9082 
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)

FWIW, output of lspci -k

Code: Select all

...
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
        Subsystem: Lenovo Device 501e
        Kernel driver in use: i915
        Kernel modules: i915
...
Profit ist seine eigene Belohnung.

chinnybob
Posts: 3
Joined: Mon, 27. May 13, 10:45
x3ap

Post by chinnybob » Sun, 15. Mar 15, 00:12

Hi,

Started testing this a couple of hours ago, here's a list of all the issues I encountered so far.


1. During the opening cut scene the speech cuts out after the line about "prohibitive cost of components". After that there is no more speech until you get in to the game. Ambient sound still works.

2. The game frame rate is very variable. Sometimes it runs at 60+ FPS. Other times it will stutter and freeze for several seconds between frames. There doesn't seem to be anything different on screen when it does this.

3. When NPCs speak there is often a large delay between lines.

4. When NPCs speak the subtitles sometimes don't show, or only show some of the lines and not others.

5. After pressing the 'O' key to pull in cargo, the sound effect loops forever. Pressing it again starts another loop playing until eventually that is all you can hear. Docking, entering the menu etc does not stop the sound playing.







Hardware information:

Processor Information:
Vendor: AuthenticAMD
CPU Family: 0x10
CPU Model: 0x4
CPU Stepping: 0x2
CPU Type: 0x0
Speed: 3200 Mhz
4 logical processors
4 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Unsupported
SSE4a: Supported
SSE41: Unsupported
SSE42: Unsupported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 14.04.2 LTS (64 bit)
Kernel Name: Linux
Kernel Version: 3.13.0-46-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11501000
X Window Manager: Xfwm4
Steam Runtime Version: steam-runtime-release_2015-01-06

Video Card:
Driver: NVIDIA Corporation GeForce GTX 780/PCIe/SSE2

Driver Version: 4.4.0 NVIDIA 331.113
OpenGL Version: 4.4
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 59 Hz
VendorID: 0x10de
DeviceID: 0x1004
Number of Monitors: 2
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1200
Desktop Resolution: 3200 x 1200
Primary Display Size: 20.39" x 12.76" (24.02" diag)
51.8cm x 32.4cm (61.0cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 3072 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: VIA VT1708S

Memory:
RAM: 16048 Mb

Miscellaneous:
UI Language: English
LANG: en_GB.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 464467 Mb
Largest Free Hard Disk Block: 43480 Mb

Installed software:

Recent Failure Reports:
Thu Mar 12 02:47:21 2015 GMT: file ''/tmp/dumps/crash_20150312024700_6.dmp'', upload yes: ''CrashID=bp-21c9351d-3b4a-4e5a-bd20-b6c482150311''
Sat Mar 14 02:28:42 2015 GMT: file ''/tmp/dumps/assert_20150314022834_5.dmp'', upload yes: ''CrashID=bp-51c0ffe6-0b16-4f18-9204-6c0312150313''

User avatar
Unshra
Posts: 1
Joined: Sun, 15. Mar 15, 18:41
xr

Post by Unshra » Sun, 15. Mar 15, 19:09

When I try to start the campaign or free play the game starts to load then the screen goes black and eventually returns to the desktop.

Code: Select all

OS: Arch Linux
	Kernel: 3.18.6-1-ARCH
CPU: Intel(R) Core(TM) i7-4510U
Video: NVIDIA Corporation GK107M [GeForce GT 750M]
	Driver: Nvidia 346.47

Code: Select all

XFocusChanged(1)
SDL_WINDOWEVENT_RESIZED 1920 1080
InformResolutionChange wh 1920 1080
BE_UnitNum 32
======================================
[Movie.LoadFormat] File videos/logo_publisher.mkv: avformat_open_input = -2 'No such file or directory'
======================================
======================================
[Movie.LoadFormat] File videos/logo_publisher.mkv: avformat_open_input = -2 'No such file or directory'
======================================
======================================
[Video.Start] Failed to start movie -2
======================================
TextureD3D::BE_SetSize(textures\dynamic\movie_frame0[]-dynamic) 1280 720
TextureD3D::BE_SetSize(textures\dynamic\movie_frame1[]-dynamic) 1280 720
processed 18
Name shadergl\high_spec\xu_l_pass_pointlight compiled 1227
Name shadergl\high_spec\xu_l_pass_pointlight compiled 1230
Name shadergl\high_spec\xu_l_pass_pointlight compiled 1233
Name shadergl\high_spec\xu_l_pass_pointlight compiled 1236
Name shadergl\high_spec\xu_g_buffer_pass compiled 1239
Name shadergl\high_spec\xu_g_buffer_pass compiled 1242
Name shadergl\high_spec\xu_g_buffer_pass compiled 1245
Name shadergl\high_spec\xu_g_buffer_pass compiled 1248
Name shadergl\high_spec\xu_g_buffer_pass_alpha compiled 1251
Name shadergl\high_spec\xu_g_buffer_pass_alpha compiled 1254
Name shadergl\high_spec\xu_g_buffer_pass_alpha compiled 1257
Name shadergl\high_spec\xu_g_buffer_pass_alpha compiled 1260
Name shadergl\high_spec\xu_l_pass_boxlight compiled 1263
Name shadergl\high_spec\xu_l_pass_boxlight compiled 1266
Name shadergl\high_spec\xu_l_pass_boxlight compiled 1269
Name shadergl\high_spec\xu_l_pass_boxlight compiled 1272
TextureD3D::BE_Load(assets\fx\textures\envmap_lightbrown): YAY

TextureD3D::BE_SetSize(assets\fx\rendertargets\cockpit_detailmonitor-rendertarget) 1319 877
======================================
[Movie.LoadFormat] File videos/logo_publisher.mkv: avformat_open_input = -2 'No such file or directory'
======================================
======================================
Cannot match path '//add_player_choice_sub[@text='{1002,3002}']' in patch file 'extensions\taf\md\npc_shiptrader.xml'. Skipping node.
======================================
======================================
Failed to resolve AI script handler reference 'ShipOwnedAttackedHandler'
======================================
/home/<username>/.local/share/Steam/SteamApps/common/X Rebirth/testandlaunch: line 30: 19078 Aborted 
        (core dumped) ./$1
Game removed: AppID 2870 "X Rebirth", ProcID 20265 

sh_vit
Posts: 1
Joined: Sun, 15. Mar 15, 20:24

Fatal Error

Post by sh_vit » Sun, 15. Mar 15, 20:35

Error when I'am run X-Rebirth (in red window):

A fatal error has occured and X cannot recover:
RenderDevice::CreateDefaultDeviceResources('shadergl\high\xu_downsample', handle=1:0) could not find/compile DownSample-shader!
Version: 3.50 - Code revision: 192864

--
Steam in Ubuntu 14.04 x64

apella
Posts: 5
Joined: Tue, 11. Jan 11, 15:03
x3tc

Post by apella » Sun, 15. Mar 15, 20:40

noticed issues that aren't on the known issues list:
  • * Sound levels are completely off when using 5.1 sound. In stereo, the audio sounds (kinda) fine. It sounds as if the distances to the sound sources are at fault, the protagonist's voice is loud, others are quiet.
    * Twilight sentinel is completely magenta
    * Faces look horrible, lip-sync doesn't seem to work (Could be normal though, this is my first playthrough of X Rebirth)
    * Conversations are extremely awkward: long pauses between sentences, subtitles that are cut off, but also extremely bad voice acting. I guess that last thing is something I'll have to live with anyway.

apcolvin
Posts: 4
Joined: Sun, 15. Mar 15, 21:17

Post by apcolvin » Sun, 15. Mar 15, 21:30

Played the campaign until going through the gate and after that the screen is pink. I have tried restarting and changing all of the graphics settings. Here is a screenshot
https://drive.google.com/file/d/0B-z_UP ... sp=sharing

pete910
Posts: 8
Joined: Sun, 10. May 09, 16:18

Post by pete910 » Mon, 16. Mar 15, 02:03

Was going to report the light and dark issue but seems to have been mentioned all ready.

Will add though that since that small patch I have to exit steam then start off the command line via

Code: Select all

steam steam://run/2870
If I exit the game then try to re-run X Rebirth this is output to the console and fails to re-start

Code: Select all

XLib::XMLInputOpenCallback(): Failed to open the file: t/0002


When started like said in the console I keep seeing this

Code: Select all

ShaderD3D::SetTechniqueByName() shader shadergl\high_spec\xu_ssao techinque SSAOPOST

cause of the light/dark issue ?

290x 14.12 driver btw

dark7np
Posts: 85
Joined: Mon, 16. Mar 15, 12:09
x4

Post by dark7np » Mon, 16. Mar 15, 12:16

I just wanted to report that it worked well for me. According to steam, I've played 13 hours over the weekend. I had no big graphical issues (some delays in text rendering). It did crash twice or so. Apart from that, it was smooth. I'm on Arch Linux (rolling release) Kernel 3.18, Nvidia GTX 460 with proprietary drivers 346.47. Didn't have to fix any further libraries (steam itself has some issues with arch due to steam providing old libraries), it just worked out of the box.

Ah, one annoying graphical thing: In station scanning mode, unscanned stuff was white. Since the menus (right side of cockpit) are transparent, that meant I could not read them over the white station schematics...

What I did have issues with however is the game itself... Dunno if I like it. Played the campaign, but the Rahanas did not really want to trade all that much. It worked for a bit, then it stopped (did not move). Not sure if it was because I bought some space fuel without the proper PMC licence and then tried to sell it. But after that, I dunno... Even with the licence it did not work. I could tell it to sell something, then it was stuck undocking. Can that be an issue with the linux Version? Mouse wheel sure would have been nice. The whole interface felt confusing. Scanning stations is a PITA. So is smalltalk, finding missions, navigating with the ingame maps. I really missed a zoom function (mousewheel?). I also really missed the ability to select a target from the local map so that I know which direction to fly to for scanning a station.

When using the autopilot the screen was shaking back and forth, so I stopped using it. No SETA is boring.

So all in all... mixed feelings. The gameplay experience was not what I hoped for, but I don't think it was because of the Linux version. So nice work with that I guess. :)

Post Reply

Return to “X Rebirth - Technical Support”