[MOD] X Rebirth Lost Sectors v1.5.0

The place to discuss scripting and game modifications for X Rebirth.

Moderators: Scripting / Modding Moderators, Moderators for English X Forum

User avatar
KrYcHokE
Posts: 259
Joined: Wed, 2. Dec 15, 13:15
x4

Re: [MOD] X Rebirth Lost Sectors v1.5.0

Post by KrYcHokE » Sat, 11. Nov 23, 15:18

I'd say jobs, since regions didn't do much in background, some still can cause performance drop when you enter them due to too high density.

John Colman
Posts: 140
Joined: Sat, 3. Jan 15, 22:35

Re: [MOD] X Rebirth Lost Sectors v1.5.0

Post by John Colman » Tue, 14. Nov 23, 20:11

I usually only get frame drops in very crowded zones with many ships or close to some clouds.
The framedrop with ships is just a minor issue but some specific clouds, like the ones in Home of Opportunity, cause massive lag to me.
But i never noticed any issues with the increasing number of systems.
For me, with all the systems from mods, the performance is equal to playing vanilla.

Realspace
Posts: 1327
Joined: Wed, 15. Nov 06, 10:21
x4

Re: [MOD] X Rebirth Lost Sectors v1.5.0

Post by Realspace » Thu, 16. Nov 23, 08:48

John Colman wrote:
Tue, 14. Nov 23, 20:11
I usually only get frame drops in very crowded zones with many ships or close to some clouds.
The framedrop with ships is just a minor issue but some specific clouds, like the ones in Home of Opportunity, cause massive lag to me.
But i never noticed any issues with the increasing number of systems.
For me, with all the systems from mods, the performance is equal to playing vanilla.
I've installed the mods one by one, starting a new game at each step. Initially I thought some specific mod being the reason but then realized that it increases (reduces few fps) at each one added. So had the idea about the reason that is also the cause in my massive X4 xrsge mod: regions and/or jobs.
The drop happens at the very start of the game and continues, also far from the added sectors (in Albion).
I've tested the mods by removing the jobs and the fps goes back up. I've then edited the mods (yours and Lost sectors) by reducing the jobs a lot. I also changed some regions that are a 600.000km sphere to a much thinner tube or cylinder, but I don't think they make that much of a difference.
This allows me to play despite the fps drop still happening randomly, which also lets me think there is maybe some problem in my pc to handle the calculations, ram or cpu (ryzen 3600 + 32gb 3600).
I am sure graphics are not the reason, my old RX 580 handles X4 even better than Rebirth. Maybe some driver is corrupted.
Usually some stuttering or random fps drop is due to errors, I'll investigate further in the debug log.
I don't want to give up on using to these mods, after I've seen the new map I simply can't play in vanilla map only without getting depressed :D

Btw. if you want I can provide you the new jobs, that can be put as optional patches in the nexus. I've taken the time to simply reduce them at 1/3, no reason for you to do it too, you already did a great job by doing that massive content..I'm the most titled to say that, doing the X4 overhaul took me one year! :D

John Colman
Posts: 140
Joined: Sat, 3. Jan 15, 22:35

Re: [MOD] X Rebirth Lost Sectors v1.5.0

Post by John Colman » Thu, 16. Nov 23, 18:36

Realspace wrote:
Thu, 16. Nov 23, 08:48
This allows me to play despite the fps drop still happening randomly, which also lets me think there is maybe some problem in my pc to handle the calculations, ram or cpu (ryzen 3600 + 32gb 3600).
I am sure graphics are not the reason, my old RX 580 handles X4 even better than Rebirth. Maybe some driver is corrupted.
Usually some stuttering or random fps drop is due to errors, I'll investigate further in the debug log.
I would assume its hardware related, the game runs smooth for me, just some minor stutters when i enter a system or lags close to some nebula or large amounts of ships.
My graphiccard is a AMD Ryzen 5 2400G with Radeon Vega Graphics 3.60 GHz.

Before you wrote me this, no one ever has told me about this issue. Sadly, if its about the hardware, i cant really do that much.
But today now, i was informed by Horizons815 in the comments for Procura Nebula, about the same issue.
Realspace wrote:
Thu, 16. Nov 23, 08:48
I don't want to give up on using to these mods, after I've seen the new map I simply can't play in vanilla map only without getting depressed :D

Btw. if you want I can provide you the new jobs, that can be put as optional patches in the nexus. I've taken the time to simply reduce them at 1/3, no reason for you to do it too, you already did a great job by doing that massive content..I'm the most titled to say that, doing the X4 overhaul took me one year! :D
Thanks for these honorable words! 8)
You can give me those files, if you want, but i hope we might find a solution for you to enjoy my content as intended without any cuts or losses.

ziplock815
Posts: 287
Joined: Wed, 8. Oct 14, 20:30

Re: [MOD] X Rebirth Lost Sectors v1.5.0

Post by ziplock815 » Fri, 17. Nov 23, 15:32

It was me, Newhorizons815 guy :D
Realspace, you've told that you have RX 580 card, and I have even older RX 570. Maybe the issue could be caused with these cards? For example, I was experiencing lots of crashes in Starfield until I downloaded RX 570/580 fix.
Anyway, It's strange to have low fps issues in Rebirth, because I have stable 60-90 fps in X4 :gruebel:

Post Reply

Return to “X Rebirth - Scripts and Modding”