Fatal Error at launch

Ask here if you experience technical problems with X Rebirth.

Moderator: Moderators for English X Forum

Post Reply
RBdes
Posts: 1
Joined: Mon, 21. Sep 20, 23:10

Fatal Error at launch

Post by RBdes » Mon, 21. Sep 20, 23:52

Hello Egosoft Team. I manually downloaded X:Rebirth outside of GOG Galaxy from my GOG account.
The installation was a success, but when I try to launch the game an error message shows.


Took a screen of it from the desk ..... https://ibb.co/PFw6W15

I am running Linux Mint 19.3 Tricia 64 - Linux kernel 5.4.0-47-generic x86_64 - MATE 1.22.2
Nvidia 1050 TI - Ryzen 3600

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 22875
Joined: Fri, 16. Apr 04, 19:21
x4

Re: Fatal Error at launch

Post by Alan Phipps » Tue, 22. Sep 20, 11:39

Have you used the GOG verification tool to check your game installation?

You will need to post some more information, especially about your system and any game mods, if that does not help.

If you think it may be an issue specific to Linux (and I canot help you with that) then it may be worth checking this thread.
A dog has a master; a cat has domestic staff.

Alm888
Posts: 155
Joined: Sat, 14. Sep 19, 19:38
x4

Re: Fatal Error at launch

Post by Alm888 » Wed, 11. Nov 20, 17:39

RBdes wrote:
Mon, 21. Sep 20, 23:52
…when I try to launch the game an error message shows.
Took a screen of it from the desk ..... https://ibb.co/PFw6W15
Just in case you did not manage to fix the problem, I'd want to inform that the case and solution are indeed described in this post.

So, even manual removal of two extra (highlighted in the post) "/*" sequences from lines 574 and 622 of the "<main_dir>/shadergl/shaders/common.fh" file fixes the problem.

Apparently, nVidia became much more strict with shader compilation and will not tolerate bad syntax anymore.

Post Reply

Return to “X Rebirth - Technical Support”