Ausrüstungsmodifikationen unter 2.x

Hier ist der ideale Ort um über Scripts und Mods für X4: Foundations zu diskutieren.

Moderators: Moderatoren für Deutsches X-Forum, Scripting / Modding Moderators

Post Reply
stb.rweckener
Posts: 366
Joined: Sun, 1. Apr 12, 09:20
x3ap

Ausrüstungsmodifikationen unter 2.x

Post by stb.rweckener » Fri, 5. Apr 19, 15:52

Ich hatte einige neue Schiffsausrüstungen erstellt... Antriebe, Schilde, Waffen. Unter 1.xx funktionieren die Modifikationen. Seit 2.0 geht nichts mehr. Hat Ego da was eingebaut was diese Modifikationen unmöglich macht?

User avatar
Marvin Martian
Posts: 3122
Joined: Sun, 8. Apr 12, 09:40
x4

Re: Ausrüstungsmodifikationen unter 2.x

Post by Marvin Martian » Tue, 9. Apr 19, 14:50

banalste Ursache könnte eine geänderte Struktur in der Ware.xml sein, einfach mal die 1.x zu 2.x vergleichen, durch die Spielerwerften könnte da was passiert sein

was sagt denn dein Debuglog?

stb.rweckener
Posts: 366
Joined: Sun, 1. Apr 12, 09:20
x3ap

Re: Ausrüstungsmodifikationen unter 2.x

Post by stb.rweckener » Tue, 9. Apr 19, 16:23

Vielen Dank erstmal für die Rückmeldung. Meine Moddingkenntnisse sind doch relativ begrenzt.

Das es an der Wares liegt glaube ich nicht. Beim Aufbau kann ich keinen Unterschied finden der das erklären würde, Außerdem wäre das meiner Meinung nach nur problematisch beim Kauf eder Verkauf der Ausrüstung...

Problem bei mir ist, dass es jede menge Schiffe bei mir gibt, die die Ausrüstung (u. A. Antriebe) schon drinn haben. Selbige ist dann nach dem Laden des 1.6 er Standes weg. Mit einem Neuanfang fuzt das ganze auch nicht...

Wie erzeuge ich die Debug.log?

stb.rweckener
Posts: 366
Joined: Sun, 1. Apr 12, 09:20
x3ap

Re: Ausrüstungsmodifikationen unter 2.x

Post by stb.rweckener » Tue, 9. Apr 19, 18:02

Anbei die Debug aus der unidata. Es erwägt den Anschein, das er die Dateien nicht läd weil sie nicht zertifiziert sind? Dann würde doch aber kein Mod mehr funktionieren oder?


[12.000000]={
["gamestart"]=1.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\index\\macros.xml.sig'",
["timestamp"]=1554818119.000000,},
[11.000000]={
["gamestart"]=1.000000,
["message"]="Info: File I/O: Failed to verify the file signature for file '.\\extensions\\super eqip mod\\index\\components.xml' (error: 14)",
["timestamp"]=1554818119.000000,},
[10.000000]={
["gamestart"]=1.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\index\\components.xml.sig'",
["timestamp"]=1554818119.000000,},
[9.000000]={
["gamestart"]=1.000000,
["message"]="Info: File I/O: Failed to verify the file signature for file '.\\extensions\\super eqip mod\\libraries\\wares.xml' (error: 14)",
["timestamp"]=1554818119.000000,},
[23.000000]={
["gamestart"]=2.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\index\\macros.xml.sig'",
["timestamp"]=1554818750.000000,},
[8.000000]={
["gamestart"]=1.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\libraries\\wares.xml.sig'",
["timestamp"]=1554818119.000000,},
[19.000000]={
["gamestart"]=2.000000,
["message"]="Info: File I/O: Failed to verify the file signature for file '.\\extensions\\super eqip mod\\t\\0001-l049.xml' (error: 14)",
["timestamp"]=1554818742.000000,},
[7.000000]={
["gamestart"]=1.000000,
["message"]="Info: 'GeForce GTX 1050 Ti' NVidia-driver v411.63.0 (Vulkan 1.1.82) check=1",
["timestamp"]=1554818112.000000,},
[1.000000]={
["gamestart"]=1.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\advancedsatelliterange\\content.xml.sig'",
["timestamp"]=1554818110.000000,},
[6.000000]={
["gamestart"]=1.000000,
["message"]="Info: File I/O: Failed to verify the file signature for file '.\\extensions\\super eqip mod\\t\\0001-l049.xml' (error: 14)",
["timestamp"]=1554818111.000000,},
[5.000000]={
["gamestart"]=1.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\t\\0001-l049.xml.sig'",
["timestamp"]=1554818111.000000,},
[4.000000]={
["gamestart"]=1.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\content.xml.sig'",
["timestamp"]=1554818110.000000,},
[21.000000]={
["gamestart"]=2.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\index\\components.xml.sig'",
["timestamp"]=1554818750.000000,},
[24.000000]={
["gamestart"]=2.000000,
["message"]="Info: File I/O: Failed to verify the file signature for file '.\\extensions\\super eqip mod\\index\\macros.xml' (error: 14)",
["timestamp"]=1554818750.000000,},
[22.000000]={
["gamestart"]=2.000000,
["message"]="Info: File I/O: Failed to verify the file signature for file '.\\extensions\\super eqip mod\\index\\components.xml' (error: 14)",
["timestamp"]=1554818750.000000,},
[18.000000]={
["gamestart"]=2.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\t\\0001-l049.xml.sig'",
["timestamp"]=1554818742.000000,},
[20.000000]={
["gamestart"]=2.000000,
["message"]="Info: 'GeForce GTX 1050 Ti' NVidia-driver v411.63.0 (Vulkan 1.1.82) check=1",
["timestamp"]=1554818743.000000,},
[3.000000]={
["gamestart"]=1.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\increasedlongrangescan\\content.xml.sig'",
["timestamp"]=1554818110.000000,},
[17.000000]={
["gamestart"]=2.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\super eqip mod\\content.xml.sig'",
["timestamp"]=1554818741.000000,},
[16.000000]={
["gamestart"]=2.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\increasedlongrangescan\\content.xml.sig'",
["timestamp"]=1554818741.000000,},
[15.000000]={
["gamestart"]=2.000000,
["message"]="Error: File I/O: Could not find file '.\\extensions\\increasedbailchance\\content.xml.sig'",
["timestamp"]=1554818741.000000,},
[13.000000]={
["gamestart"]=1.000000,
["message"]="Info: File I/O: Failed to verify the file signature for file '.\\extensions\\super eqip mod\\index\\macros.xml' (error: 14)",
["timestamp"]=1554818119.000000,},},}

stb.rweckener
Posts: 366
Joined: Sun, 1. Apr 12, 09:20
x3ap

Re: Ausrüstungsmodifikationen unter 2.x

Post by stb.rweckener » Tue, 9. Apr 19, 21:35

@ Marvin Martian, Danke für den Debutip. Hab das Problem gefunden. Das komische ist, das ich jetzt wieder die 1.6 er Version meines Mods nehme, die unter 2.0 nicht wollte... Der Anpassungsversuch hat dann dazu geführt, das der Mod unter 2.2 nicht ging... Darauf wäre ich ohne die Debug nie gekommen...

Post Reply

Return to “X4: Foundations - Scripts und Modding”