[PROGRAM] Plugin Manager : V1.531 : 11/08/2015

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Post Reply
User avatar
stavros
Posts: 393
Joined: Fri, 4. Nov 05, 13:41
x4

Post by stavros » Sat, 23. Jan 10, 18:57

sorry............i got completely the wrong file extension.

What i meant was .xsp files.

What do i do with them???
He who fires the first shot, admits he has lost the argument

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20605
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Sat, 23. Jan 10, 20:05

if you have the latest plugin manager, 1.10 RC4, then you do exactly the same as spk files

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20605
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Sat, 23. Jan 10, 21:12

New version available, 1.10

main features is full ship installing support

Changes from 1.00
  • Improved display for installed multi-spk files
  • Improved displays when enabling/disabling multiple packages
  • Added Ship Installler Compatability
  • Added File Assocation, allows double clicking to install spk/xsp files
  • Added EMP-X support
Also includes the old ship creator, in the Old Tools section
and the XSP Convertor to allow you specify weapon masks for both Reunion and Terran Conflict

User avatar
stavros
Posts: 393
Joined: Fri, 4. Nov 05, 13:41
x4

Post by stavros » Sat, 23. Jan 10, 22:17

i dont think that i do have the latest plugin manager (1.10 rc4).

Can you point me in the direction of obtaining it please.
He who fires the first shot, admits he has lost the argument

exhale99
Posts: 47
Joined: Mon, 12. Jan 09, 17:53

Post by exhale99 » Sat, 23. Jan 10, 22:24


User avatar
Valkyrie004
Posts: 13
Joined: Mon, 18. Jan 10, 15:55

Program Error

Post by Valkyrie004 » Sun, 24. Jan 10, 12:07

Hiya!

I loaded the manager today to install something, and it requested permission to update, so I said yes. It installed, then the whole program stopped working. Now I get an error whenever I try to open the manager.

Code: Select all

The procedure entry point
?GetCurrentDirectory@CPackages@@QAE?AVCyString@@XZ could not be located in the dynamic link library spk.dll.

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20605
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Sun, 24. Jan 10, 12:39

yeah its a problem with the auto updater from the old version, just download the full installer and reinstall and it should work.

the auto updater is fixed in 1.10, so it'll work to update to future versions

Web Goblin
Posts: 115
Joined: Sun, 21. Nov 04, 17:35
x4

Post by Web Goblin » Sun, 24. Jan 10, 12:59

I havent played TC for over a year now but have just installed in in my new computer. Along with my ATI5870 it should run very smoothly so it looks like time to start again.
Cycrow its good to see that you are still supporting this game.
One question though, as for installing ships with the new manager where do they appear or how do I assign them to shipyards?

Mnay thanks

Ian

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20605
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Sun, 24. Jan 10, 13:03

ships can be assigned to shipyards from the ship creator, then they should be added to the shipyards of what ever races were assigned.

User avatar
Valkyrie004
Posts: 13
Joined: Mon, 18. Jan 10, 15:55

Post by Valkyrie004 » Sun, 24. Jan 10, 13:44

Cycrow wrote:yeah its a problem with the auto updater from the old version, just download the full installer and reinstall and it should work.

the auto updater is fixed in 1.10, so it'll work to update to future versions
Okay. I download & installed it. It works again. Thank you.

heh...such an easy fix, feel silly for even asking about it. lol

Web Goblin
Posts: 115
Joined: Sun, 21. Nov 04, 17:35
x4

Post by Web Goblin » Sun, 24. Jan 10, 14:18

Cycrow,
I take it I need to install the old plugin manager as well to get the ship creator?

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20605
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Sun, 24. Jan 10, 14:37

no the old ship creator is included in the full installer, just goto the option at the bottom for Old Tools

Web Goblin
Posts: 115
Joined: Sun, 21. Nov 04, 17:35
x4

Post by Web Goblin » Sun, 24. Jan 10, 15:58

Cycrow,
Have installed the old tools package, forgot to check the box forst time.
When I pick the X3 directory the ship creator says it cannot find the exe file even though it is the correct directory. Tried to point to it manually and get the same error. Plugin manager lite finds the x3 directory ok.
The auto updater for the SPK library also gives a SONAR warning in NORTON IS 2010.
Any ideas?

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20605
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Sun, 24. Jan 10, 16:37

the ship creator is only the old one, and it only works with X3 Reunion

the warning is from auto Updater.exe itself ?

no idea y it would be cause that, as its just a basic file downloader in .net

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20605
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Sun, 24. Jan 10, 17:57

ok i looked into SONAR some more and seems like your own opens is to exclude the file from being scanned.

only way to make it not bring up a false positive is to add a digital signature to the file, which isn't cheap.

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”