[PROGRAM] X Plugin Manager : V1.62 : 2022-06-20

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Scripting / Modding Moderators, Moderators for English X Forum

Post Reply
FTLasteroid
Posts: 1
Joined: Sun, 25. Oct 20, 07:13

Re: [PROGRAM] X Plugin Manager : V1.60 : 2021-04-10

Post by FTLasteroid » Fri, 22. Apr 22, 19:55

I cannot start game from the program,after I click the launch button,the plugin manager just close itself,and nothing more.
Is anybody can help me?I would be extremely grateful.

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 21310
Joined: Mon, 15. Nov 04, 00:26
x4

Re: [PROGRAM] X Plugin Manager : V1.60 : 2021-04-10

Post by Cycrow » Fri, 22. Apr 22, 21:08

There is an issue with the launcher which will be fixed in the next version.

however, you can just run the game manually

Das Attorney
Posts: 10
Joined: Tue, 13. May 08, 01:55
x3tc

Re: [PROGRAM] X Plugin Manager : V1.60 : 2021-04-10

Post by Das Attorney » Tue, 24. May 22, 18:42

Hi,

I'm having an issue with adding mods in the v1.60 plugin manager.

If I use the Lite version, I can install one mod (which has the .cat & .dat in the format someName.cat & someName.dat). If I try to either give them a number so they can be loaded as fake patch (like 20.cat & 20.dat), then rezip, they refuse to install with "Install Archive" option. This is the same on the advanced manager too. From what I've read in this thread, I believe the Plugin Manger should renumber them automatically. Is this correct?

I tried using package creator.exe to convert the archive to an .spk and right click to "convert to fake patch" but once I've Saved the spk, it won't install using the "Install Package" option.

I've reinstalled The Plugin Manager using links from the front page & tried running in Admin mode (in case of permissions problems). Also installed VC++ library so I don't think that's the issue.

I can upload a video &/or the mod files I'm trying to activate if that will help. (Mars & Complex Cleaner).

Thanks

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 21310
Joined: Mon, 15. Nov 04, 00:26
x4

Re: [PROGRAM] X Plugin Manager : V1.60 : 2021-04-10

Post by Cycrow » Tue, 24. May 22, 18:56

When you tried to install it via the spk file you created, what error message did you get ?

For the zip file, make sure when you renamed them, you also move them out of the mods directory.

If you can upload the mid files and spk file you created somewhere I can take a look

Das Attorney
Posts: 10
Joined: Tue, 13. May 08, 01:55
x3tc

Re: [PROGRAM] X Plugin Manager : V1.60 : 2021-04-10

Post by Das Attorney » Tue, 24. May 22, 19:31

Thx for the reply.

I've uploaded a video showing the issue here:

https://drive.google.com/file/d/1PPnq-3 ... sp=sharing

It's me trying to install complex cleaner (repacked by Dr Bullwinkle for PM). I ran it in admin just to show that's not the issue. Everything seems ok until it's selected then the GUI flashes (refreshes??) and nothing happens.

Then it shows the mod repacked for spk and same thing. This time though, both of them are showing up as import options.

I put the mods into an archive & uploaded here:

https://drive.google.com/file/d/1WrDtMx ... sp=sharing

Thanks for taking a look - let me know if you need anything else.

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 21310
Joined: Mon, 15. Nov 04, 00:26
x4

Re: [PROGRAM] X Plugin Manager : V1.61 : 2022-05-25

Post by Cycrow » Wed, 25. May 22, 20:11

I've updated the Plugin Manager to 1.61, this should fix installing fake patches

Das Attorney
Posts: 10
Joined: Tue, 13. May 08, 01:55
x3tc

Re: [PROGRAM] X Plugin Manager : V1.61 : 2022-05-25

Post by Das Attorney » Wed, 25. May 22, 20:59

Thanks for working on this; I tried updating but I get the dialog saying that the spk libraries & plugin manager will be updated, and when I click "yes" to "do you wish to download & install it?", the window vanishes.

I checked event viewer and this error appears:

Code: Select all

Faulting application name: AutoUpdater_old.exe, version: 0.0.0.0, time stamp: 0x607166d8
Faulting module name: KERNELBASE.dll, version: 10.0.19041.1706, time stamp: 0x40a40d01
Exception code: 0xe0434352
Fault offset: 0x0012c3a2
Faulting process ID: 0x56c0
Faulting application start time: 0x01d870687c83587a
Faulting application path: C:\Users\alucard\AppData\Local\Temp\AutoUpdater_old.exe
Faulting module path: C:\Windows\System32\KERNELBASE.dll
Report ID: 96e18648-30b5-4528-a263-4d32b11510eb
Faulting package full name: 
Faulting package-relative application ID: 
I'm pretty sure my .net libraries are ok. Windows is fully up to date and sfc /scannow didn't come back with any errors/corruption.

Let me know if you need any other info.

Edit: Here's the stack trace:

Code: Select all

Application: AutoUpdater_old.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.Resources.MissingManifestResourceException at System.Resources.ManifestBasedResourceGroveler.HandleResourceStreamMissing(System.String) at System.Resources.ManifestBasedResourceGroveler.GrovelForResourceSet(System.Globalization.CultureInfo, System.Collections.Generic.Dictionary`2<System.String,System.Resources.ResourceSet>, Boolean, Boolean, System.Threading.StackCrawlMark ByRef) at System.Resources.ResourceManager.InternalGetResourceSet(System.Globalization.CultureInfo, Boolean, Boolean, System.Threading.StackCrawlMark ByRef) at System.Resources.ResourceManager.InternalGetResourceSet(System.Globalization.CultureInfo, Boolean, Boolean) at System.Resources.ResourceManager.GetObject(System.String, System.Globalization.CultureInfo, Boolean) at System.Resources.ResourceManager.GetObject(System.String) at AutoUpdater.Form1.InitializeComponent() at AutoUpdater.Form1..ctor(System.String) at <Module>.main(System.String[]) 

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 21310
Joined: Mon, 15. Nov 04, 00:26
x4

Re: [PROGRAM] X Plugin Manager : V1.61 : 2022-05-25

Post by Cycrow » Wed, 25. May 22, 22:06

its an issue with the auto updater, it should be fixed in 1.61, but obviously it wont work until its installed.

just download the full installer and install over the top

Das Attorney
Posts: 10
Joined: Tue, 13. May 08, 01:55
x3tc

Re: [PROGRAM] X Plugin Manager : V1.61 : 2022-05-25

Post by Das Attorney » Wed, 25. May 22, 22:15

Hi, I've tried all the links on the first page.

The first two download & install 1.60 and the last link is dead (https://mirror.xpluginmanager.co.uk/XPl ... taller.exe)

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 21310
Joined: Mon, 15. Nov 04, 00:26
x4

Re: [PROGRAM] X Plugin Manager : V1.61 : 2022-05-25

Post by Cycrow » Wed, 25. May 22, 22:27

Try it again now, i've reuploaded them

Das Attorney
Posts: 10
Joined: Tue, 13. May 08, 01:55
x3tc

Re: [PROGRAM] X Plugin Manager : V1.61 : 2022-05-25

Post by Das Attorney » Wed, 25. May 22, 22:45

Thanks for the reply.

I downloaded & installed over the top - everything seems to be working ok - I can add fake patches in now.

Just to let you know, my browser (Edge) was keeping something old cached as it kept downloading 1.60 installer. I ended up using Tor Browser which grabbed 1.61.

Thanks again : )

Celle648
Posts: 1
Joined: Thu, 23. Jun 22, 06:58

Re: [PROGRAM] X Plugin Manager : V1.62 : 2022-06-20

Post by Celle648 » Thu, 23. Jun 22, 07:42

Thank you for the awesome Toolpack.

Let me help to fix some bugs I found and hope im not the only suffering to these.
  1. The Plugin Manager sometimes tends to create a TMissile.txt in my addon2/types folder which doesnt contain a few Missiles and two have XTM IDs with an unknown Name (ReadText Not found)
  2. There seems to be a problem with reading or saving the TShips file inside the xsp files.
    When I adapt an old XSP Ship via the Ship Editor from your tools gets, for whatever reason, a more or less random Missile compatibility. Changing, Saving and Installing sometimes work. But dont dare to load the Missile compatibility via the Ship Editor, It'll just rolls it back or rolls a new compatibilty.
    However - I think the "random" missile compatibility seems to be based on the previous Missile compatibility. Meaning that the tool cant correctly "understand" the Missile entry.
    Using the generated file from the Plugin Manager, editing the TShip entry and its compatible Missiles, extracting the Line from the new TShip File and Copy and Paste it manually into the Package Creator.... Doesnt work.
  3. The Plugin Manager sometimes doesnt include installed Ships in the generated TShips (Currently installed 15 Ships ingame loaded 14) (To reproduce - The more the better)
    It doesnt seem to be related to the Ships itself.
    Uninstalling the Ships and reinstalling them in a different order seems to result in different behaviour, so maybe the one ship missing from my list is now appeared and or some other dissappeared
I hope its possible to reproduce these bugs. They are oddly inconsistent.

Update:
#2 is half wrong. I figured out that the XSP File is correct. The file contains the correct informations. But when going to edit the Missile Comp its not correctly loaded.... so Instead of [SG_MISSILE_LIGHT, ...MEDIUM, COUNTER] being selected, it selects [...KHAAK, DISRUPTOR] for example.
I have no clue how the wrong displayed stuff gets into the TShips and into the game. But I didnt tried hard enough to get the source code.

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”