[PROGRAM] X Plugin Manager : 1.60 : 2021-04-10

The place to discuss scripting and game modifications for X³: Farnham's Legacy

Moderators: Scripting / Modding Moderators, Moderators for English X Forum, Moderators for the X3:FL Forums

User avatar
Posts: 2
Joined: Fri, 23. Jul 21, 02:53

Re: [PROGRAM] X Plugin Manager : 1.60 : 2021-04-10

Post by Star-X » Fri, 23. Jul 21, 03:09

Figured I'd chime in my two cents on the update for Linux.

In previous versions, all that was needed to make a wine prefix work with the plugin manager were the winetricks vcrun2008 and dotnet20. Now, though, it needs dotnet40, and even then functionality is wrong.

Specifically, fake patches will not install on the new version with dotnet40. It just stops dead and can't figure out how to install them.

At the moment I'm stuck with having to use the older, dotnet20 compatible version, as no other plugin manager exists that works on Linux. Obviously this means FL isn't moddable :(

I'd really appreciate it if you could maybe set up a Linux VM or WSL2 or something and see about getting the plugin manager to compile using mono. I tried, but that was beyond me. I expect that the actual dev might have a better chance of it tbh.

Posts: 14
Joined: Sun, 28. Feb 10, 13:56

Re: [PROGRAM] X Plugin Manager : 1.60 : 2021-04-10

Post by AzKat » Tue, 3. Aug 21, 12:01

ERROR 404 - Not Found!
The following error occurred:
The requested URL was not found on this server.

Please check the URL or contact the webmaster.

Getting this error when trying to download the plugin manager.

edit: worked after refreshing the page ~6 times

Posts: 9
Joined: Tue, 26. Jul 16, 23:26

Re: [PROGRAM] X Plugin Manager : 1.60 : 2021-04-10

Post by TheCam72 » Mon, 30. Aug 21, 23:24

whenever I try running this plugin exe defender stops it. If I disable defender I just get a message saying I don't have permission and the .exe file disappears from my computer
I really miss my old XP laptop :(

Posts: 3
Joined: Wed, 16. Oct 19, 01:18

Re: [PROGRAM] X Plugin Manager : 1.60 : 2021-04-10

Post by mercelin » Tue, 14. Sep 21, 16:50

I have been having the same issue. I try and run the game on modified and the loader crashes and no game load. I tried to install the old version and update it to the current. The same thing happens for me, nothing. I tried running as admin, also nothing. I run the game normally from steam and the plug-ins are present and my game changed to modified, so why complicate things with a broken launch button...just make us close the program and run normally.

Post Reply

Return to “X³: Farnham's Legacy - Scripts and Modding”