[7.0b533724] Bug - UI issue - Buttons go off screen - Fix in a future build.

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
Fleabum
Posts: 158
Joined: Wed, 24. Dec 03, 21:44
x4

[7.0b533724] Bug - UI issue - Buttons go off screen - Fix in a future build.

Post by Fleabum » Mon, 10. Jun 24, 17:14

Issue - UI is broken when the following is done :-

If you only have the left info panel open it works fine :-
Initiate crew transfer from on ship to another
Click "Show full crew list"
You can see the Confirm and Cancel buttons.

If you open the right info panel and repeat the same steps as above:-
Initiate crew transfer from on ship to another
Click "Show full crew list"
The transfer crew window now expands off the visible part of the window and you cant see the Confirm and Cancel buttons.

Screenshots for all 4 scenarios :-
https://imgur.com/a/A3i3c3O

1 info panel, hide full crew list - Works OK
1 info panel, show full crew list - Works OK
2 info panels, hide full crew list - Works OK
2 info panels, show full crew list - buttons off the page

Fleabum
Posts: 158
Joined: Wed, 24. Dec 03, 21:44
x4

Re: [7.0b533724] Bug - UI issue - Buttons go off screen

Post by Fleabum » Mon, 10. Jun 24, 17:19

If I had to guess where the issue lies, I would say when 1 info panel is open the transfer crew window expands upwards so the buttons stay on screen, but when 2 info panels are open, the transfer crew window is set to expand downwards which pushes it of screen.

Check code for a difference between 1 and 2 info panels open... /shrug

florianlt
EGOSOFT
EGOSOFT
Posts: 1322
Joined: Mon, 22. Aug 11, 14:05
x4

Re: [7.0b533724] Bug - UI issue - Buttons go off screen

Post by florianlt » Wed, 12. Jun 24, 10:38

Cannot reproduce. Please provide a save and tell me your resolution and UI scale setting.

Fleabum
Posts: 158
Joined: Wed, 24. Dec 03, 21:44
x4

Re: [7.0b533724] Bug - UI issue - Buttons go off screen

Post by Fleabum » Wed, 12. Jun 24, 15:58

Hi florianlt,

Resolution is :- 3840 x 2160
UI Scale is:- 1.0

I know its hard to explain these things sometimes just with screenshots, so today I managed to find the time to record a video of the bug in action, I also added my video and game settings at the beginning to assist:-
https://www.dropbox.com/scl/fi/t0lgh2au ... obe7b&dl=0

Here is the game file used in the video:-
https://www.dropbox.com/scl/fi/goub6jag ... grz40&dl=0

I also tried to reproduce on a newer game with less assets and smaller ships and could not do it, but I did see something else weird where the transfer crew window didn't go back to the same location after clicking the Show/Hide full crew button. So this might also be related, but its just effected more on a more full asset list. There is a video of the newer game issue:-
https://www.dropbox.com/scl/fi/qxx7xm6a ... ckwkm&dl=0

Please give me a shout if you need any more background information and/or files/videos.

Regards
Flea

florianlt
EGOSOFT
EGOSOFT
Posts: 1322
Joined: Mon, 22. Aug 11, 14:05
x4

Re: [7.0b533724] Bug - UI issue - Buttons go off screen

Post by florianlt » Fri, 14. Jun 24, 10:30

Thanks, got it reproduced. Fixed in an upcoming build, but probably not for 7.00

Post Reply

Return to “X4: Foundations - Public Beta Feedback”