[6.20 Beta 7] Carrier interception does not work

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
Alexadre4444
Posts: 10
Joined: Sat, 8. Sep 07, 10:49
x4

[6.20 Beta 7] Carrier interception does not work

Post by Alexadre4444 » Wed, 9. Aug 23, 18:28

Hello,

I have encountered an anomaly using the interception with my Shark carrier.

The beta group is set to Interception:
X4_bug_report_no_interception_1.png
X4_bug_report_no_interception_4.png
An enemy trade ship is in sight (17km away only), but the beta group does not undock and attack:
X4_bug_report_no_interception_2.png
X4_bug_report_no_interception_3.png
For information, some other groups are in "Position Defence" (I don't know if there are any links).

Savefile:
https://www.dropbox.com/scl/fi/okwu2qr5 ... 0m7bk&dl=0

j.harshaw
EGOSOFT
EGOSOFT
Posts: 1845
Joined: Mon, 23. Nov 15, 18:02

Re: [6.20 Beta 7] Carrier interception does not work

Post by j.harshaw » Wed, 9. Aug 23, 19:12

Confirmed, and they do engage if their escort behavior is restarted with the target already in sight.

Can you remember at which point you took over control of the carrier?
Do you have a save from shortly before that particular target came into radar range?

Alexadre4444
Posts: 10
Joined: Sat, 8. Sep 07, 10:49
x4

Re: [6.20 Beta 7] Carrier interception does not work

Post by Alexadre4444 » Wed, 9. Aug 23, 20:53

I do not have an earlier savegame.

I often use the launched/docked toggle before moving my Shark. What I remember is (I'm not sure of all the steps):
* After destroying the defence station, I set all the group to docked
* I launch the position defence
* I removed Beta, Gamma and Zeta groups from defence position (I put them back to "Interception", "Supply" and "Bombardment")
* I've put groups Alpha and Beta to "Launched"

I've got a bit of time tomorrow, so I'll try to reproduce it.

j.harshaw
EGOSOFT
EGOSOFT
Posts: 1845
Joined: Mon, 23. Nov 15, 18:02

Re: [6.20 Beta 7] Carrier interception does not work

Post by j.harshaw » Fri, 11. Aug 23, 10:53

Tried to repro by bringing a carrier with subordinates set to Docked to within radar range of hostile ships, then setting subordinates to Launched. Subordinates correctly launched to engage, so will need a reliable repro to investigate further.

Scoob
Posts: 9908
Joined: Thu, 27. Feb 03, 22:28
x4

Re: [6.20 Beta 7] Carrier interception does not work

Post by Scoob » Fri, 11. Aug 23, 13:13

Something similar is happening in my current v6.10 game, but might have some relevance...

I'm using Carriers a lot, so am burning through Fighters as a result, leading to my having to reinforce wings from time to time. There is an issue that occurs that prevents ship launching to Intercept, and I'll give an example of the sequence of events:

Let's say a Carrier has an Alpha Group of 10 Fighters, set to Intercept and Launched. They perform their duties perfectly, no issues.

After some time, through general attrition, Alpha Group is down from 10 to 5 Fighters, so I assign 5 more to reinforce the group (I build my own Fighters, so it's easy). They arrive, dock at the carrier and I think I'm good.

However, those new 5 Fighters will NOT launch to Intercept with the original 5. As those original 5 get whittled away - they're at half strength of course - I reinforce with (eventually) another 5. At this point Alpha group no longer launches to Intercept at all.

To be clear, I'm NOT ordering the reinforcements to DOCK at the Carrier (which would be a blocker to them launching automatically) rather I am simply assigning them, having been just freshly built.

The Fix / Work-around? Simply toggle Alpha group's Launched / Docked status from Launched to Docked and back to Launched again. At this point, Alpha group will wake up and all 10 Fighters will launch to Intercept as they should.

This behaviour has been consistent for me, but I didn't initially realise what was happening. Perhaps it is of some relevance to the issue at hand?

Alexadre4444
Posts: 10
Joined: Sat, 8. Sep 07, 10:49
x4

Re: [6.20 Beta 7] Carrier interception does not work

Post by Alexadre4444 » Fri, 11. Aug 23, 13:20

Hello guys,

I was unable to reproduce the anomaly again. However, I did encounter other strange anomalies just afterwards (all my ships in Defence position received an attack order around my carrier after killing a target). I tried to reproduce it reliably, but without success either. I'll keep watching and testing. If I get a reliable way to reproduce, I'll repost a save.

Regarding Scoob's comment, I don't remember adding any new ships to the group before the anomaly arrived. The symptoms seem to be the same, but not the origin.

Post Reply

Return to “X4: Foundations - Public Beta Feedback”