[6.10 509827] Double music track playing throughout the entire game

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
Vokial
Posts: 4
Joined: Fri, 23. Sep 22, 17:25
x4

[6.10 509827] Double music track playing throughout the entire game

Post by Vokial » Tue, 8. Aug 23, 22:27

Hello everybody,
since when I purchased the Kingdom End expansion I have been experiencing this weird issue: every time I start the game (as soon as I click "play" on Steam) the main theme of Kingdom End starts and it overlaps every other sound and music track in the game:
- It overlaps the sound effect of the Egosoft logo
- It still plays during loading screens and normal play, overlapping the dynamic music
- The "music" volume slider in the option menu only affects the "correct" music track (the dynamic one, that I can mute if I want to) but not the overlapping one
- it still plays whenever I exit the game, during the short moment between the app closing (showing Windows desktop) and Steam "releasing" the play button to green.. and it just stops when Steam aknowledges the application is closed with the green play button.

By "main theme" I mean the music track you hear in the K.E. trailer that's on Steam
I have 100+ hours in this game on Steam and this issue only started to appear after I bought Kingdom End, some days ago (I already owned the other three DLCs)

Here's what I already tried, with no success:
A full re-install of the game (completely removing the Egosoft folder in my documents)
I deactivated the Kingdom End dlc from the game menu
I deactivated the Kingdom End dlc from the "manage dlc" area of Steam
I uninstalled all mods (both from the Steam workshop and the other ones)
I tried version beta 6.20 - 6

Quick review of my pc specs:
AMD Ryzen 5 3600
32Gb Ram
Nvidoa RTX 3060 Ti (non OC'd)
Win 10
the game is installed on a SSD drive
I have an additional USB audio card that I use as the main one, but I tried to disconnect that too with no improvement

Do you guys have any idea on why this is happening?
I have searched this forum for help but I couldn't find any on my specific issue.

Thanks a lot, any help is appreciated!

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 30308
Joined: Fri, 16. Apr 04, 19:21
x4

Re: [6.10 509827] Double music track playing throughout the entire game

Post by Alan Phipps » Tue, 8. Aug 23, 22:56

Somebody else had a similar issue but did not come back again, so we cannot see what you may have had in common.

Just for elimination purposes, have you ever played Stalker with the Anomaly mod?
A dog has a master; a cat has domestic staff.

Vokial
Posts: 4
Joined: Fri, 23. Sep 22, 17:25
x4

Re: [6.10 509827] Double music track playing throughout the entire game

Post by Vokial » Tue, 8. Aug 23, 23:34

Hello Alan, thanks for your reply.
I actually saw the thread you linked, and it was that one that gave me the idea of cleaning both the Steam game folder and the Egosoft folder, among other tests...
By "Stalker with the Anomaly mod" you mean Stalker the fps game? If that's that, then no, I have never played it :-/
Does it have something to do with my issue?

Vokial
Posts: 4
Joined: Fri, 23. Sep 22, 17:25
x4

Re: [6.10 509827] Double music track playing throughout the entire game

Post by Vokial » Wed, 9. Aug 23, 01:39

Here's an update: I made it work.
I've had the Steam cloud savegames active, which not only backups the save games but also a lot of configuration files. I turned off that feature, deleted the Egosoft folder inside my Documents and started the game again. It worked, no more double music track..
I wouldn't call this a fix because I had to ditch all my configurations and start again the game entirely, but still I got it working again.. and that explains why the complete reinstall didn't work in the first place.
What happened probably is that I had some very old saves (either game saves or config saves) that got into some sort of conflict with the new code added by Kingdom End and caused that issue.

Anyway.. I'm fine with starting it all over again, it's a sandbox game after all :) I'm sorry I couldn't find any other way around this issue for the people who don't want to lose their saves/configuration though..

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 30308
Joined: Fri, 16. Apr 04, 19:21
x4

Re: [6.10 509827] Double music track playing throughout the entire game

Post by Alan Phipps » Wed, 9. Aug 23, 10:04

That Stalker game mod permanently messes with OpenAL settings and so adversely affects sound and music playback in other games too.

Do you still have your old X4 config file and save? The sound/music devs might wish to take a look if they have time to check them.
A dog has a master; a cat has domestic staff.

Vokial
Posts: 4
Joined: Fri, 23. Sep 22, 17:25
x4

Re: [6.10 509827] Double music track playing throughout the entire game

Post by Vokial » Wed, 9. Aug 23, 12:42

Oh, right, I undestand the issue with Stalker. As far as I remember, I've never played that game at all.
About OpenAL: I'm not sure whether this could be helpful or not, but I use the same PC to do some audio recording/editing with Cubase. Probably unrelated to this specific issue, but since we are talking about audio problems I thought it could be worth mentioning.

As for the old files, yes I do. I have backed up my whole Egosoft folder (the one in my Documents. I can send them to you with WeTransfer (it's about 500Mb because of the save files) or some other way.. let me know!

Post Reply

Return to “X4: Foundations - Public Beta Feedback”