[#1411][6.20 Beta] shipbuilding blockage - Fix in a build after 6.20 b6.

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
Jedi Pitter
Posts: 218
Joined: Thu, 7. Oct 04, 23:36
x4

[#1411][6.20 Beta] shipbuilding blockage - Fix in a build after 6.20 b6.

Post by Jedi Pitter » Thu, 3. Aug 23, 01:02

In the 6.20 beta I have the following problem:
If I have more ships built in the dock than there are building sites available, the built ships no longer automatically leave the dock and the construction of further ships comes to a halt.
This has already been discussed in the German forum.
möge der Spaß mit uns sein

User avatar
BurnIt!
EGOSOFT
EGOSOFT
Posts: 5063
Joined: Wed, 6. Nov 02, 20:31
x4

Re: [6.20 Beta] shipbuilding

Post by BurnIt! » Thu, 3. Aug 23, 10:03

Please provide the information requested in the pinned thread at the top of this forum:
Public Beta Rules and Information - PLEASE READ THIS BEFORE YOU POST

For this case we are especially going to need a save and clear description of which station/ships to look for that allows us to replicate the situation.
BurnIt!
In der Ruhe liegt die Kraft. / In peace lies strength.

Jedi Pitter
Posts: 218
Joined: Thu, 7. Oct 04, 23:36
x4

Re: [6.20 Beta] shipbuilding

Post by Jedi Pitter » Fri, 4. Aug 23, 12:13

BurnIt! wrote:
Thu, 3. Aug 23, 10:03
Please provide the information requested in the pinned thread at the top of this forum:
Public Beta Rules and Information - PLEASE READ THIS BEFORE YOU POST

For this case we are especially going to need a save and clear description of which station/ships to look for that allows us to replicate the situation.
There are 8 building sites in the dock; Construction order of 20 ships; 8 ships are built and do not automatically leave the dock; Further ship building will not continue until the completed 8 ships leave the dock with order.
In changelog 5 this was fixed for capital ships, but it also affects S/M ships!!! (at least for me (changelog 6))
möge der Spaß mit uns sein

CBJ
EGOSOFT
EGOSOFT
Posts: 51648
Joined: Tue, 29. Apr 03, 00:56
x4

Re: [6.20 Beta] shipbuilding

Post by CBJ » Sat, 5. Aug 23, 16:59

BurnIt! wrote:
Thu, 3. Aug 23, 10:03
...we are especially going to need a save and clear description of which station/ships to look for that allows us to replicate the situation.

User avatar
BurnIt!
EGOSOFT
EGOSOFT
Posts: 5063
Joined: Wed, 6. Nov 02, 20:31
x4

Re: [6.20 Beta] shipbuilding

Post by BurnIt! » Mon, 7. Aug 23, 12:11

Your original report didn't even mention that you were talking about S/M ships - you posted in a thread about capital ships saying the fix for that issue didn't work.
Also I did just test it and as long as resources are available the construction continues. The S/M Fabrication Bay has internal storage capacity (100 S and 30 M ships) and even though there can only be 8 construction tasks active at the same time the number of visible dock slots does not limit that. Ships will be moved to internal storage and only when the internal storage capacity is also exhausted, then ships will start to undock to make room for additional constructions.

That's working exactly as designed - if you are experiencing something else, then please provide an unmodified savegame that demonstrates the issue or we will be unable to help you.
BurnIt!
In der Ruhe liegt die Kraft. / In peace lies strength.

Alexadre4444
Posts: 10
Joined: Sat, 8. Sep 07, 10:49
x4

Re: [6.20 Beta] shipbuilding

Post by Alexadre4444 » Mon, 7. Aug 23, 12:53

Hello,

I think I have the same problem with M ships, using a Boron shipyard.

I have a Boron station with two S/M shipyards. I am building 20 Dolphins, 12 are created and remain docked. I have to move them manually.

Save file (at the end of construction):
https://www.dropbox.com/scl/fi/bfrpz56y ... u9k5r&dl=0

User avatar
BurnIt!
EGOSOFT
EGOSOFT
Posts: 5063
Joined: Wed, 6. Nov 02, 20:31
x4

Re: [#1411][6.20 Beta] shipbuilding blockage

Post by BurnIt! » Tue, 8. Aug 23, 16:29

Thank you for the save, this was helpful and allowed me to identify what was happening here.
A fix for the issue should be included in an upcoming build.
BurnIt!
In der Ruhe liegt die Kraft. / In peace lies strength.

Alexadre4444
Posts: 10
Joined: Sat, 8. Sep 07, 10:49
x4

Re: [#1411][6.20 Beta] shipbuilding blockage - Fix in a build after 6.20 b6.

Post by Alexadre4444 » Wed, 9. Aug 23, 16:59

Hello,
I tried the fix with beta 7.
When finished, the ships went into internal storage and released the docking bays --> fixed

But I have a question (maybe a new bug?): The ships are built using standard docking bays, not S/M construction bays (I don't know if that's clear...), is that normal?

Screen:
X4_bug_report_building.png
Save file:
https://www.dropbox.com/scl/fi/bfrpz56y ... u9k5r&dl=0

Post Reply

Return to “X4: Foundations - Public Beta Feedback”