[6.20b6] from Company Regard to Jupiter: fly and wait uses travel drive, attack skips travel drive

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
rudi_pioneer
Posts: 378
Joined: Fri, 2. Apr 21, 21:06
x4

[6.20b6] from Company Regard to Jupiter: fly and wait uses travel drive, attack skips travel drive

Post by rudi_pioneer » Wed, 2. Aug 23, 18:52

See ~100 ships in save with current attack orders: located in company regard, ordered to attack station in Jupiter, ships move using normal travel only. If ordered to fly and wait, travel drive will work correctly.

I noticed this earlier when fighting in ZYA sectors, but wanted to make more specific test case that covers large number of gate jumps.

Save: https://www.dropbox.com/s/altyk1a8qjpr0 ... ml.gz?dl=0

(this is similar issue to viewtopic.php?f=192&t=456876, but here specifically covering large multi-gate travel case)

|-|Mohawk|-|
Posts: 94
Joined: Mon, 9. Jan 12, 06:29
x4

Re: [6.20b6] from Company Regard to Jupiter: fly and wait uses travel drive, attack skips travel drive

Post by |-|Mohawk|-| » Fri, 11. Aug 23, 02:15

I have also experienced this (currently playing on beta 7).

For me it seems to only happen with L ships ordered to attack a station several sectors away. If I order an M ship to attack another ship, it will engage travel drive as expected to reach its target. But if I order a destroyer to attack a station in another sector, it will not engage travel drive.
Autopilot epically failed.

Post Reply

Return to “X4: Foundations - Public Beta Feedback”