[v4 beta 11 hf1] Game unresponsive after circa 5 hours - Seems resolved now.

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
User avatar
alt3rn1ty
Posts: 1225
Joined: Thu, 26. Jan 06, 20:45
x4

[v4 beta 11 hf1] Game unresponsive after circa 5 hours - Seems resolved now.

Post by alt3rn1ty » Fri, 12. Mar 21, 03:45

This may be a hard to repro' issue, but need to mention it as it's not the first time I have seen this problem during the v4 betas :

First save file - https://www.dropbox.com/s/xp00l480usixs ... ml.gz?dl=0

You may have received an auto upload of a crash dump yesterday (11th March - Somewhere between 13:49 - 14:10 UK GMT time).
I say "may have", because when I got back to the machine the game had become totally unresponsive, and all I could do was use task manager to shut it down.
I think the time you would have received it is probably about correct because I have auto saves at 40 minutes, and the above auto-save was the last one created before the crash.

Also note my laptop (see signature) seems to be running a little warmer with beta 11 HF1 and HF2 than is usual prior to this update.

Note also this crash happened with HF1 installed, before I got home and noticed afterwards HF2 was ready to download.

Issue = Run the game for no less than 5 hours (maybe more), with the above save installed, on a laptop machine with similar spec to my machine.

No need to change or do anything; I started the game with HF1 installed, and due to supporting elderly family members shielding from covid I had to leave the house which turned into a 7 hour absence, when I got back I found the game had become totally unresponsive.

I have seen this happen before under similar circumstances, where I had to leave the house for 7 hours and came back to an unresponsive game which could only be shut down with task manager. I have also seen other people reporting similar occurrences, so I believe this is probably some kind of instability which only manifests after a number of hours of not touching the keyboard and just letting the game play itself.
Laptop Dell G7 7590 : Win 10 x64
CPU 9th Gen' Core I7 9750H 4.5ghz,
GPU NVidia Geforce GTX 1650, VRAM 4gb GDDR5,
RAM Corsair Vengeance 32gb (2x16gb Dual Channel) DDR4 2666mhz,
Samsung 970 Evo Plus M.2 NVME 500gb + Dell 512gb SSDs' (both Internal)

User avatar
spankahontis
Posts: 3077
Joined: Tue, 2. Nov 10, 22:47
x4

Re: [v4 beta 11 hf1] Game unresponsive after circa 5 hours

Post by spankahontis » Fri, 12. Mar 21, 15:48

alt3rn1ty wrote:
Fri, 12. Mar 21, 03:45
This may be a hard to repro' issue, but need to mention it as it's not the first time I have seen this problem during the v4 betas :

First save file - https://www.dropbox.com/s/xp00l480usixs ... ml.gz?dl=0

You may have received an auto upload of a crash dump yesterday (11th March - Somewhere between 13:49 - 14:10 UK GMT time).
I say "may have", because when I got back to the machine the game had become totally unresponsive, and all I could do was use task manager to shut it down.
I think the time you would have received it is probably about correct because I have auto saves at 40 minutes, and the above auto-save was the last one created before the crash.

Also note my laptop (see signature) seems to be running a little warmer with beta 11 HF1 and HF2 than is usual prior to this update.

Note also this crash happened with HF1 installed, before I got home and noticed afterwards HF2 was ready to download.

Issue = Run the game for no less than 5 hours (maybe more), with the above save installed, on a laptop machine with similar spec to my machine.

No need to change or do anything; I started the game with HF1 installed, and due to supporting elderly family members shielding from covid I had to leave the house which turned into a 7 hour absence, when I got back I found the game had become totally unresponsive.

I have seen this happen before under similar circumstances, where I had to leave the house for 7 hours and came back to an unresponsive game which could only be shut down with task manager. I have also seen other people reporting similar occurrences, so I believe this is probably some kind of instability which only manifests after a number of hours of not touching the keyboard and just letting the game play itself.

I have to agree, this game falls apart after 2-5 hours of gameplay. Things i've noticed.

- Takes forever to get through static when comming an NPC cause it's struggling to load the NPC and Ship Background.
- Zyarth Patriarchy stops giving me positive rep for enemy ship/traffic kills (Reloading Game fixes that I get stacks of rep points coming in.)
- Animation for sitting Co-Pilots either spawns in the controls, will float away still in sitting pose or just skip that part of the pathfinding and teleport them into the crew quarters Or they don't move at all and I burrow into their bodies and take control of ship (Still seeing their Hands until they vanish.
- Significant Frame Rates drop no matter what Graphic settings you have, only minor improvements by reducing graphic quality.
- Freighters wont trade with my Construction projects no matter how much money and available resources are available, some freighter appear in the incoming resources section of the Build screen but they never arrive, under a day of gameplay I waited. I checked everything to see whether the mistake was on my side, everything was kosher but still the freighter on the manifest was screwing around with me.
- Schroedinger's Ships, i've seen ships near my HQ after delivering wares suddenly phase shift from one point in space to the other instantly, eventually they break out of it, you even see it on the map, icons of ships moving point A to B instantly flickering from each point for a minute or 2 before moving on their way.

The game falls apart and it's going to be released this coming Monday Afternoon with Cradle of Humanity in this state?
I can only see a 4.20 coming shortly after release cause these bugs are noticeable and are ruining my enjoyment of the game.
Ragna-Tech.. Forging a Better Tomorrow!

My most annoying Bugs list 4.10 Release Beta 3 + [All DLC]
--------------------------------
Xenon Abandon Defense Stations Fixed! :mrgreen:
SETA around Spear of Odin = Crazy Jiggling Trap :evil:
Fires of Defeat Game Start Pilot stuck in ship Still happens.
Story Mission HQ Spawn Bug Still there.
Poor optimization of current build leads to a ton of problems Somewhat improved.

Bawlislaf
Posts: 55
Joined: Sat, 14. Feb 04, 15:58
x4

Re: [v4 beta 11 hf1] Game unresponsive after circa 5 hours

Post by Bawlislaf » Sat, 13. Mar 21, 16:54

"- Significant Frame Rates drop no matter what Graphic settings you have, only minor improvements by reducing graphic quality." - sounds an awful lot like GPU driver is overruling the game settings.

As for performance drops after a long session:
I did encounter slight performance drops when being docked on a large station for a significant amount of time. (talking hundreds of modules and several hours of being afk)
These problems usually resolve itself by leaving the sector, which makes me think it might be an accumulation of wreckages in said sector.

Overall the beta patch has been stable for me even in ~8 hours long gaming sessions.
However i will note that i had to adjust my settings since the introduction of volumetric fog, as my GTX 1080ti is a bit on the older side and i refuse to play on a resolution lower than 4k. :wink:

User avatar
spankahontis
Posts: 3077
Joined: Tue, 2. Nov 10, 22:47
x4

Re: [v4 beta 11 hf1] Game unresponsive after circa 5 hours

Post by spankahontis » Sat, 13. Mar 21, 21:43

dead-comes wrote:
Sat, 13. Mar 21, 16:54
"- Significant Frame Rates drop no matter what Graphic settings you have, only minor improvements by reducing graphic quality." - sounds an awful lot like GPU driver is overruling the game settings.

As for performance drops after a long session:
I did encounter slight performance drops when being docked on a large station for a significant amount of time. (talking hundreds of modules and several hours of being afk)
These problems usually resolve itself by leaving the sector, which makes me think it might be an accumulation of wreckages in said sector.

Overall the beta patch has been stable for me even in ~8 hours long gaming sessions.
However i will note that i had to adjust my settings since the introduction of volumetric fog, as my GTX 1080ti is a bit on the older side and i refuse to play on a resolution lower than 4k. :wink:
1080 Titan, no wonder you're not seeing that many issues.
I have a 1060 6GB, It's set my default on High Settings, not Ultra.
But I don't share your views here, none of these problems were happening until a few Betas in, it's been steadily getting worse.
So either i'm seeing the limits of my computer with the new features being introduced? Or this Beta needs allot more patching before they role it out on Monday afternoon.
Ragna-Tech.. Forging a Better Tomorrow!

My most annoying Bugs list 4.10 Release Beta 3 + [All DLC]
--------------------------------
Xenon Abandon Defense Stations Fixed! :mrgreen:
SETA around Spear of Odin = Crazy Jiggling Trap :evil:
Fires of Defeat Game Start Pilot stuck in ship Still happens.
Story Mission HQ Spawn Bug Still there.
Poor optimization of current build leads to a ton of problems Somewhat improved.

User avatar
alt3rn1ty
Posts: 1225
Joined: Thu, 26. Jan 06, 20:45
x4

Re: [v4 beta 11 hf1] Game unresponsive after circa 5 hours

Post by alt3rn1ty » Mon, 22. Mar 21, 00:55

@Devs

I noticed you had some fixes for crashes in the beta after this post, and more for the hotfix after v4 was released ..

.. Have tested quite a bit now during that time and cannot reproduce the game becoming unresponsive.

Right now I have the game running and its been running for just shy of 24 hours. During that time I have done quite a few Terran covert missions, alt tabbed out and back into the game after using browser and other desktop apps (like now while typing this post), changed screens resolution and window / full screen mode a few times .. And continued playing the same session all the way through.

It seems very stable in the current public build (from my POV anyway) :)
Laptop Dell G7 7590 : Win 10 x64
CPU 9th Gen' Core I7 9750H 4.5ghz,
GPU NVidia Geforce GTX 1650, VRAM 4gb GDDR5,
RAM Corsair Vengeance 32gb (2x16gb Dual Channel) DDR4 2666mhz,
Samsung 970 Evo Plus M.2 NVME 500gb + Dell 512gb SSDs' (both Internal)

Post Reply

Return to “X4: Foundations - Public Beta Feedback”