[3.10+dlc hf1] - Accelerator sent me and my Ides 22500.0kms off course

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
User avatar
spankahontis
Posts: 2879
Joined: Tue, 2. Nov 10, 22:47
x4

[3.10+dlc hf1] - Accelerator sent me and my Ides 22500.0kms off course

Post by spankahontis » Sun, 19. Apr 20, 16:37

I went through the Accelerator Gate in Second Contact II Flashpoint to Second Contact VII with an Ides Vanguard following me, doing a deliver freighter mission for Antigone Trade Guild.
Went through the accelerator and as you can see, it has flung me 22500.0kms off course.

I've got a journey ahead of me.

Savefile
https://www.dropbox.com/s/xljzy9uy7tk82 ... y.zip?dl=0
Ragna-Tech.. Forging a Better Tomorrow!

My most annoying Bugs list 3.20 + Split Vendetta dlc HF 1
--------------------------------
Stuck in the Eclipse Vanguard Wall when getting up :rant:
Accelerator sends me 22500.0kms off course! UNRESOLVED? :gruebel:

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 22572
Joined: Fri, 16. Apr 04, 19:21
x4

Re: [3.10+dlc hf1] - Accelerator sent me and my Ides 22500.0kms off course

Post by Alan Phipps » Sun, 19. Apr 20, 17:43

With an NPC pilot and you as passenger, or with you piloting?

Either way, I think both are well known and reported, probably with a fix coming.
A dog has a master; a cat has domestic staff.

User avatar
spankahontis
Posts: 2879
Joined: Tue, 2. Nov 10, 22:47
x4

Re: [3.10+dlc hf1] - Accelerator sent me and my Ides 22500.0kms off course

Post by spankahontis » Mon, 20. Apr 20, 01:38

Myself as pilot, but I think I was in autopilot looking at sector map when this happened?
Ragna-Tech.. Forging a Better Tomorrow!

My most annoying Bugs list 3.20 + Split Vendetta dlc HF 1
--------------------------------
Stuck in the Eclipse Vanguard Wall when getting up :rant:
Accelerator sends me 22500.0kms off course! UNRESOLVED? :gruebel:

User avatar
Putmacher
Posts: 45
Joined: Thu, 28. Sep 06, 20:32
x4

Re: [3.10+dlc hf1] - Accelerator sent me and my Ides 22500.0kms off course

Post by Putmacher » Mon, 20. Apr 20, 16:47

similar issue also here: viewtopic.php?f=192&t=425324

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 22572
Joined: Fri, 16. Apr 04, 19:21
x4

Re: [3.10+dlc hf1] - Accelerator sent me and my Ides 22500.0kms off course

Post by Alan Phipps » Mon, 20. Apr 20, 16:56

It has been pointed out to me that a potential fix to this sort of issue with the AI flying the ship (NPC pilot - and maybe even the player but with autopilot on) is coming in a future build, but that the same issue with the player actively and directly piloting the ship has not yet been fully replicated and resolved using the devs' system.

The problem the devs face is that they need both a vanilla save made just before it reliably *will* happen (where that can be predicted or captured), and they need their own system to replicate the issue from that save and so demonstrate the failure mechanism.
A dog has a master; a cat has domestic staff.

Post Reply

Return to “X4: Foundations - Public Beta Feedback”