[3.0 Beta 3] Issue With Job Engine and GOD - Explained.

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
User avatar
RoverTX
Posts: 1176
Joined: Wed, 16. Nov 11, 19:37
x4

[3.0 Beta 3] Issue With Job Engine and GOD - Explained.

Post by RoverTX » Fri, 6. Dec 19, 01:31

Non modified game end up with an error for one of the new jobs not being able to find zones.

Code: Select all

[JobEngine] JobID: 'holyorder_corvette_elite_m' no zones in galaxy found, error in map?
There are also reports of new jobs or stations in the GOD file added by mods not finding their zones even though they reference the same zones as other jobs.

iforgotmysocks
Posts: 1205
Joined: Fri, 8. Nov 13, 23:35
x4

Re: Issue With Job Engine and GOD

Post by iforgotmysocks » Fri, 6. Dec 19, 01:33

Not just an issue with zones, any type of space can't be found, also sectors or clusters.

User avatar
Shuulo
Posts: 1204
Joined: Mon, 14. Apr 08, 17:03
x4

Re: Issue With Job Engine and GOD

Post by Shuulo » Fri, 6. Dec 19, 10:42

I can confirm this.
Adding new jobs via mod that are mostly copy-paste of vanilla one (just the name changed) is not working.

CBJ
EGOSOFT
EGOSOFT
Posts: 39275
Joined: Tue, 29. Apr 03, 00:56
x4

Re: Issue With Job Engine and GOD

Post by CBJ » Fri, 6. Dec 19, 11:05

RoverTX wrote:
Fri, 6. Dec 19, 01:31
Non modified game end up with an error for one of the new jobs not being able to find zones.

Code: Select all

[JobEngine] JobID: 'holyorder_corvette_elite_m' no zones in galaxy found, error in map?
I'm not seeing this error starting the game. Which gamestart are you using? And are you 100% sure that your game is not modified (noting that a savegame which has been used with mods in the past remains modified, even if the mods are subsequently disabled)?

User avatar
RoverTX
Posts: 1176
Joined: Wed, 16. Nov 11, 19:37
x4

Re: [3.0 Beta 3] Issue With Job Engine and GOD

Post by RoverTX » Fri, 6. Dec 19, 15:50

Here is the save. And yes checked to make sure all mods are turned off and no modified flag.

https://forums-rover.s3.amazonaws.com/3 ... ave.xml.gz

j.harshaw
EGOSOFT
EGOSOFT
Posts: 1062
Joined: Mon, 23. Nov 15, 19:02

Re: [3.0 Beta 3] Issue With Job Engine and GOD

Post by j.harshaw » Fri, 6. Dec 19, 17:19

Thanks for the save. Debug output is normal in this case and only serves as information.

That particular job is set up to be created only if Cluster_11_Sector001_macro (Pontifex's Claim) belongs to HOL. In the save, that sector belongs to PAR so the job engine will not create ships for that job.

User avatar
Shuulo
Posts: 1204
Joined: Mon, 14. Apr 08, 17:03
x4

Re: [3.0 Beta 3] Issue With Job Engine and GOD

Post by Shuulo » Fri, 6. Dec 19, 17:59

j.harshaw wrote:
Fri, 6. Dec 19, 17:19
Thanks for the save. Debug output is normal in this case and only serves as information.
Thanks for explaining that issue. I have another problem, I added the below job back in version 2.0 of X4, it worked fine till 3.0. Though in 3.0 it simply does not work, ships are never to be seen in the game. Maybe you can point out something?

Code: Select all

<job id="argon_battleship_patrol_xl_sector_exp" name="{20221,5031}" comment="each sector, expansion">
		<modifiers commandeerable="false"/>
		<orders>
			<order order="Patrol" default="true">
       		 <param name="range" value="class.sector"/>
			</order>
		</orders>
		<category faction="argon" tags="[factionlogic, military, battleship]" size="ship_xl"/>
		<quota galaxy="10" sector="1"/>
   		 <location class="galaxy" macro="xu_ep2_universe_macro" faction="argon" relation="self" comparison="exact"/>
		<environment buildatshipyard="true"/>
		<ship>
			<select faction="argon" tags="[military, battleship]" size="ship_xl"/>
			<loadout>
				<level min="0.85" max="1.0"/>
			</loadout>
			<owner exact="argon" overridenpc="true"/>
		</ship>
		<subordinates>
			<subordinate job="argon_frigate_escort_m"/>
		</subordinates>
	  </job>
Also, in modding community we already found out that custom stations are not added with the error message below, however mod was not updated and it worked fine in 2.6

Code: Select all

[=ERROR=] 0.00 [God Engine] God Entry ID: 'shipyard_sca_02' no sectors in galaxy found, error in map?
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 [God Engine] God Entry ID: 'wharf_sca_01' no sectors in galaxy found, error in map?
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 [God Engine] God Entry ID: 'wharf_sca_02' no sectors in galaxy found, error in map?
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 [God Engine] God Entry ID: 'shipyard_sca_01' no sectors in galaxy found, error in map?
Please let us know what info we can provide should provide to tackle this issue. Thank you in advance!

CBJ
EGOSOFT
EGOSOFT
Posts: 39275
Joined: Tue, 29. Apr 03, 00:56
x4

Re: [3.0 Beta 3] Issue With Job Engine and GOD

Post by CBJ » Wed, 18. Dec 19, 15:44

I know you've already had an answer to this privately, but for the benefit of any other modders adding job/god entries, I've now explained the reason you were having problems in the Breaking Changes documentation.

"To better support extensions which add to the base game map, a job/god entry now defaults to only spawning objects in areas of the map that are added by the extension in which that entry is defined. You can override this behaviour by adding a matchextension="false" attribute to the job/god entry definition. This allows the entry to spawn objects anywhere that matches the entry's other criteria."

Hope this helps.

Max Bain
Posts: 931
Joined: Wed, 27. Jun 18, 19:05
x3ap

Re: [3.0 Beta 3] Issue With Job Engine and GOD

Post by Max Bain » Fri, 20. Dec 19, 20:56

CBJ wrote:
Wed, 18. Dec 19, 15:44
I know you've already had an answer to this privately, but for the benefit of any other modders adding job/god entries, I've now explained the reason you were having problems in the Breaking Changes documentation.

"To better support extensions which add to the base game map, a job/god entry now defaults to only spawning objects in areas of the map that are added by the extension in which that entry is defined. You can override this behaviour by adding a matchextension="false" attribute to the job/god entry definition. This allows the entry to spawn objects anywhere that matches the entry's other criteria."

Hope this helps.
Hm can you tell me whats wrong with such a job?

Code: Select all

	
<diff>	
	<add sel="//jobs">
	  <job id="argon_battleship_patrol_xl_sector_01" name="{88100,00001}" comment="each sector, expansion" matchextension="false">
		<modifiers commandeerable="false"/>
		<orders>
			<order order="Patrol" default="true">
       		 <param name="range" value="class.sector"/>
			</order>
		</orders>
		<category faction="argon" tags="[factionlogic, military, battleship]" size="ship_xl"/>
		<quota galaxy="10" sector="1"/>
   		 <location class="galaxy" macro="xu_ep2_universe_macro" faction="argon" relation="self" comparison="exact"/>
		<environment buildatshipyard="true"/>
		<ship>
			<select faction="argon" tags="[military, battleship]" size="ship_xl"/>
			<loadout>
				<level min="0.85" max="1.0"/>
			</loadout>
			<owner exact="argon" overridenpc="true"/>
		</ship>
		<subordinates>
			<subordinate job="argon_frigate_escort_m"/>
		</subordinates>
	  </job>
	</add>
</diff>
It still says

Code: Select all

[=ERROR=] 0.00 [JobEngine] JobID: 'argon_battleship_patrol_xl_sector_01' no zones in galaxy found, error in map?
in the log file.

Because
X4 Editor (view stats of objects and make your own mod within a few clicks) viewtopic.php?f=181&t=421306
XR Ship Pack (adds several ships from XR) viewtopic.php?f=181&t=419641
Weapon Pack (adds several new weapons) viewtopic.php?f=181&t=421266

Max Bain
Posts: 931
Joined: Wed, 27. Jun 18, 19:05
x3ap

Re: [3.0 Beta 3] Issue With Job Engine and GOD

Post by Max Bain » Fri, 20. Dec 19, 22:34

edited. Had an error in the xml file.
X4 Editor (view stats of objects and make your own mod within a few clicks) viewtopic.php?f=181&t=421306
XR Ship Pack (adds several ships from XR) viewtopic.php?f=181&t=419641
Weapon Pack (adds several new weapons) viewtopic.php?f=181&t=421266

j.harshaw
EGOSOFT
EGOSOFT
Posts: 1062
Joined: Mon, 23. Nov 15, 19:02

Re: [3.0 Beta 3] Issue With Job Engine and GOD

Post by j.harshaw » Sat, 21. Dec 19, 00:22

matchextension="false" should be added to the location node.

Code: Select all

<location class="galaxy" macro="xu_ep2_universe_macro" faction="argon" relation="self" comparison="exact" matchextension="false"/>

Post Reply

Return to “X4: Foundations - Public Beta Feedback”