[4.20 Beta 3] Crew transfer when docked very slow / unreliable

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
Scoob
Posts: 8307
Joined: Thu, 27. Feb 03, 23:28
x4

[4.20 Beta 3] Crew transfer when docked very slow / unreliable

Post by Scoob » Sat, 27. Nov 21, 17:03

Hi,

I'm hoping this will be an easy one to replicate.

It seems that crew transfer *in space* happens very quickly now it's no longer reliant on the Pods actually docking. Usually, the crew is available in the new location long before the Pods dock. This has effectively negated the old issue where it'd get stuck.

However, oddly, I'm noticing that doing a crew transfer when one ship is docked to another is VERY slow. I docked an S-Class ship to an L-Class ship and ordered crew to transfer from the L-Class to the S-Class - just three Marines, I'm going to send the S-Class ship to claim some bailed vessels. However, over five minutes later the transfer has still not finished. Usually in-space transfers are completed easily within a Minute.

In essence, it's faster to undock a ship, then issue a crew transfer - pod used - than it is to issue the crew transfer while the ship is docked.

To recreate what I see, take the following step:

1) Dock an S-Class ship, with crew capacity to an L-Class ship with some Crew.
2) Issue a regular Crew Transfer command, transferring some crew from the L-Class to the S-Class. I used Marines.
3) Wait...I've been waiting close to ten minutes now and it's not competing.

Note: In a second test both ships were FULL, so I issued a parallel crew transfer. Three Service Crew from one, three Marines from the other. The Marines transferred from the S-Class to the L-Class just fine. The Service Crew got stuck transferring from the L-Class to the S-Class. This works well when Pods are used with both ships in space, not the S docked to the L.

I hope these steps allow you to recreate the issue in your test environment.

Scoob
Posts: 8307
Joined: Thu, 27. Feb 03, 23:28
x4

Re: [4.20 Beta 3] Crew transfer when docked very slow / unreliable

Post by Scoob » Sat, 27. Nov 21, 17:13

Update:

While single-direction Crew Transfers in space work well, I think there's a little more detail to be added here for clarity.

If I do a two-way transfer - so and exchange of crew if you will - it only works *one way*. The Smaller ship will immediately launch a Pod and the crew will arrive on the Larger ship very quickly. However, the Larger ship never seems to launch a pod - even though the crew are gone from it - so they never get to the destination.

I think there's a bug effecting two-way crew transfer regardless of docked / in space status. I'm sure I've had this working before.

So, from what I can see, there are perhaps two related issues here.

1) Sometimes a crew transfer TO a docked vessel from the vessel its docked to appears to fail. Said transfer works fine if the Smaller ship isn't docked, but sat in space.

2) Two-way crew exchanges (Three Marines <> Three Service crew for example) fails / takes ages regardless of docked station. The S to L transfer works quickly, the L to S transfer never completes. At least, it hasn't for me after ten minutes of waiting with the ships right next to each other.

I don't know how consistent this is, but it's just happened to me twice.

Scoob
Posts: 8307
Joined: Thu, 27. Feb 03, 23:28
x4

Re: [4.20 Beta 3] Crew transfer when docked very slow / unreliable

Post by Scoob » Sat, 27. Nov 21, 17:26

Further data.

I've tried several more times and a one-way crew transfer from a Large ship to a docked Small or Medium ship fails every time for me and never completes. It happens regardless of whether the ship is on the pad, or in internal storage.

While this is failing consistently for me when using the "Transfer Crew with" option, it works just fine if I use the comms "Work somewhere else for me" method. This is fine for individual crew transfers of course, or moving very specific crew, but not so much for larger group transfers of course.

peteran
Posts: 269
Joined: Thu, 26. Jul 07, 13:01
x4

Re: [4.20 Beta 3] Crew transfer when docked very slow / unreliable

Post by peteran » Thu, 2. Dec 21, 20:24

I cannot reproduce this problem and I've tried various combinations of:
  • being both IS and OOS
  • initiating the transfer from either S or L
  • S being in internal storage, on dock or space
  • transferring single and multiple crew members either one way or swapping crew.
The only thing I noticed was that OOS transfers were close to instantaneous while IS (actually on board of the L) took a bit of time.

I used a Magpie Vanguard and Wyvern (Mineral) for testing.

dtpsprt
Posts: 1914
Joined: Wed, 6. Nov 02, 21:31
x4

Re: [4.20 Beta 3] Crew transfer when docked very slow / unreliable

Post by dtpsprt » Sat, 4. Dec 21, 18:18

My best guess is that while the S crew are "sardined" the L Crew is "somewhere" inside a big ship therefore it may take them more time to "travel" to an elevator and into the S ship.

Even if they do get to one, they will be left on the landing pad and then have to walk into the ship (with that snail pace walk Egosoft has decided to use) not mentioning fumbling with the S ship's ladder. The S ship's crew just "appear" in the elevator, climb the ladder down (without getting stuck on it like when going up) and they are on their merry way!!!

That said I have observed that when I am in control of a ship, whether on a Station or ship Landing Pad, it takes forever for cargo and crew transfers to happen anyway...

Post Reply

Return to “X4: Foundations - Public Beta Feedback”