joystick and mouse simultaneous controls problem - solved

Ask here if you experience technical problems with X4: Foundations.

Moderator: Moderators for English X Forum

Post Reply
josemaria
Posts: 1
Joined: Sun, 24. Oct 21, 08:54

joystick and mouse simultaneous controls problem - solved

Post by josemaria » Sun, 24. Oct 21, 09:13

I use the keyboard and mouse to control the avatar, and at the same time I use a Hotas TrueMaster joystick compatible with pc and xbox to fly with the ship. The problem is that many times the mouse pointer is placed in the center of the screen and begins to move in an infinite spiral. Also in the main menu the mouse pointer moves by itself and disappears in the upper right corner of the screen. I have seen that loading my control profile again temporarily solves the problem, but after a short time the mouse pointer returns to spiral in the center of the screen. I have the Spanish version of steam. I appreciate any ideas or help to solve the problem. Thank you.

CBJ
EGOSOFT
EGOSOFT
Posts: 40869
Joined: Tue, 29. Apr 03, 00:56
x4

Re: joystick and mouse simultaneous controls problem

Post by CBJ » Mon, 25. Oct 21, 01:08

Moved to Tech Support.

It sounds like you have deadzone problems, or something external device providing input to the game. You'll need to provide a DXDiag at the very least, and more precise details of the hardware you are using, for there to be much chance of anyone being able to help you, though.

Falcrack
Posts: 3562
Joined: Wed, 29. Jul 09, 00:46
x4

Re: joystick and mouse simultaneous controls problem

Post by Falcrack » Mon, 25. Oct 21, 02:04

I think I had this problem, when I switched to running X4 on a different Windows user profile. I transferred the save file ,and when I started it up, my character was spinning wildly. Also, when I went to map, the cursor just went to the top right. I noticed that map pan horizontal and map pan vertical were assigned to some throttle buttons. Also first person analog controls were assigned to my throttle. I unassigned all of these, and it solved the problem.

Post Reply

Return to “X4: Foundations - Technical Support”