[FIX][4.1 Beta 5] Entire map UI crashes - Fix in a future build.

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Locked
User avatar
Tamina
Moderator (Deutsch)
Moderator (Deutsch)
Posts: 3090
Joined: Sun, 26. Jan 14, 10:56

[FIX][4.1 Beta 5] Entire map UI crashes - Fix in a future build.

Post by Tamina » Thu, 29. Jul 21, 12:54

Summary:
Since Beta 5, the map UI crashes after a while playing. When opening the map, not a single UI element is rendered on the screen.

Further information:
- Both times this happened to me, I was spectating another ship while opening the map. (coincidence?)
- Restarting the game, fixed the issue

Game Version:
Since 4.1 Beta 5

DxDiag and System Information:
GeforceNow

--

@Dev Can I in any way help pinpoint the bug further? I feel like this is not enough information.

Code: Select all

Und wenn ein Forenbösewicht, was Ungezogenes spricht, dann hol' ich meinen Kaktus und der sticht sticht sticht.
  /l、 
゙(゚、 。 7 
 l、゙ ~ヽ   / 
 じしf_, )ノ 

Skeeter
Posts: 3263
Joined: Thu, 9. Jan 03, 20:47
x3

Re: [4.1 Beta 5] Entire map UI crashes

Post by Skeeter » Thu, 29. Jul 21, 14:00

https://www.egosoft.com:8444/confluence ... VulkanInfo

Will be asked so might as well post these when you can to help em.

A save is usually asked too and a screenshot would help too i bet.
Image
i5 3570k cpu 16gb DDR3 1600mhz 6700XT 32" 1440p mon

User avatar
Tamina
Moderator (Deutsch)
Moderator (Deutsch)
Posts: 3090
Joined: Sun, 26. Jan 14, 10:56

Re: [4.1 Beta 5] Entire map UI crashes

Post by Tamina » Thu, 29. Jul 21, 14:17

Thanks for your input. I am playing on GeforceNow, so no Vulkan-thingy :D This seems highly savegame independent to me and happens randomly after an hour gametime or so. And I can't make a screenshot of something that is not there :D

I was rather trying to say, maybe there is some log or something (in-game) that shows UI problems. Or maybe I can do [something] when this happens that would further pinpoint the problem down.

Code: Select all

Und wenn ein Forenbösewicht, was Ungezogenes spricht, dann hol' ich meinen Kaktus und der sticht sticht sticht.
  /l、 
゙(゚、 。 7 
 l、゙ ~ヽ   / 
 じしf_, )ノ 

af_2017
Posts: 230
Joined: Sun, 7. Oct 18, 19:55
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by af_2017 » Thu, 29. Jul 21, 16:15

I feel that I can elaborate into that.
Under same conditions, that is with some playing time and using external camera (the game is beautiful and I like to stare around while flying :) ), I've got misbehavior of map UI.
I am playing on linux maybe because of this I have no crash. But the UI became unusable: I can not use context menus on ships (It says I don't own the ship), right panel with info does not correspond to selected ship. Also there's no top toolbars (research, map and such) and left toolbar (the one with missions, property).
Once I will be able to reproduce this I will attach screenshot. I tried to figure out repro steps but failed so far.
Reload of saved game does help to fix the issue.

User avatar
Erqco
Posts: 602
Joined: Sun, 7. Nov 10, 15:43
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by Erqco » Thu, 29. Jul 21, 16:19

It has happened to me also a couple of times, I can not pinpoint the cause of it, reload a save fix it for me.
Map doesn't open... it like it opens but don't show it, if I click the M again it try to open but nothing happens.

florianlt
EGOSOFT
EGOSOFT
Posts: 1133
Joined: Mon, 22. Aug 11, 14:05
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by florianlt » Fri, 30. Jul 21, 07:58

Never used GeforceNow. If you can add this parameter

-logfile debuglog.txt

when you start the game, it will write a file into the folder containing your saves folder. Include this file here once the error occured.

af_2017
Posts: 230
Joined: Sun, 7. Oct 18, 19:55
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by af_2017 » Sat, 31. Jul 21, 03:17

af_2017 wrote:
Thu, 29. Jul 21, 16:15
Once I will be able to reproduce this I will attach screenshot.
Managed to get the same error with map.

https://i.ibb.co/xMvT7hS/Screenshot-fro ... -52-56.png
https://i.ibb.co/rpmKznf/Screenshot-fro ... -53-42.png
https://i.ibb.co/CQ9tL8m/Screenshot-fro ... -53-31.png

On the screenshots is what the game displays after pressing map shortcut. There's no map at all, only property list.
I can't provide 100% reliable steps to reproduce though.
According to first screenshot, I was in ship's external fee camera (press F2 twice), I wanted to have a look at xenon who was shooting my current ship while it is on the way to auxiliary ship for repairs
It was couple of hours game session with several quick saves in between.
The map is unusable if this happens.
Unable to reproduce after reloading saved game.
Last edited by CBJ on Sat, 31. Jul 21, 11:16, edited 1 time in total.
Reason: Oversized images replaced with links

User avatar
Tamina
Moderator (Deutsch)
Moderator (Deutsch)
Posts: 3090
Joined: Sun, 26. Jan 14, 10:56

Re: [4.1 Beta 5] Entire map UI crashes

Post by Tamina » Sat, 31. Jul 21, 20:00

florianlt wrote:
Fri, 30. Jul 21, 07:58
Never used GeforceNow. If you can add this parameter

-logfile debuglog.txt

when you start the game, it will write a file into the folder containing your saves folder. Include this file here once the error occured.
I copied the last three messages from the ingame log. Is that okay?
Image Image Image
It does not seem the logfile is being synced with Steam Cloud. So I am unable to download the file to my PC. The message before that is about some fighter not being able to find a landing pad on my carrier 5 minutes before those entries happened. I figured this is unimportant to you.

Code: Select all

Und wenn ein Forenbösewicht, was Ungezogenes spricht, dann hol' ich meinen Kaktus und der sticht sticht sticht.
  /l、 
゙(゚、 。 7 
 l、゙ ~ヽ   / 
 じしf_, )ノ 

User avatar
Vannacutt-BT-
Posts: 136
Joined: Sun, 17. Jun 18, 16:57
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by Vannacutt-BT- » Sat, 31. Jul 21, 21:08

Here I have uploaded my Log and Info files when it happened multiple times for me. Every time before I hit the quick load in Log file the
problem occured. In other words every time the error happened I saved and hit quick load.

My reference: report030
Game Version: 4.10 Beta 5 (453078)
Files: https://vannacutt.devpixel.de/redirect/x4/report030
Best regards
Vannacutt-BT-


PC-Specs: PasteBin
My Mod: BaerTec God Mode
For questions why I use a mod, I am seriously ill.

"...und der Tod stellte seine Sense in die Ecke und stieg auf den Mähdrescher... denn es war Krieg" - Unknown Author

CaptGensman
Posts: 84
Joined: Thu, 20. Dec 18, 02:52
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by CaptGensman » Sun, 1. Aug 21, 16:33

Tamina wrote:
Thu, 29. Jul 21, 12:54
Summary:
Since Beta 5, the map UI crashes after a while playing. When opening the map, not a single UI element is rendered on the screen.

Further information:
- Both times this happened to me, I was spectating another ship while opening the map. (coincidence?)
- Restarting the game, fixed the issue

Game Version:
Since 4.1 Beta 5

DxDiag and System Information:
GeforceNow

--

@Dev Can I in any way help pinpoint the bug further? I feel like this is not enough information.
Yesterday i'm running in the same problem. Today it works all fine.

Steps to reproduce (yesterday)

- select a ship on the map
- use the F3 external camera - all hud elemtes are disappear.
- try to go back to the 3rd person view - F1 is not working hit 2x ESC and and retry F1 and it will works
- try to open the map and it will crash all UI elements and the map do not open

Workaround to recover the map (yesterday)

- take place on a pilot chair
- hit return
- select the "Schiffsinformationen" tab and the map is recoverd

User avatar
Vannacutt-BT-
Posts: 136
Joined: Sun, 17. Jun 18, 16:57
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by Vannacutt-BT- » Sun, 1. Aug 21, 21:23

New observation:
For me it mostly happens when I press P for pause and immediately open the map.
This quite often happened for me when I try to enter/board a ship. (Here I often use Pause and Map)

And here from Log-File:
Spoiler
Show

Code: Select all

[General] 114833.19 ======================================
[=ERROR=] 114833.19 Error while executing onEvent script for event: showMapMenu.
Errormessage: P:\SVN\temp\menu_map.lua:9573: bad argument #2 to 'GetNumOrderFailures' (cannot convert 'nil' to 'bool')
[General] 114833.19 ======================================
Best regards
Vannacutt-BT-


PC-Specs: PasteBin
My Mod: BaerTec God Mode
For questions why I use a mod, I am seriously ill.

"...und der Tod stellte seine Sense in die Ecke und stieg auf den Mähdrescher... denn es war Krieg" - Unknown Author

User avatar
Erqco
Posts: 602
Joined: Sun, 7. Nov 10, 15:43
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by Erqco » Mon, 2. Aug 21, 06:11

It has been working a few days without problem... today it is happening every ten times or so that I open the map, the UI disappear, I have observed that hitting Escape one or two time brings most of the UI back, everything but the map. Easiest way to get back to normal is F5, F9.

florianlt
EGOSOFT
EGOSOFT
Posts: 1133
Joined: Mon, 22. Aug 11, 14:05
x4

Re: [4.1 Beta 5] Entire map UI crashes

Post by florianlt » Mon, 2. Aug 21, 08:10

Thank you all. You are all encountering the same issue that was reported here: viewtopic.php?f=192&t=441054

So fixed in an upcoming build.
Last edited by Ketraar on Mon, 2. Aug 21, 12:13, edited 1 time in total.
Reason: locked to avoid dup posting, please continue in the above linked topic if needed

Locked

Return to “X4: Foundations - Public Beta Feedback”