4.1 B5 - Crash to desktop on every save

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
harlequin80
Posts: 28
Joined: Wed, 20. May 20, 02:00

4.1 B5 - Crash to desktop on every save

Post by harlequin80 » Thu, 29. Jul 21, 14:46

Save game was working pre beta 5 update. Will now crash every time a save is triggered, both autosaves and manual.

No dump files that I can see.

System in Linux Mint, Ryzen 7, RX580

Skeeter
Posts: 3264
Joined: Thu, 9. Jan 03, 20:47
x3

Re: 4.1 B5 - Crash to desktop on every save

Post by Skeeter » Thu, 29. Jul 21, 14:51

Try verify your files through steam if ur using steam.
Image
i5 3570k cpu 16gb DDR3 1600mhz 6700XT 32" 1440p mon

harlequin80
Posts: 28
Joined: Wed, 20. May 20, 02:00

Re: 4.1 B5 - Crash to desktop on every save

Post by harlequin80 » Thu, 29. Jul 21, 15:04

Typically, it crashed 4 times in a row on saves, and now that I am running the game with -logfile trigger it's not crashed.

I'll keep the log going and see what happens.

harlequin80
Posts: 28
Joined: Wed, 20. May 20, 02:00

Re: 4.1 B5 - Crash to desktop on every save

Post by harlequin80 » Thu, 29. Jul 21, 15:23

Ok just had a series of very high CPU usages followed by a crash.

Here is a link to the logfile output - https://drive.google.com/file/d/1-ya4i5 ... sp=sharing

Lots of this
[=ERROR=] 346185.58 Error in AI script order.move.recon on entity 0x3ee15: Property lookup failed: $_override_deployablecategory.mk.{3}.list.{1}
* Expression: $_override_deployablecategory.mk.{$locmk}.list.{1}.ware
* Action: <set_value>, line 349
[General] 346185.58 ======================================
[General] 346185.58 ======================================
[=ERROR=] 346185.58 Error in AI script order.move.recon on entity 0x3ee15: Failed to set table[].{null} to value 50
* Expression: $ammotable_interrupt.{$locware}
* Action: <set_value>, line 352
[General] 346185.58 ======================================
[General] 346189.87 ======================================
[=ERROR=] 346189.87 Error in AI script order.move.recon on entity 0x35e94: Property lookup failed: $_override_deployablecategory.mk.{3}.list.{1}
* Expression: $_override_deployablecategory.mk.{$locmk}.list.{1}.ware
* Action: <set_value>, line 349
[General] 346189.87 ======================================
[General] 346189.87 ======================================
[=ERROR=] 346189.87 Error in AI script order.move.recon on entity 0x35e94: Failed to set table[].{null} to value 50
* Expression: $ammotable_interrupt.{$locware}
* Action: <set_value>, line 352
[General] 346189.87 ======================================
[General] 346192.19 ======================================
[=ERROR=] 346192.19 aicontext<order.fight.escort,0x5d7eb>: Unhandled case.
escort target: Gladius 0x5d731, operational: 1, has pilot: 1
commander: Gladius 0x5d731, operational: 1, has pilot: 1
[General] 346192.19 ======================================

CBJ
EGOSOFT
EGOSOFT
Posts: 40795
Joined: Tue, 29. Apr 03, 00:56
x4

Re: 4.1 B5 - Crash to desktop on every save

Post by CBJ » Thu, 29. Jul 21, 15:33

I know it's crashing while saving, but presumably you're loading a save shortly beforehand. Can you provide a save and the steps that make it crash for you?

Edit: According to the log file your savegame is modified, and by the looks of things several of those mods are missing. Please note the rules at the top of the forum regarding modified games.

harlequin80
Posts: 28
Joined: Wed, 20. May 20, 02:00

Re: 4.1 B5 - Crash to desktop on every save

Post by harlequin80 » Thu, 29. Jul 21, 23:37

Understood. I will remove the mods and retest. I know they are a factor outside of your control, it was more a case of working fine on Beta 4 to not.

CBJ
EGOSOFT
EGOSOFT
Posts: 40795
Joined: Tue, 29. Apr 03, 00:56
x4

Re: 4.1 B5 - Crash to desktop on every save

Post by CBJ » Thu, 29. Jul 21, 23:38

I'm not sure that removing mods will help. It might even make things worse, since the error messages seem to imply that you've already removed mods that the savegame was depending on. Try it anyway, though. :)

SwizzleStick86
Posts: 161
Joined: Sat, 10. Nov 18, 16:45
x4

Re: 4.1 B5 - Crash to desktop on every save

Post by SwizzleStick86 » Fri, 30. Jul 21, 00:11

Have you updated windows recently? Ever since the 20H2 update mine would completely crash the computer (on every game). Windows firewall was preventing games from accessing their own files.and crashing the computer without displaying any notification. I had to go through windows security settings. (Possibly a different issue but this fixed mine)
"It can only be attributable to human error."
-HAL 9000

SwizzleStick86
Posts: 161
Joined: Sat, 10. Nov 18, 16:45
x4

Re: 4.1 B5 - Crash to desktop on every save

Post by SwizzleStick86 » Fri, 30. Jul 21, 00:12

Sorry my bad just saw your using linux..please ignore the last then..
"It can only be attributable to human error."
-HAL 9000

harlequin80
Posts: 28
Joined: Wed, 20. May 20, 02:00

Re: 4.1 B5 - Crash to desktop on every save

Post by harlequin80 » Fri, 30. Jul 21, 01:12

Mods removed and seems to have sorted the issue.

The mods that were showing up as not working in the logfile were ones that had been installed ages ago and weren't actually active in the game and hadn't been used in that save file at all. I guess I hadn't cleaned them out properly. This time I deleted all the extension files and directories and the game isn't crashing on load / save. The only mods that had been active in the save were "sector satellites" and "reaction force"

All of these hadn't actually been active:
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/mules_and_warehouses_extended/content.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/steambeans.craftedmodparts/content.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/iseeu0_cheat/content.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/shib_reactionforce/content.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/fastcrewlevel/content.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/equipmods_redone/content.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/mules_and_warehouses_extended/t/0001.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/shib_reactionforce/t/0001.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/sectorsatellites/t/0001-l044.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/iseeu0_cheat/t/0001-l044.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/fbb/t/0001.xml.sig'
[General] 0.00 ======================================
[General] 0.00 ======================================
[=ERROR=] 0.00 File I/O: Could not find file './extensions/equipmods_redone/t/0001.xml.sig'

harlequin80
Posts: 28
Joined: Wed, 20. May 20, 02:00

Re: 4.1 B5 - Crash to desktop on every save

Post by harlequin80 » Fri, 30. Jul 21, 01:42

Ok. So just had another CTD on save :( All mods are removed, but yes it is a savegame that has had mods.

This is the logfile - https://drive.google.com/file/d/1BUB7CW ... sp=sharing

This is the save file - https://drive.google.com/file/d/1k4uDUR ... sp=sharing

Last outputs in logfile. There are probably another ~20 of the VertexBuffers! errors before the end of the file.

[General] 347634.55 ======================================
[=ERROR=] 347634.55 [Mesh::UpdateMeshFromDataExchanger] failed to create/update all VertexBuffers!
[General] 347634.55 ======================================
[General] 347674.38 ======================================
[=ERROR=] 347674.38 Error in AI script orders.base on entity 0x2dbd3: Property lookup failed: $object.order.$baseorder.id
* $object.order.$baseorder == order<0x166a> (invalid)
* Expression: $object.order.id == 'Assist' and $object.order.$baseorder.id != 'DockAndWait'
* Action: <do_elseif>, line 209
[General] 347674.38 ======================================
[General] 347698.42 ======================================
[=ERROR=] 347698.42 [SCharacterInstance::Init] Could not find model for asset name characterinstance:46!
[General] 347698.42 ======================================
[General] 347715.27 ======================================
[=ERROR=] 347715.27 [Mesh::UpdateMeshFromDataExchanger] failed to create/update all VertexBuffers!
[General] 347715.27 ======================================
[General] 347715.27 ======================================
[=ERROR=] 347715.27 \home\jenkins\workspace\X4_Steam\src\X4\ui\core\xanark\anarkviewbridge.cpp(100): Warning. The current frame was already updated without processing the update event. Check for errors in addon scripts issuing too many update calls.
(version: 4.10 - Code revision: 453078)
[General] 347715.27 ======================================
[General] 347796.53 ======================================
[=ERROR=] 347796.53 [Mesh::UpdateMeshFromDataExchanger] failed to create/update all VertexBuffers!
[General] 347796.53 ======================================
[General] 347870.45 ======================================
[=ERROR=] 347870.45 [Mesh::UpdateMeshFromDataExchanger] failed to create/update all VertexBuffers!
[General] 347870.45 ======================================
[General] 347936.21 ======================================
[=ERROR=] 347936.21 [Mesh::UpdateMeshFromDataExchanger] failed to create/update all VertexBuffers!
[General] 347936.21 ======================================

CBJ
EGOSOFT
EGOSOFT
Posts: 40795
Joined: Tue, 29. Apr 03, 00:56
x4

Re: 4.1 B5 - Crash to desktop on every save

Post by CBJ » Fri, 30. Jul 21, 10:03

It's possible that your savegame is simply not usable without the mods that were in use when it was created. However, those particular errors relate to the graphics engine, so we'll need your full system specifications (DXDiag if you're on Windows, and vulkaninfo anyway) to look into those.

harlequin80
Posts: 28
Joined: Wed, 20. May 20, 02:00

Re: 4.1 B5 - Crash to desktop on every save

Post by harlequin80 » Sat, 31. Jul 21, 07:19

The crashing is inconsistent, and I no longer know what the trigger is. It was coinciding with saving, but now it is random. It can also play for hours one time, and 20 mins the next.

For what it's worth here is the vulkaninfo - https://drive.google.com/file/d/1hTZVXa ... sp=sharing

Post Reply

Return to “X4: Foundations - Public Beta Feedback”