[X4 v4.10 beta 4 SV COH] Engineers not fixing ship damage

This forum provides information on obtaining access to Public Beta versions of X4: Foundations allowing people running those versions to provide feedback on their experiences.

Moderator: DevNet Public Moderators

Post Reply
User avatar
alt3rn1ty
Posts: 1287
Joined: Thu, 26. Jan 06, 20:45
x4

[X4 v4.10 beta 4 SV COH] Engineers not fixing ship damage

Post by alt3rn1ty » Tue, 27. Jul 21, 11:47

Save game is modified, however I can assure you :
1. No third party mods have ever been used.
2. Edited only to give myself a ton of Seminars / Inventory items for testing purposes + One of my Yaki Captains names is now Seven of Nine :).
So hopefully you can use the following ..
Save = https://www.dropbox.com/s/1231rhij2sz7a ... ml.gz?dl=0

Issue : Two Specialist Engineers onboard my Nimcha (Named "Box Hound"), after the ship was damaged when a lock box exploded (or released a mine, not sure), the Engineers are not repairing the damage.

The save is after 10 hours real time waiting to see if the Engineers would do anything. Before I went to sleep I was going to take the ship into a Wharf for repairs, but decided to leave it and watch the olympics instead, then fell asleep some time after. Came back to it this morning and saw no progress had been made.

The ships hull is still at 1868/3000 61% - https://i.imgur.com/4G9Eyrh.png
Engineers are 5 star for both engineering and moral - https://i.imgur.com/eAjJfR6.png

I am wondering if this is a thing just from lock box damage, or just a regression in 4.10 beta 4.
Laptop Dell G7 7590 : Win 10 x64
CPU 9th Gen' Core I7 9750H 4.5ghz,
GPU NVidia Geforce GTX 1650, VRAM 4gb GDDR5,
RAM Corsair Vengeance 32gb (2x16gb Dual Channel) DDR4 2666mhz,
Samsung 970 Evo Plus M.2 NVME 500gb + Dell 512gb SSDs' (both Internal)

User avatar
alt3rn1ty
Posts: 1287
Joined: Thu, 26. Jan 06, 20:45
x4

Re: [X4 v4.10 beta 4 SV COH] Engineers not fixing ship damage

Post by alt3rn1ty » Tue, 27. Jul 21, 11:56

Forgot to mention something which may be relevant ..

The two engineers were transferred to the Nimcha using Crew Transfer, from a ship which had gained the experienced engineers over the course of the last year or so. So no editing of the save file has been done to them.
Laptop Dell G7 7590 : Win 10 x64
CPU 9th Gen' Core I7 9750H 4.5ghz,
GPU NVidia Geforce GTX 1650, VRAM 4gb GDDR5,
RAM Corsair Vengeance 32gb (2x16gb Dual Channel) DDR4 2666mhz,
Samsung 970 Evo Plus M.2 NVME 500gb + Dell 512gb SSDs' (both Internal)

User avatar
alt3rn1ty
Posts: 1287
Joined: Thu, 26. Jan 06, 20:45
x4

Re: [X4 v4.10 beta 4 SV COH] Engineers not fixing ship damage

Post by alt3rn1ty » Tue, 27. Jul 21, 12:02

Also note the ships shields are always at 99% and do not fully recover.
Possible in game ship modifications technical issue?
Check the ships Loadout to see what I have applied (Nanotube, Targe .. etcetera)
Laptop Dell G7 7590 : Win 10 x64
CPU 9th Gen' Core I7 9750H 4.5ghz,
GPU NVidia Geforce GTX 1650, VRAM 4gb GDDR5,
RAM Corsair Vengeance 32gb (2x16gb Dual Channel) DDR4 2666mhz,
Samsung 970 Evo Plus M.2 NVME 500gb + Dell 512gb SSDs' (both Internal)

-=SiR KiLLaLoT=-
Posts: 1729
Joined: Sat, 3. Mar 12, 20:58
x4

Re: [X4 v4.10 beta 4 SV COH] Engineers not fixing ship damage

Post by -=SiR KiLLaLoT=- » Tue, 27. Jul 21, 12:11

I am not aware that a size S ship can receive repairs from the engineers, at least not in the vanilla version.
Have you installed any mods that allow you to do this?
HW Spec:
CPU: Core i9 9900k @ 5.0Ghz - MOBO: MSI Z390-A PRO - RAM: 2x8GB Corsair Vengeance LPX DDR4 3200Mhz - GPU: Zotac nVidia GTX970 4GB GDDR5 - M.2: Sabrent ROCKET 512GB - SSD: Samsung 840 Pro 256GB - Samsung 850 EVO 250GB - Sandisk Plus 240GB – HDD: WD Caviar Black 1TB – WD Caviar Blue 1TB – WD Caviar Black 2TB - PSU: Enermax Liberty 620w - CASE: iTek Iron Soldier - MONITOR: 24” Asus VS247NR - Windows 10 Pro 64-Bit - KEYBOARD: Logitech G15 – MOUSE: Red Dragon Perdition
My X4 Steam screenshots.

User avatar
alt3rn1ty
Posts: 1287
Joined: Thu, 26. Jan 06, 20:45
x4

Re: [X4 v4.10 beta 4 SV COH] Engineers not fixing ship damage

Post by alt3rn1ty » Tue, 27. Jul 21, 12:22

As mentioned in the first post - No third party mods (ie nexusmods / moddb etcetera) have ever been used.

I didn't know that about Small ships if it is true, are they not supposed to fix small ships?, if so seems a bit bizarre that we can add a crew of 3 to them who do not perform what you would expect them to.

If that is the case, then this becomes a feedback thread .. Egosoft this is weird, I guess we can imagine them not having enough room to swing a cat in .. But Star Trek crew onboard a shuttle can manage to do repairs :P
Laptop Dell G7 7590 : Win 10 x64
CPU 9th Gen' Core I7 9750H 4.5ghz,
GPU NVidia Geforce GTX 1650, VRAM 4gb GDDR5,
RAM Corsair Vengeance 32gb (2x16gb Dual Channel) DDR4 2666mhz,
Samsung 970 Evo Plus M.2 NVME 500gb + Dell 512gb SSDs' (both Internal)

User avatar
alt3rn1ty
Posts: 1287
Joined: Thu, 26. Jan 06, 20:45
x4

Re: [X4 v4.10 beta 4 SV COH] Engineers not fixing ship damage

Post by alt3rn1ty » Tue, 27. Jul 21, 12:25

.. And there is still the oddity of the ships shields never recovering to 100%
Laptop Dell G7 7590 : Win 10 x64
CPU 9th Gen' Core I7 9750H 4.5ghz,
GPU NVidia Geforce GTX 1650, VRAM 4gb GDDR5,
RAM Corsair Vengeance 32gb (2x16gb Dual Channel) DDR4 2666mhz,
Samsung 970 Evo Plus M.2 NVME 500gb + Dell 512gb SSDs' (both Internal)

User avatar
alt3rn1ty
Posts: 1287
Joined: Thu, 26. Jan 06, 20:45
x4

Re: [X4 v4.10 beta 4 SV COH] Engineers not fixing ship damage

Post by alt3rn1ty » Tue, 27. Jul 21, 13:01

alt3rn1ty wrote:
Tue, 27. Jul 21, 12:22
If that is the case, then this becomes a feedback thread .. Egosoft this is weird, I guess we can imagine them not having enough room to swing a cat in .. But Star Trek crew onboard a shuttle can manage to do repairs :P
.. Although if making small ships crews do repairs would have a negative impact on overall game performance .. Not so sure I should be suggesting it becomes a thing.
Laptop Dell G7 7590 : Win 10 x64
CPU 9th Gen' Core I7 9750H 4.5ghz,
GPU NVidia Geforce GTX 1650, VRAM 4gb GDDR5,
RAM Corsair Vengeance 32gb (2x16gb Dual Channel) DDR4 2666mhz,
Samsung 970 Evo Plus M.2 NVME 500gb + Dell 512gb SSDs' (both Internal)

Post Reply

Return to “X4: Foundations - Public Beta Feedback”