2.5 killed 50% of my mods 1.6 is what i need how to rollback

The place to discuss scripting and game modifications for X4: Foundations.

Moderators: Scripting / Modding Moderators, Moderators for English X Forum

Post Reply
balogt
Posts: 764
Joined: Thu, 18. Dec 03, 10:00
x3

2.5 killed 50% of my mods 1.6 is what i need how to rollback

Post by balogt » Sat, 6. Jul 19, 07:31

as I have lost over 50% of my personal mods I made that are 1.6 based, and that made the game sing with 0 bugs (that I ever noticed). and now 2.5 is massively laggy and most of my mods don't work right..well I desperately need to back up to version 1.6 and just keep it there. otherwise I cant play the game and its essentially lost revenue spent on a game. can someone more knowledagble than I please tell me how to do it. its a steam based install but I cant figure out steam to save my life.

thanks a bundle

p.s. if its not actually possible to roll back where to I put in for a refund?

Buzz2005
Posts: 1416
Joined: Sat, 26. Feb 05, 02:47
x4

Re: 2.5 killed 50% of my mods 1.6 is what i need how to rollback

Post by Buzz2005 » Sat, 6. Jul 19, 07:42

I think it is impossible but cant you patch your mods for 2.5 if I understand correctly when you say personal mods you mean you made the mods?
Fixed credits not being able to claim abandoned ships sometimes getting stuck when boarding operation sometimes getting some owner other than the player builds a station module or surface element.

balogt
Posts: 764
Joined: Thu, 18. Dec 03, 10:00
x3

Re: 2.5 killed 50% of my mods 1.6 is what i need how to rollback

Post by balogt » Sat, 6. Jul 19, 07:50

correct I made the mods, as well I have a few from other folks as well. I have not a clue how to patch the mods to work with this version of the game. I do understand the directory structure and such of the mods but what small tag/component needs to be added to make them work with this version?

ps. thanks for the help in advance

balogt
Posts: 764
Joined: Thu, 18. Dec 03, 10:00
x3

Re: 2.5 killed 50% of my mods 1.6 is what i need how to rollback

Post by balogt » Sat, 6. Jul 19, 07:52

also a few of my older mods still work with 2.5...not sure what the magic pill is that is making them work though.

strask412
Posts: 406
Joined: Thu, 29. Nov 07, 21:34
x4

Re: 2.5 killed 50% of my mods 1.6 is what i need how to rollback

Post by strask412 » Sat, 6. Jul 19, 13:22

https://www.egosoft.com:8444/confluence ... ng+Changes

The linked wiki page has a list that EgoSoft has helpfully provided of all the changes in various versions/updates that are likely to cause broken mods.

Since yours worked in version 1.6, just look at all the entries on that table starting with the 2.0 entries about half way down, and working your way up towards the top. Each table entry tells you about the change, what it would break, and generally gives an idea of how to adjust your mod. You might need to ask additional questions about any particular thing, but that list should at least get you to the point where you know what questions you need to ask.

balogt
Posts: 764
Joined: Thu, 18. Dec 03, 10:00
x3

Re: 2.5 killed 50% of my mods 1.6 is what i need how to rollback

Post by balogt » Sun, 7. Jul 19, 03:17

I wne though that table. none of my mods utilize those TAGs, thus I am not sure why some are working and some have some parts working and not others within the same mod. I wonder if there is a heicharchy for example the speed of the quasar. my mod that alters it a tad isn't being recognized, where as it use to be in 1.6. do I need to re order where I place it or how I enumerate it for the game to see it before the default X4 data?

strask412
Posts: 406
Joined: Thu, 29. Nov 07, 21:34
x4

Re: 2.5 killed 50% of my mods 1.6 is what i need how to rollback

Post by strask412 » Sun, 7. Jul 19, 09:49

balogt wrote:
Sun, 7. Jul 19, 03:17
I wne though that table. none of my mods utilize those TAGs, thus I am not sure why some are working and some have some parts working and not others within the same mod. I wonder if there is a heicharchy for example the speed of the quasar. my mod that alters it a tad isn't being recognized, where as it use to be in 1.6. do I need to re order where I place it or how I enumerate it for the game to see it before the default X4 data?
You know, if your mods are publicly available, just link to them so we can try to analyze the issue directly. And if they are not (yet) publicly available, consider zipping them up or whatever and posting a link to google drive or dropbox or whatever.

I'm sure you've looked at the available documentation in the stickies here on the forum and over at the wiki by now. Listing off "you have to use syntax x-y-z in the third line of the foo file" for every little possible error/problem isn't going to be productive, I imagine, on the sending or receiving sides. So let's just try to get some fresh eyes on the actual source files, if that's ok.

Post Reply

Return to “X4: Foundations - Scripts and Modding”