2.60 (370595) - Station modules taking way too long to build - Devs on the case.

Ask here if you experience technical problems with X4: Foundations.

Moderator: Moderators for English X Forum

274 Below
Posts: 18
Joined: Tue, 2. Oct 18, 15:48
x4

2.60 (370595) - Station modules taking way too long to build - Devs on the case.

Post by 274 Below » Mon, 11. Nov 19, 21:31

Version: 2.60 (370595), English
No mods
Game start: Untested Explorer

I'm building a station in Argon Prime. It's taking way too long to build. It's a basic dock, three solar panels, and then two of the large container/liquid/solid storage modules.

The basic dock took 11 minutes to build, which from memory, sounds right. The solar panels, for some reason, started taking about an hour to build. In fact, when the final one started building, the initial time to complete was 15 minutes. However, after the first percentage point, it jumped up to a full hour -- which seems wrong.

This is being built with a construction ship that I own, where all of the build materials have been purchased and are sitting in build storage. I've tested both with and without a manager of the complex (only thing I could think of) -- it doesn't seem to have changed anything.

Ideas?

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 21971
Joined: Fri, 16. Apr 04, 19:21
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by Alan Phipps » Mon, 11. Nov 19, 21:46

Are all your builder drones available to the job? I recall in X Rebirth that if you started another module build before all the builder drones redocked after module completion, then those still outside were unavailable for the next build. There was no point in trying to add more drones mid-build either as they didn't become available until the next module after that.
A dog has a master; a cat has domestic staff.

274 Below
Posts: 18
Joined: Tue, 2. Oct 18, 15:48
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by 274 Below » Mon, 11. Nov 19, 21:48

I can visually see the drones zipping back and forth between the station and the construction ship. The ship itself has 50 building, 20 cargo, 20 repair and 10 defense drones.

The constructions drones line says "50 / 100 (50 Unavailable)" but I am kind of assuming that's because they should all be working on the construction...

edit: construction ship drones: https://i.imgur.com/LwekjSZ.jpg

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 21971
Joined: Fri, 16. Apr 04, 19:21
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by Alan Phipps » Mon, 11. Nov 19, 21:50

That *might* not be the case if they were unavailable at the time the latest build started. I really don't know how faithfully X4 follows XR in this respect though.

Similar threads here, here and here.

It's interesting that 2.60 HotFixes addressed some related issues:

* Fixed construction drones on shipyards becoming permanently unavailable.
* Fixed build time estimates not correctly taking available units into account.
A dog has a master; a cat has domestic staff.

274 Below
Posts: 18
Joined: Tue, 2. Oct 18, 15:48
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by 274 Below » Mon, 11. Nov 19, 22:03

Yes, it's those line items in the change log that make me suspect this is potentially a side effect (bug) of those changes. :)

geronimo3

Re: 2.60 (370595) - Station modules taking way too long to build

Post by geronimo3 » Mon, 11. Nov 19, 22:44

274 Below wrote:
Mon, 11. Nov 19, 22:03
Yes, it's those line items in the change log that make me suspect this is potentially a side effect (bug) of those changes. :)
i can confirm 274 Below ´s observation. In my game an ongoing build of a bigger complex the build times of certain modules have increased a lot with 2.6. a smart chip fabric takes now 1 hour to build, i don´t have the numbers from pre 2.6 but i am convinced they were lower. the drone configuration and unavailability status ssems to be correct (80 build drones on the cv and all occupied)

Venomaus
Posts: 10
Joined: Thu, 20. Dec 18, 23:23
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by Venomaus » Tue, 12. Nov 19, 11:26

I have seen this behaviour too on the 2.6 beta HF 2

etonbears
Posts: 63
Joined: Mon, 31. Dec 12, 01:13
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by etonbears » Tue, 12. Nov 19, 14:49

Yes, exactly the same. Build time for each module starts as expected, then after a while jumps up to about 5x expected, for a builder with 70 build drones. First noticed the behaviour around the time the 2.6 auto-update was pushed out. Not a particularly helpful "fix", even if this is an intentional change.
----------------------------
Hardware Used :
Storage : SATA3 SSD
Memory : 32GB
CPU : i7 3820 / X79
GPU : GTX 1070Ti

etonbears
Posts: 63
Joined: Mon, 31. Dec 12, 01:13
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by etonbears » Tue, 12. Nov 19, 19:03

Some additional information.

I sat and watched my station complex as it was being built. The issue seems to be that the builder only ever uses ONE drone, even though there are 70 on board. The drone flies to the current module being built, does some work and flies back, to be replaced by another single drone. This is in contrast to my recollection of watching building under 2.5, where 5 or 6 builder drones were always active, and longer build times only occurred if the number of builder drones were reduced to a handful by enemies.

When a module completes, the single active drone continues to spend some time fussing over it before flying back to the builder. During this time ( after the previous module completes, and before the builder sends out its next single drone), the new module is shown to be building at full speed. This abruptly changes when the builder sends out its next single drone, and the build time leaps up.

So, the behaviour that is wrong seems to be simply that the builder is not using more than one drone ( when it has many ), rather than there being a bug in the time calculation.
Last edited by etonbears on Tue, 12. Nov 19, 20:46, edited 1 time in total.
----------------------------
Hardware Used :
Storage : SATA3 SSD
Memory : 32GB
CPU : i7 3820 / X79
GPU : GTX 1070Ti

geronimo3

Re: 2.60 (370595) - Station modules taking way too long to build

Post by geronimo3 » Tue, 12. Nov 19, 19:46

i have also watched the build drones traffic, from the 80 available and flagged occupied drones i can see approx 6-8 flying around and building ?, still long build times.

etonbears
Posts: 63
Joined: Mon, 31. Dec 12, 01:13
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by etonbears » Tue, 12. Nov 19, 20:41

geronimo3 wrote:
Tue, 12. Nov 19, 19:46
i have also watched the build drones traffic, from the 80 available and flagged occupied drones i can see approx 6-8 flying around and building ?, still long build times.
Interesting.

Do you see a "jump" in the build time for a module after it has started building?

In my case, production modules start with 15-20min build times, then jump to 1-2Hrs.

Are you seeing the same 1Hr+ time for production modules?
----------------------------
Hardware Used :
Storage : SATA3 SSD
Memory : 32GB
CPU : i7 3820 / X79
GPU : GTX 1070Ti

etonbears
Posts: 63
Joined: Mon, 31. Dec 12, 01:13
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by etonbears » Wed, 13. Nov 19, 00:06

OK, so now the current state of build time calculations gets even more weird.

In this topic viewtopic.php?f=182&t=418310, user @VirtualLaughing says that builders with no build drones do not suffer from time dilation.

So I ordered a new Heracles without any build drones, cancelled the build order on my Albatross that has 70 build drones, and gave the build task to the drone-less Heracles instead.

And it does work for me as well. Build speed is 15-20 minutes for storage and production modules, as I assume it should be, even though the modules now appear magically with no drone activity.

I would guess this is another aspect of the same bug that causes long build times, but who knows.

This is a work-around until the problem is fixed, but it does require you to have your own builders, and not give them build drones.
----------------------------
Hardware Used :
Storage : SATA3 SSD
Memory : 32GB
CPU : i7 3820 / X79
GPU : GTX 1070Ti

274 Below
Posts: 18
Joined: Tue, 2. Oct 18, 15:48
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by 274 Below » Wed, 13. Nov 19, 17:35

Yeah, I ordered a second construction ship without any drones. And... it seems to be building just perfectly.

Which is odd. :)

geronimo3

Re: 2.60 (370595) - Station modules taking way too long to build

Post by geronimo3 » Wed, 13. Nov 19, 17:56

In my view this is a serious bug, not shure if it had come to the developers attention. i´am not familar with how to to report a bug officially, maybe the moderator who has joined in here can report this ?

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 21971
Joined: Fri, 16. Apr 04, 19:21
x4

Re: 2.60 (370595) - Station modules taking way too long to build

Post by Alan Phipps » Wed, 13. Nov 19, 18:53

The devs are indeed looking at it. As always, the issue is the time it takes to set up from scratch a scenario that replicates the issue for analysis and so any vanilla saves provided that show the issue in progress will be valuable to them.
A dog has a master; a cat has domestic staff.

Post Reply

Return to “X4: Foundations - Technical Support”