[1334]Side and bottom thrusters ON when travelling in a straight line?

Ask here if you experience technical problems with X4: Foundations.

Moderator: Moderators for English X Forum

Post Reply
Browser_ice
Posts: 477
Joined: Sun, 5. Feb 06, 18:15
x4

[1334]Side and bottom thrusters ON when travelling in a straight line?

Post by Browser_ice » Tue, 15. Jun 21, 17:56

Hi, this issue has been present since at lease 3.0

I noticed for some ships I am piloting, when going in a straight line in travel mode, the left side thursters are ON and so is the bottom one. I think the front one sometimes is on but that could depend on the ship.

It does not make sens to have them ON if you are going in a straight line. Having them ON would mean I would be stearing right and up at the same time, so no more in a straight line.

I will add a photo later.

Pretty sure it is not a ship animation thing.
Steam X-Superbox, XR, playing X4
WIndows-10
Intel I7-3770
16Gb Memory
Nvgidia GTX-1060

Browser_ice
Posts: 477
Joined: Sun, 5. Feb 06, 18:15
x4

Re: Side and bottom thrusters ON when travelling in a straight line?

Post by Browser_ice » Tue, 15. Jun 21, 19:04

Hummm, seams harder to reproduce then I thought.

I tried 5 different small ships of different kinds and could not reproduce it.

I know it happens at least on the Elite Avant Guarde we get from one of the start missions but even restarting the mission did not help to reproduce it.

Either there are special conditions to reproduce it

or

somehow it got fixed?

I do not recall when last time I had this but its no more then 2 months. I have a screenshot from March but I cannot tell if I took it when I was in travel mode (not seeing the dust lines going by)


Anyone ever noticed this ?
Steam X-Superbox, XR, playing X4
WIndows-10
Intel I7-3770
16Gb Memory
Nvgidia GTX-1060

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 24708
Joined: Fri, 16. Apr 04, 19:21
x4

Re: Side and bottom thrusters ON when travelling in a straight line?

Post by Alan Phipps » Tue, 15. Jun 21, 23:15

Have you considered that the only reason you are travelling in a straight line is because the ship AI is continuously controlling the ship with varying thrust vectors? There could be gravity pulls from nearby planets, moons and asteroids, let alone capital ship and station field effects. (OK, that's not really a serious explanation but it could be part of your roleplay. :wink: )
A dog has a master; a cat has domestic staff.

Jawms
Posts: 346
Joined: Thu, 30. Dec 10, 07:13
x4

Re: Side and bottom thrusters ON when travelling in a straight line?

Post by Jawms » Wed, 16. Jun 21, 01:25

Do you use a stick, and if so, is it drifting? When you input even the smallest course change while in travel mode it puts the animation for the thrusters at 100%. If your stick is inputting a touch, maybe that's what your seeing?

Browser_ice
Posts: 477
Joined: Sun, 5. Feb 06, 18:15
x4

Re: Side and bottom thrusters ON when travelling in a straight line?

Post by Browser_ice » Tue, 27. Jul 21, 19:17

Sorry for taking long. I was busy.

I only use mouse + keyboard + vanilla game.

I was travelling through multiple sectors to get to asteroid belt with Auto-pilot. I was busy managing my ships then when I switched into F2 view, I notice the issue was happening.

I took 2 screenshots.

As I entered The Void, I took the first picture: right side thrusters were ON
https://steamuserimages-a.akamaihd.net/ ... rbox=false

Then when entering Getsu Fune, the thrusters were now on the left side.
https://steamuserimages-a.akamaihd.net/ ... rbox=false

Then when entering Asteroid Belt, thrusters were still on left side.

I think this issue sometimes happen when exiting gates and travelling in a straight line. If ship does a turn, issue is not happening.
Steam X-Superbox, XR, playing X4
WIndows-10
Intel I7-3770
16Gb Memory
Nvgidia GTX-1060

Imperial Good
Moderator (English)
Moderator (English)
Posts: 2600
Joined: Fri, 21. Dec 18, 19:23
x4

Re: [1334]Side and bottom thrusters ON when travelling in a straight line?

Post by Imperial Good » Thu, 29. Jul 21, 04:12

I think the thrusters react based on the direction the ship is moving, which might not be the direction it is propelling itself. L and XL ships as well as asteroids have gravity wells which will pull your ship along slightly. The thrusters may be reacting to the forces these wells apply to it.

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 24708
Joined: Fri, 16. Apr 04, 19:21
x4

Re: [1334]Side and bottom thrusters ON when travelling in a straight line?

Post by Alan Phipps » Thu, 29. Jul 21, 09:38

See, IG agrees with me. :D
A dog has a master; a cat has domestic staff.

Post Reply

Return to “X4: Foundations - Technical Support”