X-Rebirth: Gameplay degrading the longer you play?

Ask here if you experience technical problems with X Rebirth.

Moderator: Moderators for English X Forum

Post Reply
Nagittchi
Posts: 417
Joined: Fri, 15. Jul 11, 01:44
x4

X-Rebirth: Gameplay degrading the longer you play?

Post by Nagittchi » Mon, 29. Aug 16, 08:45

In my unmodded campaign, unmodded newgame, then unmodded newgame to modded, I've noticed that the game FPS starts to get choppy after maybe 1-2d of gameplay time.

I remember in the X3 series there was an issue where the more sectors you found, the more missions it generates, which causes performance to decreasing dratstically over time. This was fixed with a mod to remove any random missions from popping up again from the mission computer.

Is there anything like that for X-Rebirth? Or has anyone experienced the same issue?

I just started a new game and the FPS is silky smooth - but I do know that it will degrade over time as I discover more sectors and stations again...

Rig shouldn't be an issue. Running a 6700k @ 4.7Ghz, 16GB of RAM and a 980.

Zetoss
Posts: 361
Joined: Tue, 18. Dec 07, 01:17
x4

Post by Zetoss » Wed, 31. Aug 16, 00:24

Have you tried playing another start without campaign for a few days to see if the same thing happens?

There was a bad leak once (if anyone remembers the highway sign bug) but that hole got plugged ages ago and since then I've put up to 300 hours into more than one gamestart without any noticeable difference in performance after the game has adapted to the current state of the universe, influenced almost entirely by campaign progress and difficulty.

My hardware is no longer up to the task of running XR smoothly with all DLC on the highest difficulty due to the ridiculous spawning of ships and having played a total of over 2k hours I'm "done" and basically waiting for the next game instead so throwing ideas in here is about as helpful as I'm gonna get in the matter.

The only things I've seen happen were the above mentioned influence of story progression (PMC picking fights non-stop with a thousand NPCs was a bit unhelpful for my fps) and game difficulty, however the impact of difficulty should stabilize after just a few hours.

<Paragraphed. AP>

ruedigerhansen
Posts: 13
Joined: Wed, 13. Apr 11, 16:04
x3

Post by ruedigerhansen » Fri, 2. Sep 16, 08:18

Hey

I would also be interested in a solution (or at least in an explanation) for this behaviour.
Got the same problem a few days ago. Played the campaign (~40hours), then installed a few mods (CWIR, Exploration software, YAT2) and played another 10 hours. All of a suddenly the frame rate drastically droped to a point where the game was not playable anymore. Had to start a new game, but now am afraid this will happen again after a while :(

Any ideas what might cause this or how to prevent this?

Thanks

ajax34i
Posts: 1805
Joined: Tue, 8. Sep 09, 01:32
x3tc

Post by ajax34i » Fri, 2. Sep 16, 13:29

I haven't noticed a degradation from day to day, but I do have loss of FPS when playing the game uninterrupted for more than a few hours.

I have a software overlay that shows me the video card usage (percent load, temperature, fan speed, VRAM used), and when it starts the game uses 800 MB video RAM, but as you play on, especially when you move from zone to zone and sector to sector, the video RAM usage increases, slowly.

My card is relatively new and has 4 GB of VRAM, but I start noticing lowered frame rates at about 2000 MB used (after about 4 hours), and it really gets bad at about 2500 MB used (about 6 hours).

Have to exit to desktop and then restart the game to restore responsiveness and get it back to 800 - 1500 range.

If you have a video card that only has 2 GB video RAM, you will probably have horrible frame rates as soon as you hit the limit of 2000 MB VRAM used. Because your video card will have to swap textures out of memory at that point in time.

Day-to-day degradation, I don't know. I just finished the plot, so I haven't played for too long. It took me several weeks to finish it, though. I know that performance drops to 1 FPS if it has to search the hard drive for some missing asset, but I've only had to restart it once, because of that.

EDIT: I am manually copying my savegames out of the default folder to back them up, and I haven't noticed a drastic increase in size for the files as the game progressed. 2 MB for a new game, to 6 MB now, eh. Mentioning this, because given your hardware specs, the only source of the issue can be that it's accessing the hard disk too much. HD access is way too slow to provide any sort of decent frames per second if the game is frozen waiting for a file to open.

I don't have access to the game right now, but my next test would be to use imdisk to create a virtual hard drive in 8 of your 16 GB of memory, and try to put some of the game files and the save files there. If the problem goes away because you're now accessing assets from RAM, then it's definitely hard drive related.

Note that you'll have to create hard links to folders instead of just shortcuts to folders, to trick windows into thinking that the X-Rebirth game folder is still a sub-folder of steamapps, when in fact it's in the imdisk virtual disk inside your RAM now. And keep in mind that if you shut down, everything inside RAM gets erased.

I'll try to play with it tonight and post my findings tomorrow.

Post Reply

Return to “X Rebirth - Technical Support”