EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
Buzzing sound in main menu X3 Reunion - resolved by fps cap
Post new topic Reply to topic
View previous topic :: View next topic
Author Message
ucheehQ





Joined: 16 Aug 2016



PostPosted: Tue, 16. Aug 16, 04:59    Post subject: Buzzing sound in main menu X3 Reunion - resolved by fps cap Reply with quote Print

Hi people, I have a possibly important question.
I used to play a lot of Reunion a couple years back and decided to start playing it again this week. I've since upgraded my computer, most importantly (because I highly suspect it's related to my issue) with an AMD Radeon 290x.
Now, the problem I have is, whenever I start up the game, everything *seems* to be working fine, but the whole duration while I'm in the main menu, my computer makes this buzzing or whirring noise, akin to a mosquito.
I suspect the menu displays at some insanely high FPS because reasons, since it figures my pc can easily handle it, which makes my graphics card go haywire to keep up.
As soon as I load up my save the noise stops, so most times it won't do it for more than a few seconds, but I'm worried it might do some damage in the long run.
Anyone have some experience with this, know exactly what's going on, and/or know how to fix it?

Thanks.

Back to top
View user's profile Send private message
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17199 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Tue, 16. Aug 16, 14:02    Post subject: Reply with quote Print

If you think it is your graphics card running away on the menu screen then you should be able to set an fps maximum cap for the X3 exe either in your AMD control panel or using a profiler application such as RadeonPro.

At least doing that would eliminate or confirm that issue possibility. Also you could check for yourself what the fps values are in-game by using something like FRAPS.


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
ucheehQ





Joined: 16 Aug 2016



PostPosted: Tue, 16. Aug 16, 14:37    Post subject: Reply with quote Print

I did some checks as suggested. I also found out that the splash screen and intro movie also caused the sound, but at a higher pitch where it blended in with the game's sounds.
Turns out, splash screen and intro movie showed at 1700 fps, while the main menu went down to around 450. In-game it's mostly 120-130, sometimes dips to 100.

So I downloaded RadeonPro, put in an FPS cap at 120 and tried it: works perfectly!

Thanks for helping out, you're a champ.

Back to top
View user's profile Send private message
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17199 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Tue, 16. Aug 16, 14:56    Post subject: Reply with quote Print

Good to hear and I hope that you enjoy the game.

(Also I think I'm lucky if I ever get more than ~50 fps in games! Very Happy )


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Mon, 22. Jan 18, 01:53

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2018
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.06606 seconds, sql queries = 18