EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
x2 stays in windowed mode after upgrade from win8.1 to win10 - easy workaround aval.
Post new topic Reply to topic
View previous topic :: View next topic
Author Message
chrismokvack



MEDALMEDALMEDAL

Joined: 27 Dec 2010
Posts: 100 on topic

Thank you for registering your game
PostPosted: Sat, 2. Jan 16, 11:20    Post subject: x2 stays in windowed mode after upgrade from win8.1 to win10 - easy workaround aval. Reply with quote Print

Ever since I upgraded from windows 8.1 to windows 10, x2 the threat runs in a window that covers the entire screen. I tried changing to various different resolutions, but the problem persists. I can't seem to find any setting for fullscreen. Any solution?

Back to top
View user's profile Send private message
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17206 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Sun, 3. Jan 16, 15:16    Post subject: Reply with quote Print

We know that Win10 and X2 sometimes throw up unsupported resolutions so perhaps try again using a resolution that your monitor is comfortable with and see if that helps.

An old thread also said that reinstalling DirectX 9.0c can sometimes help with this type of issue.

You could try adding -f to the command line of the exe or shortcut that runs the game to see if that forces fullscreen mode.


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
chrismokvack



MEDALMEDALMEDAL

Joined: 27 Dec 2010
Posts: 100 on topic

Thank you for registering your game
PostPosted: Sun, 3. Jan 16, 15:38    Post subject: Reply with quote Print

Ye I read the compatibility notes for windows 10, that's why I tried with different resolutions. I tried the ones I recognized from before. Now I've tested every single one, and the only difference is the size and shape of the window. None of them will give me full screen. I found the fullscreen/windowed setting - it was staring me at the face all along, but apparantly it was already set to fullscreen. I've already installed DirectX 9c for another game, so that's not the issue. -f didn't do the trick.

Back to top
View user's profile Send private message
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17206 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Sun, 3. Jan 16, 16:18    Post subject: Reply with quote Print

If this is a Steam version you can check the Steam game set-up options. Here is a method to get borderless windowed mode which some like as it has the screen usage advantages of full screen mode while making switching to other apps using Alt-Tab really safe and simple.
    To get borderless windows:

    1.Go to SET LAUNCH OPTIONS
    2.Add "/borderless /windowed" no quotes
    3.Start game and turn-off full screen



_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
chrismokvack



MEDALMEDALMEDAL

Joined: 27 Dec 2010
Posts: 100 on topic

Thank you for registering your game
PostPosted: Sun, 3. Jan 16, 19:26    Post subject: Reply with quote Print

Apparently I can't set my native resolution in windowed mode (though it does work in fullscreen mode), so I can only get a window smaller than my screen. Antialiasing doesn't work in windowed mode either. so even if I could get rid of the border this way I'm not sure it would be an overall improvement.

Back to top
View user's profile Send private message
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17206 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Sun, 3. Jan 16, 21:58    Post subject: Reply with quote Print

I'm running out of ideas, sorry. Hopefully a current X2 player using Win10 may be able to help you further.


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
shawncrites





Joined: 27 Feb 2006
Posts: 5 on topic

Thank you for registering your game
PostPosted: Tue, 5. Jan 16, 23:29    Post subject: Reply with quote Print

Smae issue here too!! I have tried everything X3 reunion and up run fine but any X game under that will not run in fullscreen mode even if its checked or -f is in the line!! It has to besomething within the ini or Direct x I just cant figure out what!! Maybe Egosoft could figure it out and update the .exe I bought the superbox off of steam along with the X rebirth!!

Back to top
View user's profile Send private message Yahoo Messenger
chrismokvack



MEDALMEDALMEDAL

Joined: 27 Dec 2010
Posts: 100 on topic

Thank you for registering your game
PostPosted: Thu, 21. Jul 16, 00:08    Post subject: Reply with quote Print

Looks like a solution has finally been found, and it was a ridiculously easy one: https://www.youtube.com/watch?v=T5qcathK4Mk

After you have starteded X2, open the task manager, go to the process tab, find x2, expand it, right click x2 and click maximize.

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Wed, 24. Jan 18, 03:25

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2018
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 3.02327 seconds, sql queries = 22