EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
[Official Mod Development Bug Reports] A Thread for Mod Creators
Post new topic Reply to topic Goto page Previous  1, 2, 3 ... 14, 15, 16
View previous topic :: View next topic
Author Message
UniTrader
Moderator (Script&Mod)
Moderator (Script&Mod)

MEDAL

Joined: 20 Nov 2005
Posts: 13650 on topic

Thank you for registering your game
PostPosted: Fri, 9. Jun 17, 17:37    Post subject: Reply with quote Print

Marvin Martian wrote:
have you tried [[a,1]], in think to rember Station-Info-UI also can't handle stations without any sort of upgrade-path, maybe something related


nah, the problem was really only the missing '' - Game cannt handle a buildplanlist containing [[ null , 0 ]] and Crashes to Desktop (which should never happen from within a Scriipting Language, thats why i am reporting it Wink i fixed this mistake in my Script already and not it works)

btw [ 'a' , 0 ] usually refers to the basic Station (at least thats what my logging of the Vanilla Build Process indicated)


_________________
if not stated otherwise everything i post is licensed under WTFPL

Ich mache keine S&M-Auftragsarbeiten, aber wenn es fragen gibt wie man etwas umsetzen kann helfe ich gerne weiter Wink

I wont do Script&Mod Request work, but if there are questions how to do something i will GLaDly help Wink
Back to top
View user's profile Send private message
UniTrader
Moderator (Script&Mod)
Moderator (Script&Mod)

MEDAL

Joined: 20 Nov 2005
Posts: 13650 on topic

Thank you for registering your game
PostPosted: Thu, 22. Jun 17, 17:24    Post subject: Reply with quote Print

next issue:

regarding the Commands
<connect_to_trade_location ship="this.ship" tradedock="if true then $parkslot else 'Unark Signal 1'" result="$success" />
and
<disconnect_from_trade_location ship="this.ship" />

i have the impression that the blocking mechanism included in them does not work properly, at least on CVs which have the oddity that multiple Parking Slots ( from <find_tradeoffer_parking_slot/> ) refer to the same park position. i already tried to force docking Ships to only use one of them, but to no avail, after several hours of leaving it running multiple Ships attempt to Dock simultaneously.at the same Parking Place.... (and yes, before attempting parking i always check the result of <connect_to_trade_location/> )
When i checked the current parking Scripts i noticed that they now include a proper queue. iirc when i wrote my own Docking Scripts (which started more than a year ago) this was not yet the case, and ships polled for free parking Slots until they got one, so i assumed this result was reliable enough to prevent this..


_________________
if not stated otherwise everything i post is licensed under WTFPL

Ich mache keine S&M-Auftragsarbeiten, aber wenn es fragen gibt wie man etwas umsetzen kann helfe ich gerne weiter Wink

I wont do Script&Mod Request work, but if there are questions how to do something i will GLaDly help Wink
Back to top
View user's profile Send private message
Charon_A





Joined: 06 Nov 2002

Location: Argon Prime

modified
PostPosted: Sun, 13. Aug 17, 17:13    Post subject: Reply with quote Print

Found a mod "Silent skunk" that turns off sound of engine and boost but it does not work for me, v4.10
It updates libraries/sound_library.xml
Code:

<remove sel="//sound[@id='engine_booster']/sample" />
<add sel="//sound[@id='engine_booster']">
<sample start="sfx\dummysilence" /> </add>

Tried to change it to use replace instead, but it did not help. Anyone has a clue how to make this code work? Thanks!
Code:

<replace sel="//sound[@id='engine_booster']/sample" >
<sample start="sfx\dummysilence" /> </replace>



_________________
Be careful about reading health books. You may die of a misprint.
---Mark Twain---


Last edited by Charon_A on Sun, 13. Aug 17, 17:38; edited 1 time in total
Back to top
View user's profile Send private message
UniTrader
Moderator (Script&Mod)
Moderator (Script&Mod)

MEDAL

Joined: 20 Nov 2005
Posts: 13650 on topic

Thank you for registering your game
PostPosted: Sun, 13. Aug 17, 17:32    Post subject: Reply with quote Print

Log Snippet from Startup please... makes it easier to track down what goes wrong with the mod, especially if its an incompatibility with your other mods unique to you. (also i am not the type to install and test mods for others to fix them - causes too much clutter in my extensions directory..


_________________
if not stated otherwise everything i post is licensed under WTFPL

Ich mache keine S&M-Auftragsarbeiten, aber wenn es fragen gibt wie man etwas umsetzen kann helfe ich gerne weiter Wink

I wont do Script&Mod Request work, but if there are questions how to do something i will GLaDly help Wink
Back to top
View user's profile Send private message
w.evans





Joined: 18 Nov 2014
Posts: 2953 on topic

Thank you for registering your game
PostPosted: Sun, 13. Aug 17, 17:47    Post subject: Reply with quote Print

Charon_A wrote:
Found a mod "Silent skunk" that turns off sound of engine and boost

both snippets should work, except there's a typo in the first snippet (should be "start" rather than "tart", but looks like you spotted that already.)

Not very familiar with the sound effects, but it looks like this will only remove one of the boost sounds. There appears to be more sounds defined for the player ship's engine in sound_library.


_________________
MarineRebalance, BetterAutoAim, SmalltalkHack, Epic Capital Ship Shields, Miscellaneous IZ Combat Tweaks, Miscellaneous OOZ Combat Tweaks
Back to top
View user's profile Send private message
Charon_A





Joined: 06 Nov 2002

Location: Argon Prime

PostPosted: Sun, 13. Aug 17, 17:53    Post subject: Reply with quote Print

Thanks guys, that's what I needed Exclamation
Did not know that game writes "Log Snippet from Startup" Razz
Log pointed me to the issue - apparently I messed the mod up by directly editing packed dat file. Ignore me, mod works fine. Thanks for quick replies!


_________________
Be careful about reading health books. You may die of a misprint.
---Mark Twain---
Back to top
View user's profile Send private message
Charon_A





Joined: 06 Nov 2002

Location: Argon Prime

PostPosted: Sun, 13. Aug 17, 19:34    Post subject: Reply with quote Print

While you're so kind to me, cannot pass up on the opportunity to ask Wink
When I kill random enemies near the stations I get 2 comm events: one saying thanks for taking care of enemies and another about paying me creditsss.
Could you point me in the direction of a file where this comm channels are being generated? I can live with notifications but would very much like to get rid of animated comms that block access to the menu.
Or maybe there's already a mod around that solve this problem? Any insight will be much appreciated!


_________________
Be careful about reading health books. You may die of a misprint.
---Mark Twain---
Back to top
View user's profile Send private message
UniTrader
Moderator (Script&Mod)
Moderator (Script&Mod)

MEDAL

Joined: 20 Nov 2005
Posts: 13650 on topic

Thank you for registering your game
PostPosted: Mon, 14. Aug 17, 06:04    Post subject: Reply with quote Print

iirc this is done in the md/notifications.xml


_________________
if not stated otherwise everything i post is licensed under WTFPL

Ich mache keine S&M-Auftragsarbeiten, aber wenn es fragen gibt wie man etwas umsetzen kann helfe ich gerne weiter Wink

I wont do Script&Mod Request work, but if there are questions how to do something i will GLaDly help Wink
Back to top
View user's profile Send private message
Charon_A





Joined: 06 Nov 2002

Location: Argon Prime

PostPosted: Mon, 14. Aug 17, 10:25    Post subject: Reply with quote Print

Thanks, UniTrader!
Found the little bugger. So much better now Smile
In case anyone needs to remove these annoying reward comms after killing enemies:
Code:

<diff>
<remove sel="//cue[@name='ReputationTrigger']/actions/do_if/do_if/start_conversation" /> 
</diff> 



_________________
Be careful about reading health books. You may die of a misprint.
---Mark Twain---
Back to top
View user's profile Send private message
donzi



MEDALMEDAL

Joined: 12 Feb 2007
Posts: 851 on topic

Thank you for registering your game
PostPosted: Sat, 2. Jun 18, 12:07    Post subject: minor kink with enable/disable due to certain content.xml Reply with quote Print

I've been working on a few small mods and have been using a boilerplate content.xml ( re: Steam Workshop for X Rebirth ) for each of them, just adjusting name and description.

id="totally_unimportant" is apparently not quite so in all contexts. It leads to the side effect of not being able to enable/disable the extensions as expected when this is assigned the same string across multiple extensions.

Unique or empty id are fine.

Back to top
View user's profile Send private message
UniTrader
Moderator (Script&Mod)
Moderator (Script&Mod)

MEDAL

Joined: 20 Nov 2005
Posts: 13650 on topic

Thank you for registering your game
PostPosted: Sat, 2. Jun 18, 14:58    Post subject: Re: minor kink with enable/disable due to certain content.xml Reply with quote Print

donzi wrote:
id="totally_unimportant" is apparently not quite so in all contexts. It leads to the side effect of not being able to enable/disable the extensions as expected when this is assigned the same string across multiple extensions.


from where did you get that the mod id was unimportant? i think every docrelated to it should point out that this is an unique identifier for each mod to differ between them.. if left out or empty the extension folder name is instead used as id btw. The only exception i could imagine is when uploading to the steam workshop because in this case the id will be changed...


_________________
if not stated otherwise everything i post is licensed under WTFPL

Ich mache keine S&M-Auftragsarbeiten, aber wenn es fragen gibt wie man etwas umsetzen kann helfe ich gerne weiter Wink

I wont do Script&Mod Request work, but if there are questions how to do something i will GLaDly help Wink
Back to top
View user's profile Send private message
X2-Illuminatus
Moderator (Deutsch)
Moderator (Deutsch)

MEDALMEDALMEDAL

Joined: 02 Apr 2006
Posts: 20717 on topic

Thank you for registering your game
PostPosted: Sat, 2. Jun 18, 17:21    Post subject: Reply with quote Print

UniTrader wrote:
from where did you get that the mod id was unimportant?


From the example code in the linked tutorial for uploading mods to the Steam Workshop for X Rebirth.

Quote:
Example for a content.xml to publish a new extension:

Code:
<?xml version="1.0" encoding="utf-8" ?>
<!-- My Test Extension v0.10 -->
<content id="totally_unimportant" name="My Test Extension" description="This is just an example." version="10">
  <!-- Requires Workshop item 12345, minimum version 1.00 -->
  <dependency id="ws_12345" version="100" />
  <!-- Requires minimum game version 1.50 -->
  <dependency version="150" />
  <!-- Optional localisation (NOTE: not visible in Steam Workshop, cannot be updated from Workshop website) -->
  <!-- German: -->
  <text language="49" name="Meine Test-Erweiterung" description="Dies ist nur ein Beispiel." />
</content>


Minimalistic example:

Code:
<?xml version="1.0" encoding="utf-8" ?>
<content id="" name="Foo" description="Test" version="100">
</content>



_________________
Besteht Interesse an einem Nopileos-Hörbuch?

Farnhams Legende und Nopileos als E-Books!

"People who think they know everything are a great annoyance to those of us who do." - Isaac Asimov

"If it's not impossible, there must be a way to do it." - Sir Nicholas Winton
Back to top
View user's profile Send private message
donzi



MEDALMEDAL

Joined: 12 Feb 2007
Posts: 851 on topic

Thank you for registering your game
PostPosted: Wed, 6. Jun 18, 00:33    Post subject: Re: minor kink with enable/disable due to certain content.xml Reply with quote Print

UniTrader wrote:
from where did you get that the mod id was unimportant?

The link in my message up there Very Happy -- ( re: Steam Workshop for X Rebirth )

I thought that I'd pass over that since X2-Illuminatus poked you already, but since you're a moderator.. Laughing

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic Goto page Previous  1, 2, 3 ... 14, 15, 16
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Control Panel
Login Data
The time now is Wed, 18. Jul 18, 19:52

All times are GMT + 2 Hours

[ Disclaimer / Impressum ] | [ Privacy Policy / Datenschutz ]

Board Security

Copyright © EGOSOFT 1989-2018
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.10835 seconds, sql queries = 27