EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
OS X support thread
Post new topic Reply to topic Goto page Previous  1, 2, 3, 4, 5  Next
View previous topic :: View next topic
Author Message
rboerdijk
EGOSOFT
EGOSOFT



Joined: 11 Jan 2013
Posts: 767 on topic
Location: The Neverlands
Thank you for registering your game
PostPosted: Fri, 13. Nov 15, 22:04    Post subject: Reply with quote Print

Thanks for the feedback,

For the xbox controller you have to have some driver installed - otherwise osx doesn't support it. I'm not behind my machine, so I can't check exactly which one I'm using ( and I tested under yosemite, upgraded my machine today to E Capitan and will retest on monday ).

Strange that there is no reaction at all from the joystick, will also retest that locally... Did anyone else get it to work ?

Back to top
View user's profile Send private message
Haudrauf





Joined: 13 Nov 2015

Location: The FR of G

PostPosted: Fri, 13. Nov 15, 22:08    Post subject: Reply with quote Print

I have installed the XBox 360 controller driver 0.15 beta 3. With this driver the x360 works fine with every game except Rebirth.

Back to top
View user's profile Send private message
rboerdijk
EGOSOFT
EGOSOFT



Joined: 11 Jan 2013
Posts: 767 on topic
Location: The Neverlands
Thank you for registering your game
PostPosted: Fri, 13. Nov 15, 22:26    Post subject: Reply with quote Print

Hmm.. strange... "it worked on my machine" (tm). I asked the guys in the Linux forum to give it a test on that OS too ( it's the same code). Either way I'll retest this on monday.

One more question, if you go into the controller menu, does it show anything ( like "xbox controller") - or is it completely empty ?

Back to top
View user's profile Send private message
Haudrauf





Joined: 13 Nov 2015

Location: The FR of G

PostPosted: Fri, 13. Nov 15, 22:41    Post subject: Reply with quote Print

It's completely empty. No entry for the X360 or the Thrustmaster Hotas.

Back to top
View user's profile Send private message
rboerdijk
EGOSOFT
EGOSOFT



Joined: 11 Jan 2013
Posts: 767 on topic
Location: The Neverlands
Thank you for registering your game
PostPosted: Sat, 14. Nov 15, 01:07    Post subject: Reply with quote Print

... and I assume you are running build "3.61 Build 19 (202267)" ?

Back to top
View user's profile Send private message
Haudrauf





Joined: 13 Nov 2015

Location: The FR of G

PostPosted: Sat, 14. Nov 15, 02:14    Post subject: Reply with quote Print

No. The game shows me 3.61 (200382 OSX 18 ). This is the newest version Steam offers me.
If it will be useful for you: Steam says the actual content build ID is 821169.

Back to top
View user's profile Send private message
rboerdijk
EGOSOFT
EGOSOFT



Joined: 11 Jan 2013
Posts: 767 on topic
Location: The Neverlands
Thank you for registering your game
PostPosted: Mon, 16. Nov 15, 11:04    Post subject: Reply with quote Print

Can you try again? It should now show 3.61 (202267 build 19).

For the Joystick load the "Joystick (osx/linux)"-profile for some (hopefully) somewhat decent mappings. And you can always remap it yourself.

For reference, I'm using the "XBox 360 controller driver version 0.14" - that one works for Yosemite ( didn't test yet under El Capitan ).

Back to top
View user's profile Send private message
Haudrauf





Joined: 13 Nov 2015

Location: The FR of G

PostPosted: Mon, 16. Nov 15, 21:27    Post subject: Reply with quote Print

I give it another try with build 19. Both my x360 and my Hotas are working well. I can configure them as I like to and was able to save and manage my settings.
FYI the x360 works great with XBOX 360 Controller Driver 0.15 (Beta 3).
Thanks for your support!

But there are some other issues with the game.
1. Sometimes the game freezes.
The OS shows me the spinning beachball of death . There are still some noises from the environment in the background but I cannot do anything in the game. In this case I have to force quit the game. I have bought the game a few days ago and played it just for a couple of hours(less then ten hours). During this time I have three freezes.
2. There are some issues with the subtitles.
The subtitles are not synchronized with the voices. The subtitles are far behind the spoken words. When I switch the subtitles off the last few words were always shown.


_________________
Dagegen!
Back to top
View user's profile Send private message
rboerdijk
EGOSOFT
EGOSOFT



Joined: 11 Jan 2013
Posts: 767 on topic
Location: The Neverlands
Thank you for registering your game
PostPosted: Thu, 19. Nov 15, 12:58    Post subject: Reply with quote Print

Haudrauf wrote:

2. There are some issues with the subtitles.
The subtitles are not synchronized with the voices. The subtitles are far behind the spoken words. When I switch the subtitles off the last few words were always shown.


We have a fix for this in 4.0 versions - note that it's unlikely we will do another update for 3.61 on the osx/linux branches, so it might take some time before you can try it.

Back to top
View user's profile Send private message
rboerdijk
EGOSOFT
EGOSOFT



Joined: 11 Jan 2013
Posts: 767 on topic
Location: The Neverlands
Thank you for registering your game
PostPosted: Thu, 19. Nov 15, 13:02    Post subject: Reply with quote Print

Haudrauf wrote:

1. Sometimes the game freezes.
The OS shows me the spinning beachball of death . There are still some noises from the environment in the background but I cannot do anything in the game. In this case I have to force quit the game. I have bought the game a few days ago and played it just for a couple of hours(less then ten hours). During this time I have three freezes.


These kind of issues are always hard to fix, because it's usually hard to reproduce - and good repro cases make it much easier to find.

Is there anything specific you were doing?
Are you playing in fullscreen or windowed - and did you switch to another app?
Were you playing the "campaign" (if so, roughly where in the campaign did it happen) or "free play" ?

Another question, what hardware do you have ( macbook, imac - which GPU ? ).

Back to top
View user's profile Send private message
Haudrauf





Joined: 13 Nov 2015

Location: The FR of G

PostPosted: Fri, 20. Nov 15, 22:18    Post subject: Reply with quote Print

rboerdijk wrote:

Is there anything specific you were doing?


No.

rboerdijk wrote:

Are you playing in fullscreen or windowed - and did you switch to another app?


Fullscreen - No

rboerdijk wrote:

Were you playing the "campaign" (if so, roughly where in the campaign did it happen) or "free play" ?


I play the campaign.
1. It happens one time when I start the Game. The program icon was jumping in the dock and nothing happens. The beachball of death was rotating endless. I have to force quit Rebirth.
2. It happens at the beginning of the campaign when I was told to hold Yisha onboard. After that dialog I entered the menu to look at something (I don't remember what). Approximately one or two seconds after I left the menu the game freezes.
3. I flew in space on my way to my freighter hidden in an ice asteroid field. During my flight the game freezes.


rboerdijk wrote:

Another question, what hardware do you have ( macbook, imac - which GPU ? ).


iMac 27" late 2013, 3,4 GHz Core i5, 16GB RAM, GTX 780M 4GB
OSX El Capitan 10.11.1


_________________
Dagegen!
Back to top
View user's profile Send private message
rboerdijk
EGOSOFT
EGOSOFT



Joined: 11 Jan 2013
Posts: 767 on topic
Location: The Neverlands
Thank you for registering your game
PostPosted: Fri, 20. Nov 15, 23:25    Post subject: Reply with quote Print

Thanks for the info, I'll try early next week and see if I can get a freeze on my system. I do know of another similar issue under El Capitan, but that happened when switching into side-by-side fullscreen ( that should be fixed in our internal builds and it didn't happen on my iMac ).

If you have any other such freezes, please report back with a short description of what happened, maybe we can narrow down when it happens (or at least get an estimate on how often it happens ).

Back to top
View user's profile Send private message
Eriru Drourojj



MEDALMEDALMEDAL

Joined: 29 Oct 2005
Posts: 98 on topic
Location: UK
Thank you for registering your game
PostPosted: Mon, 14. Dec 15, 18:39    Post subject: Reply with quote Print

Hi,

Still having the same issue with the loading times, upside something changed possibly a driver update I downloaded but my Xbox one controller now works with rebirth.

Also can anyone confirm that Ren's cockpit chair animation still isn't right, I haven't been able to find a post I made a while ago(not sure how to use the forums search functions effectively still) The chair turns toward the central display in the cockpit when entering but doesn't turn fully or move back. I get this in any new game starts in either OS X el capitan and win 8.1 bootcamp.


_________________
Ever since man first left his cave and met a stranger with a different language and a new way of looking at things, the human race has had a dream, to kill him so we don't have to learn his language or his new way of looking at things!!! - Zap Brannigan
Back to top
View user's profile Send private message MSN Messenger
toby_p





Joined: 03 Oct 2015
Posts: 7 on topic

Thank you for registering your game
PostPosted: Mon, 1. Feb 16, 13:21    Post subject: No repairs Reply with quote Print

Hi,

first of all: great work on the OS X version! I am not sure why you still call it "Alpha", it is working really really well!
However, I have encountered a strange problem: in my game, no hull repairs are getting done. Neither for ships nor stations. Yes, my ships have 5* engineers AND construction drones aboard, but they're not getting repaired. Sometimes not even in shipyards: I order them to repair, they take my money, the ship docks, some time passes and it undocks again, with the same low hull percentage as before!
The point where this gets really annoying is stations. I assume (correct me if I'm wrong) that NPC stations are supposed to repair damaged modules over time. Well, mine don't. This means that every module that was ever destroyed by the omnipresent Heretic Vanguards or other pirates stays this way. The problem is that the destroyed modules usually are storage modules - so now all those stations can't store the resources needed to produce their products anymore, which means the economy totally stalls. I have trade agents on every single station in OL and there is currently no Bio-Electric Neurogel and no BoFu offered in the whole system. I am aware that production may slow down due to various reasons, so I went to those stations and checked them out. They do not have any trade offers to buy the resources they need and when I check their storage, it says 0/0 - so if I get it correctly, they cannot store the resources because their storage is destroyed.

My system:
MacBook Pro 15" Retina Mid '14
2,5 Ghz Intel i7
16 GB RAM
Intel Iris Pro & Nvidia GeForce GT 750M

Game:
X Rebirth 4.0 Beta 6 Hotfix 1
No mods are or ever were installed.

The reason I am reporting this here is that I tried to play my save game on Windows 8.1 and all my ships immediately started repairing themselves.
Should I also report this in the Bug Tracker or do you generally do that?

Back to top
View user's profile Send private message
timon37
EGOSOFT
EGOSOFT

MEDALMEDALMEDAL

Joined: 14 Dec 2012
Posts: 334 on topic

Thank you for registering your game
PostPosted: Mon, 1. Feb 16, 18:28    Post subject: Re: No repairs Reply with quote Print

@toby_p

Could you upload your savegame somewhere? Alternatively send it to my or Rogers email (top of first post).

We currently prefer if you just directly post to the bug-tracker (it's anonymous so include your forum name), and keep the threads more for discussions and "request for someone to reproduce an issue". Though you don't have to create the issue now.

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic Goto page Previous  1, 2, 3, 4, 5  Next
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum
Control Panel
Login Data
The time now is Mon, 20. Aug 18, 03:24

All times are GMT + 2 Hours

[ Disclaimer / Impressum ] | [ Privacy Policy / Datenschutz ]

Board Security

Copyright © EGOSOFT 1989-2018
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.11171 seconds, sql queries = 29