[Mod] Show Skills

The place to discuss scripting and game modifications for X Rebirth.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

StormMagi
Posts: 1208
Joined: Sat, 17. Mar 07, 04:53
x4

Post by StormMagi » Fri, 19. Dec 14, 00:48

I cleared my saves and started fresh for 3.0 so I don't have a fleet yet.

The main way I tested was with the merchant start and just shot up the engines on the freighter you get. Without the mod the engineer took a little bit of time to analyze modules then sent the construction urvs out to repair. With the mod running it wouldn't go past analyzing modules. When I saved mid repair and enabled mod it reverted to analyzing modules and the construction urvs got stuck in a loop going between both ends of the freighter.

Any tests I attempted on the Skunk ended with the Skunk blowing up due to me not preparing properly or too many enemies.

The freighter tests got the same result as the initial testing on an Arawn according to a mod user on Steam (which I posted earlier).
MOD XR Show Skills

Flying spaceships since 1993.

UniTrader
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 13817
Joined: Sun, 20. Nov 05, 23:45
x4

Post by UniTrader » Fri, 19. Dec 14, 01:25

i just had a short look into this issue:

The Engineer is not broken per se, he repairs Components just fine ;) (tested with some hacked in time acceleration) problem is the Display of his Action is not reflecting this, it stays at scanning components even though he is practically repairing. currently doing a search through the whole game data to find out where the commandaction is connected to the t-file or updating the UI because i couldnt find this in the ui, aiscript or md folder, but its getting late here so thats probably all for now..
if not stated otherwise everything i post is licensed under WTFPL

Ich mache keine S&M-Auftragsarbeiten, aber wenn es fragen gibt wie man etwas umsetzen kann helfe ich gerne weiter ;)

I wont do Script&Mod Request work, but if there are questions how to do something i will GLaDly help ;)

w.evans
Posts: 2954
Joined: Tue, 18. Nov 14, 17:23
xr

Post by w.evans » Fri, 19. Dec 14, 01:25

Did as StormMagi suggested, and did a Merchant Start:

Blew up an engine of the Styrvok. A Marauding Titurel then appeared, so I thought that I'd test my MarineRebalance mod at the same time, so saved, alt-tabbed out, magicked me some cash, hired a marine officer and some cannon fodder, and moved to board the Titurel. Did not manage to disable the Titurel's engines before the Titurel moved close enough to start hitting my Styrvok.

And both tests successful! Styrvok is launching construction URVs, and Engineer's status shows "repairing Styrvok." And my marines are working as expected.

It IS possible that the Engineer will stop at repairing the hull, and won't repair the surface elements. Will report after it's done.

It might have taken a while though. Time flies when you're dodging turret fire.

StormMagi
Posts: 1208
Joined: Sat, 17. Mar 07, 04:53
x4

Post by StormMagi » Fri, 19. Dec 14, 01:29

That would be good to know since I only tested on surface elements.
MOD XR Show Skills

Flying spaceships since 1993.

w.evans
Posts: 2954
Joined: Tue, 18. Nov 14, 17:23
xr

Post by w.evans » Fri, 19. Dec 14, 01:37

Have to keep the Titurel from blowing up the Styrvok, while at the same time keeping the Titurel in one piece first though. Have to get that casualty report.

Way off topic, sorry, but does anyone know how to save edit a capship's hull back up?

edit: no worries. got it.

StormMagi
Posts: 1208
Joined: Sat, 17. Mar 07, 04:53
x4

Post by StormMagi » Fri, 19. Dec 14, 01:51

UniTrader wrote:i just had a short look into this issue:

The Engineer is not broken per se, he repairs Components just fine ;) (tested with some hacked in time acceleration) problem is the Display of his Action is not reflecting this, it stays at scanning components even though he is practically repairing. currently doing a search through the whole game data to find out where the commandaction is connected to the t-file or updating the UI because i couldnt find this in the ui, aiscript or md folder, but its getting late here so thats probably all for now..
Then what about the issue with the URVs? I thought that is what the engineer used to repair the components.
MOD XR Show Skills

Flying spaceships since 1993.

w.evans
Posts: 2954
Joined: Tue, 18. Nov 14, 17:23
xr

Post by w.evans » Fri, 19. Dec 14, 01:56

Boarding and repairing tests are still on-going, but I just thought that I'd report in and say that I checked the Styrvok's Engineer status, and it reads:

"Repairing Matter/Antimatter Drives"

That's with my personal copy though. All of the changes I did to the ShowSkills file were the following:

Code: Select all

<show_help force="true" chance="0" custom="'Revealed skills of NPC %1 (%2), distance=%3, combinedskill=%4'.[event.object, event.object.knownname, event.object.distanceto.{player.entity}, event.object.combinedskill]" />
is commented out, and this:

Code: Select all

xsi:noNamespaceSchemaLocation="../../../modding/md.xsd"
was changed to this:

Code: Select all

xsi:noNamespaceSchemaLocation="md.xsd"
And Show Skills is fully functional.

edit: will report again later when it's done to see if everything is in fact repaired. But display's fine from what I'm seeing.

w.evans
Posts: 2954
Joined: Tue, 18. Nov 14, 17:23
xr

Post by w.evans » Fri, 19. Dec 14, 02:28

Done and done.

Am glad to report that the engines were repaired, and the Engineer status now reads "Repairing Energy Storage." Hull is at 90%, which is evidence of hull repair after the pummeling it took from the Titurel.

The two construction URVs are flitting around the Styrvok, but they oddly have pilots, and their Command status reads "None."

And I must say, off topic though it might be, that the Olmekron is awesome.

So Show Skills apparently works in X Rebirth v3.1. (Am NOT using the Special Test beta version)

Could post a list of the mods I have installed, if that might help.


edit: re-checked the Styrvok and the Engineer's status again reads "Repairing Matter/Antimatter Drive" Moved in close to manually check the drive exhausts one by one, and the one I initially damaged had 59% hull value. I then watched it change to 60%, so it is getting repaired. Last step, I guess, would be to see if the Construction URVs dock after they're done.

For further verification, checked Engineer status in my save file, and it reads:

Code: Select all

<entity id="[0x87c5d7]">
<script id="2356" name="engineer.ai" version="5" label="checkforrepair" time="1198.284" index="6">
<command type="repair"/>
<commandaction type="repairingto">
<param type="component" value="[0x87c562]"/>
</commandaction>
edit 2: just realized that the case with the Engineer in the Styrvok might not be valid because I never asked to see her skills, so ShowSkills never ran on her. Am now monitoring the Titurel to see if they'll repair. Don't know if I should expect the Titurel's engineer to repair though since it doesn't have any Construction URVs.

edit 3: Titurel's Engineer's status now reads "Repairing Jump Tunnel Device"

StormMagi
Posts: 1208
Joined: Sat, 17. Mar 07, 04:53
x4

Post by StormMagi » Fri, 19. Dec 14, 04:02

Interesting... wonder what was going on then. If it was just changing the md file link I doubt I would have thought to check that at all first. If all is good in your tests I will update my copy to change that line and update the mod links :D

Also I noticed the URV pilots too. Couldn't com them when I tried (iirc).

Edit: It is valid, I didn't ask to see the skills on mine when I tested.
MOD XR Show Skills

Flying spaceships since 1993.

ty_cho
Posts: 206
Joined: Tue, 20. Nov 07, 07:39
x3tc

Post by ty_cho » Fri, 19. Dec 14, 05:50

I'll say it again, the only problem I've ever experienced with engineers is it showing the construction URVs as always in use, otherwise, they take a few minutes to "analysing components", then start repairs, hull first, then engines, then other components. Having the URVs does seem to speed up the process, so things seem to work just fine for me using this mod as is avaliable from steam workshop..?

StormMagi
Posts: 1208
Joined: Sat, 17. Mar 07, 04:53
x4

Post by StormMagi » Fri, 19. Dec 14, 07:09

ty_cho wrote:I'll say it again, the only problem I've ever experienced with engineers is it showing the construction URVs as always in use, otherwise, they take a few minutes to "analysing components", then start repairs, hull first, then engines, then other components. Having the URVs does seem to speed up the process, so things seem to work just fine for me using this mod as is avaliable from steam workshop..?
Maybe I didn't let the test run long enough then. let each go for about a minute and w/o script i had a barely functioning engine component. With script I didn't get that.
MOD XR Show Skills

Flying spaceships since 1993.

w.evans
Posts: 2954
Joined: Tue, 18. Nov 14, 17:23
xr

Post by w.evans » Fri, 19. Dec 14, 10:54

ty_cho wrote:showing the construction URVs as always in use
Yeah, noticed that too. In the test yesterday, after repairing the Styrvok, the Construction URVs appeared to dock, they were no longer visible outside the Styrvok, but it did still show unavailable.

Running another test today without Show Skills to compare.

w.evans
Posts: 2954
Joined: Tue, 18. Nov 14, 17:23
xr

Post by w.evans » Fri, 19. Dec 14, 14:48

The issue with Construction URVs showing Unavailable after docking does not appear to be linked to Show Skills.

Just ran the exact same scenario I did yesterday, but with Show Skills deactivated. Verified that it is inactive by asking some folks to show me their skills, and they showed question marks.

A couple of hours after the battle ended, the Styrvok showed everything repaired, Engineer status reads "Analyzing Components" and Construction URVs are no longer visible outside the Styrvok. However, they still show as "In Use" in the detail Status of the Styrvok (and "Unavailable" in the save file).

Went a bit further this time and blew up the same engine on the same poor Styrvok. Engineer status changed to "Repairing enginebooster_size_l_01_macro" after around 10 minutes. No Construction URVs being launched.

Would venture a guess that it's a vanilla issue. Yup, found a bug report here:

http://forum.egosoft.com/viewtopic.php?t=374707

in the patch public beta forums. That was for v3.00 RC1 though. Ego did not mention that issue in the changelogs, as far as I know (just that it sometimes takes a long time for drones to dock sometimes, listed as a known issue.)

Will leave it running for 30 minutes more to see if the drones eventually dock.

StormMagi
Posts: 1208
Joined: Sat, 17. Mar 07, 04:53
x4

Post by StormMagi » Fri, 19. Dec 14, 20:05

So then the mod basically just needed the md file location changed but still works fine.

w.evans you want to take over the mod? I feel kind of bad for hosting a mod but can't even troubleshoot it properly let alone fix it.
MOD XR Show Skills

Flying spaceships since 1993.

w.evans
Posts: 2954
Joined: Tue, 18. Nov 14, 17:23
xr

Post by w.evans » Fri, 19. Dec 14, 20:17

Not sure if that's a good idea. Kept quite busy with the MarineRebalance mod at the moment, and I seem to have the unfortunate tendency to produce rather prodigious walls of text.

You did mention that X Rebirth isn't really your primary game anymore though, so it is rather unfair to ask you to give time to it.

Maybe ask one of the Mods? The mod shouldn't need much maintenance.

If there aren't any takers though, sure.

If you don't mind continuing to host it though, I really don't mind troubleshooting when problems arise.

Seem to have a perverted sense of fun, but I find it fun.

Post Reply

Return to “X Rebirth - Scripts and Modding”