Too many trips planned for this ship

Ask here if you experience technical problems with X Rebirth.

Moderator: Moderators for English X Forum

User avatar
Vandragorax
Posts: 1178
Joined: Fri, 13. Feb 04, 05:25
x4

Too many trips planned for this ship

Post by Vandragorax » Sat, 16. Nov 13, 14:34

Hey there,

I'm having an issue with one of the early story missions, namely trying to get the Rahanas to sell 100 Energy Cells to the big asteroid base.

Yes I have checked for example the Rahanas is in the same sector, is has the energy cells, bla bla.

The problem is when I try to tell it to sell, the panel comes up and where it shows the Rahanas at the top, it says "Planned Trips: 3" then below that "There are too many trips planned for this ship".

Even though I have told it just to follow me.

I can't for the life of me find a way to view all the queued orders to cancel whatever is blocking it, and this has basically stopped me in my tracks on the story missions :(

Any ideas from anyone, or have I totally missed this being resolved elsewhere? I did have a good look around before posting, thanks.

User avatar
Swallen
Posts: 278
Joined: Tue, 11. Oct 11, 19:13

Post by Swallen » Sat, 16. Nov 13, 14:54

As far as I know you can't cancel orders. Orders are final.

Ravenhurst
Posts: 541
Joined: Sat, 10. Aug 13, 12:39

Post by Ravenhurst » Sat, 16. Nov 13, 14:58

I have this too, 3 trips planned, too many trips planned for this ship, can´t complete the "deliver 100 energy cells" mission.

Where can I cancel trips? Where do I even see which trips are planned? Totally lost here... no clue what is even going on

User avatar
Vandragorax
Posts: 1178
Joined: Fri, 13. Feb 04, 05:25
x4

Post by Vandragorax » Sat, 16. Nov 13, 14:59

Then that's a huge gap in the player UI that needs to be resolved. Since orders can apparently become 'stuck' in some way and with no way for me to cancel the one that's stuck, it's like having a printer queue fill up with jobs and not being able to reset the print spool - so it just becomes a useless pile of metal scrap :(

Cavespider
Posts: 35
Joined: Sun, 21. Apr 13, 05:17
x4

Post by Cavespider » Sat, 16. Nov 13, 15:02

yup I do not for see it getting fixed any time soon, Idk how the game got shipped with such a HUGE bug in the plot/game. But like always there will be no post to this from Egosoft no accountability for it not even a hey we know we are working on it nothing.

User avatar
Vandragorax
Posts: 1178
Joined: Fri, 13. Feb 04, 05:25
x4

Post by Vandragorax » Sat, 16. Nov 13, 15:05

I know exactly how it got shipped with such a huge defect/bug in it. As stated in my first post, it's the QA time. ALL companies' management seem to think they can just QA in like 1 month and be done with it. They have no clue how long it takes to work out defects and bugs properly, and then most of the time they ignore regression testing (which makes sure all the code changes don't interfere with each other).

Happens everywhere I've worked as a QA tester so far, and seems it has happened here too. But it would be fixable if they actually had a good UI design where I could view and cancel queued ship orders, but this seems to have been missed out all together!

Mind boggling.

Hob Anagerik
Posts: 632
Joined: Fri, 28. Oct 05, 20:05
x3tc

Post by Hob Anagerik » Sat, 16. Nov 13, 15:06

I doubt there was any pressure from publishers in this case either.
Windows 7 Pro x64, Intel i7 975, 12GB Corsair Dominator, Asus P6T6 WS Revolution, C.Labs X-Fi Fatal1ty, EVGA Nvidia 3GB 780 Ti, 2x 240GB Intel 520 SSD

User avatar
Vandragorax
Posts: 1178
Joined: Fri, 13. Feb 04, 05:25
x4

Post by Vandragorax » Sat, 16. Nov 13, 15:07

There nearly always is. So don't doubt too hard.

Cretain
Posts: 19
Joined: Fri, 24. Feb 06, 12:21

Post by Cretain » Sat, 16. Nov 13, 15:11

I had the same issue, so I relaoded an older save...I did that 3 times until I had the freighter with cells on board in the target sector and no planned trips left.
Sadly it just does nothing after I sell the cells. It confirms the order, has a trip planned then, but just does not move.....

Dodgey
Posts: 171
Joined: Sun, 20. Sep 09, 23:49

Post by Dodgey » Sat, 16. Nov 13, 16:29

same. Completely stuck on this mission. My transporter has 100 cells on board and just comes to me at the destination mine and sits there. If I order another delivery, it flies back to the mission start location.

Black_Beat
Posts: 5
Joined: Fri, 6. Feb 04, 12:52
x4

Post by Black_Beat » Sat, 16. Nov 13, 16:48

Same here. hate it! -.- :evil:
-"Wer tot ist, ist noch lange nicht offline"-

SG
Black_Beat

PowerPC603
Posts: 890
Joined: Sat, 20. Mar 04, 20:06
xr

Post by PowerPC603 » Sat, 16. Nov 13, 16:53

I got this too.
Tried for 2 hours to get the energy cells delivered.

I re-ordered the same command to sell the energy cells to the destination.
And always the traders went back to the previous zone for some reason.
I then tried to pilot a course to the trader ship and follow him, to check what's he doing.

I even docked with the trader and was standing on the deck, watching where he was flying to.
He docked with some station in the previous zone, bought 100 energy cells and went back to the destination.

While buying the energy cells, I got messages from the captain saying he's about to buy stuff, then finally I got a report that he bought "0 energy cells for 0 credits", while in fact he bought 100 energy cells, as I watched his cargohold.

When flying to the destination, the game crashed (screen froze and there was a "critical error" in the background.

I replaced all my previous steps and saved regularly.
Finally, he arrived at the destination and sold his energy cells and the mission completed.

While doing his trade-run, the command shown was "Follow Albion Skunk", instead of "Flying to destination" or "Selling energy cells".

He also flew right through some stations without getting damage from collisions.
After delivering the energy cells, he turned around and flew right through the center of that station instead of going around it.

After that, everything was fine.
I even got into the next solar system, but lost my trader.
I don't know if that's intentional (the trader might just be given for explaining the trading stuff), but the NPC's for which I paid lots of cash are gone as well.
GamePC: 64bit Quad-core i5-3450 @ 3.1GHz, 12GB RAM, AMD Radeon HD7770 (1GB), 22" LG Full-HD LED-monitor, Windows 7 Home 64bit

Feuerriese
Posts: 204
Joined: Thu, 28. Sep 06, 12:25
x4

Post by Feuerriese » Sat, 16. Nov 13, 17:28

If your freighter is stuck with "too many trips" save your game. Then open your savegame in

documents/egosoft/x rebirth/12345/save

Any editor will do. Once the file is opened search for shopping and delete those three trade orders which cause your ship to freeze. Save, quit, start X Rebirth, reload your game. Enjoy an empty trading queue.

P.S. To start trading you must issue a new trade order (just throught I'd mention this because some people forgot to do it). Works for all freighters including the one for the first e-cell mission. Enjoy!

Rekalty
Posts: 106
Joined: Thu, 18. Feb 10, 15:57
x4

Post by Rekalty » Sat, 16. Nov 13, 17:35

This exact same issue also plagued me, impressed that something like this was missed. In previous X games we had a lot more control over our ships, I don't get why it's been dumbed down so much that it's even breaking the game... At least they didn't bother to code/encrypt the save files in any way, so they're rather easy to edit, I'll give Feuerrise's workaround a try later, though this really needs to be fixed properly, soon.

User avatar
Vandragorax
Posts: 1178
Joined: Fri, 13. Feb 04, 05:25
x4

Post by Vandragorax » Sat, 16. Nov 13, 17:53

ty Feur this worked well as a workaround!

+1

Locked

Return to “X Rebirth - Technical Support”