X³: TC and AP - Linux support thread

Ask here if you experience technical problems with X³: Terran Conflict or X³: Albion Prelude.

Moderators: timon37, Moderators for English X Forum

Post Reply
timon37
EGOSOFT
EGOSOFT
Posts: 338
Joined: Fri, 14. Dec 12, 12:02

X³: TC and AP - Linux support thread

Post by timon37 » Mon, 15. Apr 13, 17:17

X³: TC and AP - Linux support thread

To post in this forum you need to register your game with the forum account, right click on the game in steam select "Register game", which redirects you to an egosoft site with the key copy and paste in your account settings under "Game Registration Code".

Please attach savegames for almost any issue, it'll help a lot. In case you can't or don't want to include it in the forum post, my email address is: tim13on ( on ) egosoft.com, of course remove the 13 and ( on ) is @ (hope not too many spam bots figure that out);p

If textures are broken (red green blue stripes):
You are running open-source drivers without support for texture compression.
If you have an AMD/ATI or NVIDIA graphics card you can install the proprietary drivers which should also result in improved performance.
If you are running Intel graphics or wish to use open-source drivers you will have to install libtxc-dxtn.

Ubuntu: you should get a prompt to install the library, if not report a bug and either:
search for libtxc-dxtn-s2tc0 in the "ubuntu software center",
or open a terminal and type in: "sudo apt-get install libtxc-dxtn-s2tc0" when prompted enter your password and follow any later instructions
Mint/Debian: probably same as ubuntu (the terminal instructions)
Fedora: not sure yet
Suse: not sure yet
Arch: not sure but on 32bit I think "sudo pacman -S community/libtxc_dxtn" on 64bit you probably need to add some repository sources and do "sudo pacman -S multilib/lib32-libtxc_dxtn"
Gentoo: "sudo emerge media-libs/libtxc_dxtn"

Generic information:
Especially at first it is advised to run in windowed mode.
If the game crashes in fullscreen mode it's possible that it'll leave the desktop in a lower resolution mode.

Savegames are by default stored in a hidden folder ".config/EgoSoft/X3TC/save/" in your home directory as X01.sav, X02.sav etc.
Windows savegames should be two-way compatible and shouldn't be flagged as "modified", if there are any issues please report a bug.

Additional shortcuts:
  • ctrl+g toggles window grabbing
  • ctrl+c tries to kill the game a.s.a.p.
Joystick setup:
X3TC supports up to 6 axes, you can set which of your actual joystick axes are mapped to which internal X3 axes in the input config dialog (before starting the game). You can also see the resulting current state of the given axis.
To disable an axis set the "Source/Disable:" to -1.
To invert an axis set the scale to -1, if you set scale to e.g. -1.2 or 1.2 it will "saturate" it by 20% (it will reach minimum/maximum value before the physical movement limit).
The throttle axis is special and should be used for "slider" controls (those that don't center automatically).

You can map the actual function of each internal X3 axis inside the games control settings (start a new game or load a save, in flight press escape or if docked select options, select "Controls", select second tab "Controls").
The deadzone is also set in the in-game settings menu.

Certain joysticks may have a hand sensor that will confuse the game and result in very fast keyrepeat and menu navigation.
To disable the button you can enter the "Input Device" config dialog and press "Remap buttons".
Any button name in red is currently pressed, locate those that are constantly red or red when you hold the joystick and either set "Button:" to -1 or click Assign and then press Delete.
If the button number is higher than 15 you'll have to edit the configuration file in "~/.config/EgoSoft/X3(TC or AP)/config.yaml"
and set "Joy Button<button number> Src' to '-1'.

If the game doesn't detect your joystick and you have /dev/input/js0 when you plug in your joystick but no /dev/js0 then try this:

Code: Select all

sudo ln -s input/js0 /dev/js0
Gamepad mode:
X3AP supports a gamepad mode tailored for the Xbox 360 controller.
If you have the controller connected it should be correctly enabled by default, if it isn't please report a bug and in the meantime clicking "Reset to Xbox controller" should enable it.
If you have a different gamepad you can still use the "controller mode", however you'll probably need to remap the axes and buttons in the config dialog.

Known issues and missing features (in rough order of fixing priority):
  • Issue: Blurred in-game text with 16xAA on nvidia binary drivers
  • Issue: Portrait videos can show a few frames of the wrong face in idle loop
  • Issue: Darker buildings on ground in 2nd plot mission
  • Issue: Main menu envmap looks different
  • Issue: Config file is saved on quit, which can be annoying when testing.
    Postponed: It unfortunately has to, at least for now.
Bugreporting etc:

Please attach savegames for almost any issue, it'll help a lot. In case you can't or don't want to include it in the forum post, my email address is: tim13on ( on ) egosoft.com, of course remove the 13 and ( on ) is @ (hope not too many spam bots figure that out);p

There's lots of console output that may look bad, in general don't worry or report it unless you get a crash or I asked for it.

If you notice any graphical anomalies, please (if you can) first try to confirm that they don't happen on windows, take screenshots (the windows ones may appear transparent, but are correct, so attach them anyway). If possible attach a savegame as close as possible to the offending situation/cutscene (use salvage insurrance and preferrably have some left so I can make a save at a later point).
Build history:

AP:
2015-03-30 1:30 UTC - Build 16:
- Fixed potential crash on undocking
- Fixed missile trails

2014-10-10 14:30 UTC - Build 15:
- Partially decreased stutter (at the cost of longer initial game start)

2013-09-28 23:30 UTC - Build 12:
- Fixed "run in background"
- Significant performance improvements on intel and amd drivers (I've seen between 10-40%)

2013-09-10 21:45 UTC - Build 11:
- Fixed compatibility with newer SDL2 and updated it to the official release
- Fixed cursor image being offset to right from actual click point
- Improved glow performance

2013-07-29 10:05 UTC - Build 9:
- Fixed texture corruption on AMD (hopefully)
- Fixed video seeking (bug with wrong portraits being shown)
- Alt+enter for windowed/fullscreen transition
- Better automatic mouse grabbing/ungrabbing in windowed mode

2013-07-21 13:30 UTC - Build 8:
- Various performance improvements (most notably on nvidia)
- Fixed doppler effect
- Improved launch and load time

2013-06-30 19:10 UTC - Build 7:
- ;)
- AMD catalyst 13.6 crash workaround
- View distance fogging fix

2013-06-28 15:05 UTC - Build 6:
- Performance improvement by up to 14% (especially on intel's graphics)
- Various improvements to config dialogs
- Message fix for statistics export (no more "My documents")
- Stat signing fix

2013-06-26 22:45 UTC - Build 5: Major shader refactor, if you notice any other changes or something you think is wrong, don't hesitate to tell me
- Boron and Paranid major fresnel color change
- Fixed CTD in earth sector (known issue: the torus is a bit brighter than on windows)
- Other more minor graphical improvements

2013-05-28 11:30 UTC - Build 4:
- Fixed ship shaking when not all that far from sector center
- Fixed mesa 8.0 compatibility on intel graphics
- Fixed throttle overridden by undisabled but nonexistent trigger axis
- Added missing gamepad graphic to the button remapping dialog

2013-05-25 15:30 UTC - Build 3:
- Gamepad mode with support for two "Trigger" axes (mark "Use as XBox gamepad" in the input config dialog)
- Button remapping/disabling (full control of all 30 buttons in config file)
- Fixed "can't rotate camera with numpad while holding tab or arrows"
- Fixed potential issue with partially black textures on intel graphics

2013-05-21 15:30 UTC - Build 2:
- Fixed garbled textures on lower quality settings after jumping
- Fixed fps counter appearing from nowhere

2013-05-17 17:30 UTC - Build 1:
- Fixed striped asteroids
- Fixed black teladi phoenix
- Fixed black complex hub
- Workaround for "missing voices" (otherwise known as unlimited data verification and redownload;p)

2013-05-15 00:42 UTC - Build 0:
- Wouldn't it be beatiful if every next build only included improved features because there are no bugs;)

TC:
2015-03-30 1:30 UTC - Build 24:
- Fixed potential crash on undocking
- Fixed missile trails

2014-10-10 14:30 UTC - Build 23:
- Fixed steam achievements and DiD
- Partially decreased stutter (at the cost of longer initial game start)

2013-09-28 23:30 UTC - Build 20:
- Fixed "run in background"
- Fixed whirls staying visible on UFJD jump to "A New Home" plot sector (unless you've got less than 1.2gb of memory)
- Significant performance improvements on intel and amd drivers (I've seen between 10-40%)

2013-09-10 21:45 UTC - Build 19:
- Fixed compatibility with newer SDL2 and updated it to the official release
- Fixed cursor image being offset to right from actual click point
- Improved glow performance

2013-07-29 10:05 UTC - Build 17:
- Fixed texture corruption on AMD (hopefully)
- Fixed video seeking (bug with wrong portraits being shown)
- Alt+enter for windowed/fullscreen transition
- Better automatic mouse grabbing/ungrabbing in windowed mode

2013-07-21 13:30 UTC - Build 16:
- Various performance improvements (most notably on nvidia)
- Fixed doppler effect
- Improved launch and load time

2013-06-30 19:10 UTC - Build 15:
- ;)
- AMD catalyst 13.6 crash workaround

2013-06-28 15:05 UTC - Build 14:
- Performance improvement by up to 14% (especially on intel's graphics)
- Various improvements to config dialogs
- Message fix for statistics export (no more "My documents")
- Stat signing fix

2013-06-26 22:45 UTC - Build 13: Major shader refactor, if you notice any other changes or something you think is wrong, don't hesitate to tell me
- Boron and Paranid major fresnel color change
- Other more minor graphical improvements

2013-05-28 11:30 UTC - Build 12:
- Fixed ship shaking when not all that far from sector center
- Fixed mesa 8.0 compatibility on intel graphics

2013-05-21 15:30 UTC - Build 11:
- Fixed garbled textures on lower quality settings after jumping
- Fixed fps counter appearing from nowhere

2013-05-17 17:30 UTC - Build 10:
- Fixed striped asteroids
- Fixed black teladi phoenix
- Fixed black complex hub

2013-05-11 14:30 UTC - Build 9:
- Load time reduced by 50%
- Fixed garbage in main menu on amd catalyst
- Fixed the terrible 1-3sec hangs on amd catalyst

2013-05-02 14:10 UTC - Build 8:
- Fixed joystick hat
- Fixed player stats signing

2013-04-30 09:10 UTC - Build 7:
- Fixed hub sector

2013-04-25 15:20 UTC - Build 6:
- Fixed tractor beam
- Fixed collisions with gate
- Fixed saturation/contrast/hue correction for certain objects (e.g. tractor beam)

2013-04-22 16:10 UTC - Build 5:
- Savegame compatibility fix
- Fix oops with occlusion map
- Partial blurring fix for nvidia+16xAA
- Grab mouse when in mouse-follow-steering

2013-04-18 16:40 UTC - Build 4:
- Wrong colors in a few places
- Popup menu item fading after click
- Fix scroll in menus

2013-04-17 16:40 UTC - Build 3:
- Fix crash on amd (possibly other drivers)

2013-04-16 23:14 UTC - Build 2:
- Fix crash on mission around neptune
- Fix crash on reset to default in graphics settings
- Fix fading to black

2013-04-16 15:15 UTC - Build 1:
- Fix crash on load with nvidia drivers
- Fix white load screen with nvidia drivers

2013-04-15 18:00 UTC - Build 0:
- Wouldn't it be beatiful if every next build only included improved features because there are no bugs;)
Last edited by timon37 on Mon, 29. Jun 15, 09:26, edited 29 times in total.

DGhost
Posts: 3
Joined: Mon, 15. Apr 13, 20:07

White window

Post by DGhost » Mon, 15. Apr 13, 20:33

Hi,
nice to see that X3TC finally made it to Steam for Linux. :)

Unfortunately I'm currently unable to start the game. Whenever I try the start the game the launcher pops up and after the click on start I just see a completely white window which closes after a short amount of time.

The last lines in the console are:

Code: Select all

[mpegvideo @ 0xab7b400] max_analyze_duration 5000000 reached at 5000000
[mpegvideo @ 0xab7b400] Estimating duration from bitrate, this may be inaccurate
movloadmovie success: reply=1 (1 / 16)
J3D_LoadCut2: Loaded embedded body 831000001
J3D_LoadCut2: Loaded embedded body 831000002
ST_LoadCut() cut 8310 loaded
ST_StartFromIndex(8310, 1) found starttime 0, endtime 13000
Switching to Camera Camera01
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 831 flags 256
movloadmovie success: reply=1 (1 / 20)
../X3.5/X3/s_linux/s3d.cpp : RenderInit : 9442 : dStub
~/Steam/SteamApps/common/X3 Terran Conflict/testandlaunch: Zeile 31: 10003 Speicherzugriffsfehler  (Speicherabzug geschrieben) ./$1
Game removed: AppID 2820 "X3: Terran Conflict", ProcID 10003 
I have a fully patched Kubuntu 12.10 X64 with 32bit compatibility libraries installed running on a AMD 64 X2 5200+.
My graphics card is a Nvidia 460 GTX with the 310.14 proprietary drivers installed.
And I have 4Gb of RAM.

Hopefully this can be fixed soon so I can start playing X3TC again. :)

DGhost
Posts: 3
Joined: Mon, 15. Apr 13, 20:07

The SigSev in the Launcher

Post by DGhost » Mon, 15. Apr 13, 20:59

Hi again,

here is another bug. If you go in the graphics Settings and press "Reset to Default" the launcher will get a SigSev and after reloading the launcher the graphics settings are not reset to the default values.

For the System details see my post above ...

Skrigger
Posts: 5
Joined: Mon, 21. Jan 13, 21:15

Post by Skrigger » Mon, 15. Apr 13, 20:59

Some for me.

Latest string + gdb run X3TC_main:

Code: Select all

[mpegvideo @ 0x96441e0] max_analyze_duration 5000000 reached at 5000000
[mpegvideo @ 0x96441e0] Estimating duration from bitrate, this may be inaccurate
[New Thread 0xa1d7eb40 (LWP 7548)]
[New Thread 0xa257fb40 (LWP 7549)]
[New Thread 0xa2d80b40 (LWP 7550)]
movloadmovie success: reply=1 (1 / 16)
J3D_LoadCut2: Loaded embedded body 831000001
J3D_LoadCut2: Loaded embedded body 831000002
ST_LoadCut() cut 8310 loaded
ST_StartFromIndex(8310, 1) found starttime 0, endtime 13000
Switching to Camera Camera01
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 831 flags 256
[New Thread 0xa057bb40 (LWP 7551)]
[New Thread 0x9fd7ab40 (LWP 7552)]
[New Thread 0x9f579b40 (LWP 7553)]
movloadmovie success: reply=1 (1 / 20)
../X3.5/X3/s_linux/s3d.cpp : RenderInit : 9442 : dStub
Program received signal SIGSEGV, Segmentation fault.
0xb4782da9 in ?? ()
(gdb) bt
#0  0xb4782da9 in ?? ()
Cannot access memory at address 0x104
(gdb) q
Latest string + gdb run X3TC_config->Graphics Settings->Reset to defaults:

Code: Select all

Profile = default
Player Logo Number = 0
Player Logo Name = (null)
[New Thread 0xb1cdeb40 (LWP 7567)]
[New Thread 0xb12ffb40 (LWP 7568)]
../X3.5/X3/s_linux/ConfigDialog.cpp : Video_MonitorChange : 2604 : monitoridx =         0
../X3.5/X3/s_linux/ConfigDialog.cpp : Video_MonitorChange : 2604 : monitoridx =         0
Program received signal SIGSEGV, Segmentation fault.
0x08053181 in ?? ()
(gdb) bt
#0  0x08053181 in ?? ()
#1  0xb626fa05 in g_cclosure_marshal_VOID__VOIDv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#2  0xb626dee1 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#3  0xb628765a in g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#4  0xb6288233 in g_signal_emit () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#5  0xb67032ca in gtk_button_clicked () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#6  0xb67046d0 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#7  0xb626f9ea in g_cclosure_marshal_VOID__VOIDv () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#8  0xb626c587 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#9  0xb626dee1 in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#10 0xb628765a in g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#11 0xb6288233 in g_signal_emit () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#12 0xb67031ea in gtk_button_released () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#13 0xb6703234 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#14 0xb67c2512 in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#15 0xb626cacd in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#16 0xb626dc36 in g_closure_invoke () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#17 0xb627fbfc in ?? () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#18 0xb6287cc3 in g_signal_emit_valist () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#19 0xb6288233 in g_signal_emit () from /usr/lib/i386-linux-gnu/libgobject-2.0.so.0
#20 0xb68fae7b in ?? () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#21 0xb67c0604 in gtk_propagate_event () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#22 0xb67c09a0 in gtk_main_do_event () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#23 0xb66339e8 in ?? () from /usr/lib/i386-linux-gnu/libgdk-x11-2.0.so.0
#24 0xb61a63b3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#25 0xb61a6750 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#26 0xb61a6c2b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#27 0xb67bf710 in gtk_main () from /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
#28 0x0804fae3 in ?? ()
#29 0xb5d26935 in __libc_start_main (main=0x804f050, argc=1, ubp_av=0xbffff074, init=0x806c1e0, fini=0x806c250, rtld_fini=0xb7fed600 <_dl_fini>, stack_end=0xbffff06c)
    at libc-start.c:260
#30 0x0804fded in ?? ()
(gdb) q

User avatar
ezra-r
Posts: 3066
Joined: Fri, 14. Oct 05, 21:04

Post by ezra-r » Mon, 15. Apr 13, 22:20

I tried to run it getting a SEGFAULT, did it on terminal so you can find the whole output here:

http://pastebin.com/Q3VtCeGf

Hope it helps!

PS: My specs:
http://pastebin.com/YPXu7KM7

rictec
Posts: 100
Joined: Wed, 15. Dec 04, 18:04

Nice to have this on Linux so happy

Post by rictec » Tue, 16. Apr 13, 00:36

i m suffering from what other report
click logo first page appears ...white screen
back to desktop

anyway to run the game on a console to get info or must do it from steam?

Rictec

running ubuntu with nvidia made graphics driver 64 bits
from the terminal
http://pastebin.com/z8SXGUmv
cpu amd 4 core nvidia 9800gt 8G ram

timon37
EGOSOFT
EGOSOFT
Posts: 338
Joined: Fri, 14. Dec 12, 12:02

Post by timon37 » Tue, 16. Apr 13, 00:54

Ouch:(
@Skrigger You also on nvidia?

@everyone with the crash: Does X3R still work? And do you also get a white loading screen there?

Merlin-TC
Posts: 12
Joined: Tue, 8. Apr 03, 02:18

Post by Merlin-TC » Tue, 16. Apr 13, 00:56

X3R still works fine here but X3TC crashes with the same error as stated by the others. White screen for a short moment then the crash.

I have an nvidia 670gtx.

timon37
EGOSOFT
EGOSOFT
Posts: 338
Joined: Fri, 14. Dec 12, 12:02

Post by timon37 » Tue, 16. Apr 13, 01:16

Anyone got nvidia and not experiencing the crash?
Too bad my chances of getting an answer to that one are pretty low;p

Hmm I'm afraid for a few reasons it'll take at least a day or two to fix, maybe even three:(
In the mean time can you test if an older/newer driver changes anything?
If you got any other machines please also test on them, it looks nvidia specific but you never know.

chadlongstaff
Posts: 1
Joined: Fri, 29. Feb 08, 16:13

white screen nvidia/reunion

Post by chadlongstaff » Tue, 16. Apr 13, 01:56

Same problem with TC, on R there is a white screen and some perceived delay at the Deep Silver screen but it sorts itself out and game seems to run normally, going to try with Beta nvidia drivers, shortly.

vuldin
Posts: 1
Joined: Tue, 16. Apr 13, 01:51

Post by vuldin » Tue, 16. Apr 13, 01:56

I'm having the same problem when attempting to start the game with an Nvidia card. I haven't checked the errors to see if I'm having the same exact issue, but the outcome is the same (white screen then crash). If the error is different than what is already posted I'll make sure to copy my error into this thread.

I'm using the latest available drivers, see specs below (from Steam, Help -> System Info):

Processor Information:
Vendor: GenuineIntel
Speed: 2401 Mhz
8 logical processors
4 physical processors
HyperThreading: Supported
FCMOV: Supported
SSE2: Supported
SSE3: Supported
SSSE3: Supported
SSE4a: Unsupported
SSE41: Supported
SSE42: Supported

Network Information:
Network Speed:

Operating System Version:
Ubuntu 12.10 (64 bit)
Kernel Name: Linux
Kernel Version: 3.5.0-25-generic
X Server Vendor: The X.Org Foundation
X Server Release: 11300000
X Window Manager: Compiz
Steam Runtime Version: steam-runtime-release-i386_2013-04-02

Video Card:
Driver: NVIDIA Corporation Quadro 1000M/PCIe/SSE2

Driver Version: 4.3.0 NVIDIA 319.12
Desktop Color Depth: 24 bits per pixel
Monitor Refresh Rate: 60 Hz
VendorID: 0x10de
DeviceID: 0xdfa
Number of Monitors: 1
Number of Logical Video Cards: 1
Primary Display Resolution: 1920 x 1080
Desktop Resolution: 1920 x 1080
Primary Display Size: 13.54" x 7.60" (15.51" diag)
34.4cm x 19.3cm (39.4cm diag)
Primary Bus: PCI Express 16x
Primary VRAM: 2048 MB
Supported MSAA Modes: 2x 4x 8x 16x

Sound card:
Audio device: Conexant CX20590

Memory:
RAM: 32131 Mb

Miscellaneous:
UI Language: English
LANG: en_US.UTF-8
Microphone: Not set
Total Hard Disk Space Available: 437315 Mb
Largest Free Hard Disk Block: 182479 Mb

_JD_
Posts: 9
Joined: Wed, 29. Oct 08, 16:05

Post by _JD_ » Tue, 16. Apr 13, 02:06

Same white screen then crash on X3TC. X3R still works fine.

Code: Select all

Processor Information:
    Vendor:  GenuineIntel
    Speed: 2301 Mhz
    8 logical processors
    4 physical processors
    HyperThreading:  Supported
    FCMOV:  Supported
    SSE2:  Supported
    SSE3:  Supported
    SSSE3:  Supported
    SSE4a:  Unsupported
    SSE41:  Supported
    SSE42:  Supported
    
Network Information:
    Network Speed:  
    
Operating System Version:
    Ubuntu Raring Ringtail (development branch) (32 bit)
    Kernel Name:  Linux
    Kernel Version:  3.8.0-17-generic
    X Server Vendor:  The X.Org Foundation
    X Server Release:  11303000
    X Window Manager:  Compiz
    Steam Runtime Version:  steam-runtime-release-i386_2013-04-02
    
Video Card:
    Driver:  NVIDIA Corporation GeForce GTX 670M/PCIe/SSE2

    Driver Version:  4.3.0 NVIDIA 313.30
    Desktop Color Depth: 24 bits per pixel
    Monitor Refresh Rate: 60 Hz
    VendorID:  0x10de
    DeviceID:  0x1213
    Number of Monitors:  2
    Number of Logical Video Cards:  1
    Primary Display Resolution:  1920 x 1080
    Desktop Resolution: 3840 x 1080
    Primary Display Size: 6,30" x 3,54"  (7,20" diag)
                                            16,0cm x 9,0cm  (18,3cm diag)
    Primary Bus: PCI Express 16x
    Primary VRAM: 3072 MB
    Supported MSAA Modes:  2x 4x 8x 16x 
    
Sound card:
    Audio device: VIA VT1802
    
Memory:
    RAM:  16167 Mb
    
Miscellaneous:
    UI Language:  English
    LANG:  it_IT.UTF-8
    Microphone:  Not set
    Total Hard Disk Space Available:  501673 Mb
    Largest Free Hard Disk Block:  4830 Mb
    
Installed software:
    
Recent Failure Reports:   

Code: Select all

../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
[TC_MemoryFlush] freed 0, released 0 of 0 cached textures
../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
MOV_FreeVoices() 0 pages with total 0 voices entries freed.
SB_LoadLocation() loading story file x3intro
Version=5
FontHeight=15.000000
TopPadding=0.000000
BottomPadding=2.000000
FontYAdvance=13.000000
MaxGlyph=1169
NumGlyphs=612
max char height=14 (user supplied font height=13)
Version=5
FontHeight=33.000000
TopPadding=0.000000
BottomPadding=0.000000
FontYAdvance=33.000000
MaxGlyph=512
NumGlyphs=274
max char height=25 (user supplied font height=26)
======================================
MOV_LoadVoices(39) can't open file
======================================
LoadVoices(44)
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 144 flags 272
movloadmovie success: reply=1 (1 / 3)
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 1 flags 8
[mpegvideo @ 0xad19860] max_analyze_duration 5000000 reached at 5000000
[mpegvideo @ 0xad19860] Estimating duration from bitrate, this may be inaccurate
movloadmovie success: reply=1 (1 / 3)
../X3.5/X3/s_linux/s3d.cpp : S_3DCleanAndOptimizeMesh : 2425 : dStub
../X3.5/X3/s_linux/sdl2/svideo.cpp : W_RectFill : 1332 : dStub
J3D_LoadCut2: Loaded embedded body 830000001
J3D_LoadCut2: Loaded embedded body 830000002
ST_LoadCut() cut 8300 loaded
ST_StartFromIndex(8300, 1) found starttime 0, endtime 4000
Switching to Camera Camera01
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 830 flags 256
Error opening movie stream: 830
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 830 flags 272
Error opening movie stream: 830
======================================
Failed loading movie 830
======================================
======================================
Failed freeing movie 8300
======================================
======================================
#200[019384]600.SetState Undefined function 0(0).GetEnvironment called!
======================================
Failed stoping movie 830
======================================
Failed freeing movie 830
======================================
ST_UnloadCut() cut 8300 start
ST_UnloadCut() starting unload cut 8300, numinst=3
J3D_FreeCut() freeing cut 8300
No dump, because DEBUG disabled
../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
[TC_MemoryFlush] freed 5, released 0 of 5 cached textures
../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
MOV_FreeVoices() 132 pages with total 9990 voices entries freed.
No dump, because DEBUG disabled
../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
[TC_MemoryFlush] freed 0, released 0 of 0 cached textures
../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
../X3.5/X3/s_linux/s3d.cpp : FlushShaderTexBindCache : 1644 : dStub
MOV_FreeVoices() 0 pages with total 0 voices entries freed.
SB_LoadLocation() loading story file x3intro
LoadVoices(44)
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 144 flags 272
movloadmovie success: reply=1 (1 / 16)
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 1 flags 8
[mpegvideo @ 0xab75b00] max_analyze_duration 5000000 reached at 5000000
[mpegvideo @ 0xab75b00] Estimating duration from bitrate, this may be inaccurate
movloadmovie success: reply=1 (1 / 16)
J3D_LoadCut2: Loaded embedded body 831000001
J3D_LoadCut2: Loaded embedded body 831000002
ST_LoadCut() cut 8310 loaded
ST_StartFromIndex(8310, 1) found starttime 0, endtime 13000
Switching to Camera Camera01
../X3.5/X3/s_linux/s_movie.cpp : S_OpenMovie : 636 : id 831 flags 256
movloadmovie success: reply=1 (1 / 20)
../X3.5/X3/s_linux/s3d.cpp : RenderInit : 9442 : dStub
Errore di segmentazione (core dump creato)

d10sfan
Posts: 3
Joined: Thu, 10. Jan 13, 20:20

Post by d10sfan » Tue, 16. Apr 13, 02:26

Have the same problem as the others on X3TC. X3R works fine.

I'm on Nvidia card, 313.30 drivers

scratch42069
Posts: 47
Joined: Sat, 17. Dec 05, 08:59

Post by scratch42069 » Tue, 16. Apr 13, 03:03

I'm also experiencing the white screen followed by a crash issue. My graphics card is a GTX 560 with the 319.12 drivers.

rictec
Posts: 100
Joined: Wed, 15. Dec 04, 18:04

my X3R was made by LGP

Post by rictec » Tue, 16. Apr 13, 03:19

do i have to get it inside steam and reinstall or something ?

tyed all my copies of X3 none of them activate on steam ..


note: after a struggle with password on LGP
X3R 2.5 with extended mod 7.04 works my save game loaded ok ...

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Technical Support”