EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
X³: Reunion - Linux support thread
Post new topic Reply to topic Goto page Previous  1, 2, 3 ... , 23, 24, 25  Next
View previous topic :: View next topic
Author Message
Artactics





Joined: 16 Sep 2015



PostPosted: Wed, 16. Sep 15, 22:25    Post subject: a whole new joystick issue Reply with quote Print

I seem to be having a new and exciting joystick issue. At the very least I haven't found anything about it in the thread so far (please tell me if I overlooked anything!).

I'm using a Saitek X45 which is properly detected by X3 as such. All the axis work perfectly fine... and none of the buttons work at all.

I haven't had any similar issues with other software.

Back to top
View user's profile Send private message
timon37
EGOSOFT
EGOSOFT

MEDAL

Joined: 14 Dec 2012
Posts: 333 on topic

Thank you for registering your game
PostPosted: Thu, 17. Sep 15, 14:10    Post subject: Re: a whole new joystick issue Reply with quote Print

@Artactics
That somehow sounds familiar, but I can't seem to find anything specific in the forum.
The problem that often happens is that a joystick has a hand sensor or just a button that is always pressed. Afaik that actually breaks a lot more (iirc keyboard repeat becomes extremely rapid).

But that doesn't sound like what you're seeing?
Regardless I'd try experimenting with the Button mapping in the config file to see if you can get anything to work (rough explanation of how to do it is in the first post).
First thing to try is just disable all buttons except the first one and check if it works, then disable all except the second button, if neither works then disabling buttons can't fix the problem.

Back to top
View user's profile Send private message
Artactics





Joined: 16 Sep 2015



PostPosted: Thu, 17. Sep 15, 16:34    Post subject: Reply with quote Print

@timon37

I did have the "switches" that are permanently pressed buttons disabled with "-ignorejoy" command line switches. I just tried disabling the rest of them the same way with no luck.

My "Input Device" dialog doesn't allow to remap buttons, which I suspect is a bad sign.

I also tried to remove the button entries in config.yaml but they were just automatically recreated.

Back to top
View user's profile Send private message
timon37
EGOSOFT
EGOSOFT

MEDAL

Joined: 14 Dec 2012
Posts: 333 on topic

Thank you for registering your game
PostPosted: Thu, 17. Sep 15, 17:06    Post subject: Reply with quote Print

@Artactics

Honestly it's possible or even likely -ignorejoy won't work for the linux version (though I don't remember), so I would still try setting it in the config file.

There is no button remapping UI for R & TC because it's normally not necessary since you can remap buttons in-game.
Though AP has a special one for an xbox controller.

Back to top
View user's profile Send private message
Artactics





Joined: 16 Sep 2015



PostPosted: Thu, 17. Sep 15, 17:35    Post subject: Reply with quote Print

@timon37

My bad on the UI, seems like the info on the first page is out of date.

Setting all but one of the buttons to "-1" in config.yaml has had no effect either so unless that's not the right way to disable them either I'm probably stuck with rebinding the buttons to keyboard shortcuts with QJoyPad.

Back to top
View user's profile Send private message
timon37
EGOSOFT
EGOSOFT

MEDAL

Joined: 14 Dec 2012
Posts: 333 on topic

Thank you for registering your game
PostPosted: Fri, 18. Sep 15, 10:09    Post subject: Reply with quote Print

@Artactics

That's correct and that's what I feared:(
Right now I'm busy with XR opengl work, and I'll probably be busy with XR till the end of this year. But after that I'll try to gather some joysticks we have lying around and check if I can reproduce some of the issues people saw.
Btw which distro are you on?

Back to top
View user's profile Send private message
Artactics





Joined: 16 Sep 2015



PostPosted: Fri, 18. Sep 15, 19:43    Post subject: Reply with quote Print

@timon37

At least the axis work so I'm not stranded. I'm on Ubuntu 14.04

Back to top
View user's profile Send private message
Rompetroll





Joined: 29 Jan 2013



PostPosted: Sun, 15. Nov 15, 19:47    Post subject: Reply with quote Print

After upgrading to openSUSE Leap 42.1 i'v run in to a issue with X3 games crashing.

Code:
hallvar@linux-vk72:~/.local/share/Steam/steamapps/common/X3 - Reunion> ./X3R_config
 *** X3 version 2.5 (Mar 27 2015 13:36:18) ***
../src/X3/s_linux/init.cpp : XMenuInit : 254 : dStub
======================================
error opening prim. Catalog: 1
======================================
======================================
EXIT(0)!!!
======================================
hallvar@linux-vk72:~/.local/share/Steam/steamapps/common/X3 - Reunion> ./X3R
X3R_config          X3ReadMe1.4.02.rtf  X3ReadMe2.0.01.rtf  X3ReadMe2.0.02.rtf  X3ReadMe2.5.rtf     X3R_main           
hallvar@linux-vk72:~/.local/share/Steam/steamapps/common/X3 - Reunion> ./X3R_main
../src/X3/s_linux/sdl2/sio.cpp : main : 1250 : dPStub: atexit (_quit);
 *** X3 version 2.5 (Mar 27 2015 13:36:23) ***
../src/X3/s_linux/init.cpp : XMenuInit : 254 : dStub
======================================
error opening prim. Catalog: 1
======================================
../src/X3/s_linux/sdl2/sio.cpp : S_SystemMessage : 1275 : dStub
======================================
EXIT(0)!!!
======================================
hallvar@linux-vk72:~/.local/share/Steam/steamapps/common/X3 - Reunion>


and gdb

Code:
hallvar@linux-vk72:~/.local/share/Steam/steamapps/common/X3 - Reunion> gdb ./X3R_config
GNU gdb (GDB; %maintenance_distribution) 7.9.1
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-suse-linux".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://bugs.opensuse.org/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from ./X3R_config...(no debugging symbols found)...done.
(gdb) run
Starting program: /home/hallvar/.local/share/Steam/steamapps/common/X3 - Reunion/X3R_config
Missing separate debuginfos, use: zypper install glibc-32bit-debuginfo-2.19-17.1.x86_64
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
warning: Ignoring non-absolute filename: <lib/libz.so.1>
Missing separate debuginfo for lib/libz.so.1
Try: zypper install -C "debuginfo(build-id)=259d049fcdd8bb383f2a97e1b2f11f778c359649"
 *** X3 version 2.5 (Mar 27 2015 13:36:18) ***
../src/X3/s_linux/init.cpp : XMenuInit : 254 : dStub
======================================
error opening prim. Catalog: 1
======================================
======================================
EXIT(0)!!!
======================================
[Inferior 1 (process 1965) exited normally]
Missing separate debuginfos, use: zypper install fontconfig-32bit-debuginfo-2.11.0-3.2.x86_64 libX11-6-32bit-debuginfo-1.6.3-1.1.x86_64 libXau6-32bit-debuginfo-1.0.8-6.1.x86_64 libXcomposite1-32bit-debuginfo-0.4.4-10.1.x86_64 libXcursor1-32bit-debuginfo-1.1.14-6.1.x86_64 libXdamage1-32bit-debuginfo-1.1.4-9.1.x86_64 libXext6-32bit-debuginfo-1.3.3-3.1.x86_64 libXfixes3-32bit-debuginfo-5.0.1-5.1.x86_64 libXi6-32bit-debuginfo-1.7.5-1.1.x86_64 libXinerama1-32bit-debuginfo-1.1.3-5.1.x86_64 libXrandr2-32bit-debuginfo-1.5.0-1.1.x86_64 libXrender1-32bit-debuginfo-0.9.9-1.1.x86_64 libXss1-32bit-debuginfo-1.2.2-10.1.x86_64 libXxf86vm1-32bit-debuginfo-1.1.4-1.1.x86_64 libatk-1_0-0-32bit-debuginfo-2.16.0-2.3.x86_64 libbz2-1-32bit-debuginfo-1.0.6-30.4.x86_64 libcairo2-32bit-debuginfo-1.14.2-3.1.x86_64 libdbus-1-3-32bit-debuginfo-1.8.16-5.2.x86_64 libexpat1-32bit-debuginfo-2.1.0-15.4.x86_64 libffi4-32bit-debuginfo-5.2.1+r226025-4.1.x86_64 libfreetype6-32bit-debuginfo-2.5.5-8.2.x86_64 libgcc_s1-32bit-debuginfo-5.2.1+r226025-4.2.x86_64 libgdk_pixbuf-2_0-0-32bit-debuginfo-2.31.6-1.2.x86_64 libgio-2_0-0-32bit-debuginfo-2.44.1-2.3.x86_64 libglib-2_0-0-32bit-debuginfo-2.44.1-2.3.x86_64 libgmodule-2_0-0-32bit-debuginfo-2.44.1-2.3.x86_64 libgobject-2_0-0-32bit-debuginfo-2.44.1-2.3.x86_64 libgraphite2-3-32bit-debuginfo-1.3.1-1.1.x86_64 libgtk-2_0-0-32bit-debuginfo-2.24.28-2.9.x86_64 libharfbuzz0-32bit-debuginfo-1.0.3-1.1.x86_64 libpango-1_0-0-32bit-debuginfo-1.36.8-2.2.x86_64 libpcre1-32bit-debuginfo-8.33-3.5.x86_64 libpixman-1-0-32bit-debuginfo-0.32.6-3.2.x86_64 libpng16-16-32bit-debuginfo-1.6.8-2.2.x86_64 libselinux1-32bit-debuginfo-2.3-3.5.x86_64 libstdc++6-32bit-debuginfo-5.2.1+r226025-4.2.x86_64 libudev1-32bit-debuginfo-210-84.1.x86_64 libxcb-render0-32bit-debuginfo-1.11.1-1.1.x86_64 libxcb-shm0-32bit-debuginfo-1.11.1-1.1.x86_64 libxcb1-32bit-debuginfo-1.11.1-1.1.x86_64
(gdb)



_________________
tux4ever
Back to top
View user's profile Send private message
timon37
EGOSOFT
EGOSOFT

MEDAL

Joined: 14 Dec 2012
Posts: 333 on topic

Thank you for registering your game
PostPosted: Mon, 16. Nov 15, 11:26    Post subject: Reply with quote Print

@Rompetroll

Hmmm for some reason the game can't open the first catalog.
Either the permissions are wrong, maybe your user id changed after the update?
Though that would break a lot more, but still first try setting yourself as the owner for the game directory and everything in it.
Then try verifying the local game cache in steam.
Also can you give me md5 or sha1 checksums for the catalogs?

Final possibility is a nasty problem that someone once mentioned about filesystems with 64bit inode numbers, where iirc normal fstat would simply refuse to work. What filesystem are you using and did that change in the update? Sounds more like a reinstall than an update at that point though;p

Back to top
View user's profile Send private message
Rompetroll





Joined: 29 Jan 2013



PostPosted: Mon, 16. Nov 15, 14:00    Post subject: Reply with quote Print

Premissions are correct, its installed as default under home folder. however I used to have a seperate folder under /usr/share/games/ where i put some steam games, due to running my / folder on a 4x ssd raid 5 intel raid. and my /home folder on a 4x 1tb hybrid disks in a software raid 5 array.

i'v now made a new installation folder on my root partition /usr/share/games/Steam/ where i am installing X3.

My root partition is BtrFS
My home partition (where x3 was installed) is XFS

Maybe its the XFS filesystem wich screws thing up.

Aw damn, I forgot to get the checksums befor I changed directories. I'll have those for you if the changeing from /home partition to the root partition dosnt solve this Smile

opensuse is probably one of the few distro wich defaults to XFS as the home filesystem. Also, maybe this can solve some issues i have with a few other games (civ 5 and BE)


_________________
tux4ever
Back to top
View user's profile Send private message
Rompetroll





Joined: 29 Jan 2013



PostPosted: Mon, 16. Nov 15, 15:13    Post subject: Reply with quote Print

@Timon37

Confirming filesystem issue related to XFS. When starting from /usr/share/games/Steam on a BtrFS partiton it works as a charm.

Thanks for pointing this out to me Smile

Now thats an ugly one for XFS Wink


_________________
tux4ever
Back to top
View user's profile Send private message
timon37
EGOSOFT
EGOSOFT

MEDAL

Joined: 14 Dec 2012
Posts: 333 on topic

Thank you for registering your game
PostPosted: Mon, 16. Nov 15, 15:46    Post subject: Reply with quote Print

for reference I just looked up a description of the issue with some workarounds: http://www.tcm.phy.cam.ac.uk/sw/inodes64.html

Back to top
View user's profile Send private message
rrob





Joined: 11 Feb 2009



PostPosted: Thu, 3. Dec 15, 13:15    Post subject: too fast mouse in linux Reply with quote Print

Hi,
sry for asking but didnt find any way how to search this thread.

I have udpated Ubuntu 14.04 with updated steam with updatet X3 Renuion.
Im using Logitech MX510 gaming mouse with 800dpi. In system is my sensitivity as low as possible. Also on mouse is it set to lowest.
But in the game it is not possible to control turret in simulator or ship because it is extremly fast.
I also didnt found any mouse settings in any menu.
I have googled that is not possible to change sensitivity from game.

It is possibel to solve it somehow? Or is the game unplayable.

Back to top
View user's profile Send private message Visit poster's website
timon37
EGOSOFT
EGOSOFT

MEDAL

Joined: 14 Dec 2012
Posts: 333 on topic

Thank you for registering your game
PostPosted: Thu, 3. Dec 15, 13:21    Post subject: Re: too fast mouse in linux Reply with quote Print

@rrob

Can you test if this also happens in windowed mode?
Or in fullscreen if you're using windowed already.

Back to top
View user's profile Send private message
rrob





Joined: 11 Feb 2009



PostPosted: Thu, 3. Dec 15, 13:28    Post subject: Reply with quote Print

@timon37

Tested and it happens in both modes same.

Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:   
Post new topic Reply to topic Goto page Previous  1, 2, 3 ... , 23, 24, 25  Next
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Wed, 13. Dec 17, 07:13

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2017
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.15345 seconds, sql queries = 29