EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
X3 Reunion Freezes - Lingering mod issue resolved
Post new topic Reply to topic
View previous topic :: View next topic
Author Message
Buck_Rogers





Joined: 21 Dec 2004
Posts: 1462 on topic
Location: Aberdeenshire
Thank you for registering your game
PostPosted: Tue, 22. Dec 15, 18:48    Post subject: X3 Reunion Freezes - Lingering mod issue resolved Reply with quote Print

Hi Peeps

Me again Smile not sure if I should've continued my other thread, or what. but since this is a separate issue....

I have got the game working again. However, upon loading an old save, the game locks up completely. I end up having to reset my PC.

I have done all the usual. I.E update my drivers, but everything was already as up to date as it could be.

I also managed to cancel all running commands on my ships, but it still freezes. usually after about 10 - 15 minutes game play.

I can add further info if required.

Thanks in advance


_________________
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!
Back to top
View user's profile Send private message MSN Messenger
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17024 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Tue, 22. Dec 15, 18:58    Post subject: Reply with quote Print

After your previous AV quarantine installation issues, are you positive that your game is properly and entirely installed and patched?


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
CBJ
EGOSOFT
EGOSOFT



Joined: 29 Apr 2003
Posts: 35702 on topic

Thank you for registering your game
PostPosted: Tue, 22. Dec 15, 19:07    Post subject: Reply with quote Print

Buck_Rogers, in the previous thread, wrote:
...didnt play my saves coz I need to install all my mod/script collection...

Not having the right mods/scripts installed could also result in your savegames not working, in unpredictable ways. That said, no script or mod, nor indeed the game itself, will hang up your entire PC as that is out of the scope of what Windows allows "normal" applications to do. That suggests that either there is still some AV-related issue or that you have some wider issue with, say, your drivers or hardware.

Back to top
View user's profile Send private message
Buck_Rogers





Joined: 21 Dec 2004
Posts: 1462 on topic
Location: Aberdeenshire
Thank you for registering your game
PostPosted: Tue, 22. Dec 15, 20:54    Post subject: Reply with quote Print

Alan Phipps wrote:
After your previous AV quarantine installation issues, are you positive that your game is properly and entirely installed and patched?


Absolutely positive Mr Phipps Very Happy Especially since I got rid of that Comodo rubbish. The game also appears in the Apps and Features list now. It is also properly patched to 2.5

CBJ wrote:
Not having the right mods/scripts installed could also result in your savegames not working, in unpredictable ways. That said, no script or mod, nor indeed the game itself, will hang up your entire PC as that is out of the scope of what Windows allows "normal" applications to do. That suggests that either there is still some AV-related issue or that you have some wider issue with, say, your drivers or hardware.


Well hello Mr CBJ. Nice to see another old timer Very Happy

I was thinking that myself. I wouldnt have posted if I was convinced it was an issue with my scripts/mods. They should not hang my entire system.


_________________
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!
Back to top
View user's profile Send private message MSN Messenger
Buck_Rogers





Joined: 21 Dec 2004
Posts: 1462 on topic
Location: Aberdeenshire
Thank you for registering your game
PostPosted: Wed, 23. Dec 15, 11:31    Post subject: Reply with quote Print

Guys

I think I might be onto something. But just wanted to check. If this turns out to be the problem, I will be surprised though!

I have just had a quick look in the Global Script List of the script editor, and have found a script in there that I had removed previously. This was due to incompatibility issues.

Anyway. As I said, I removed it, but why does it still show in the Global List??? The script is NOT in the scripts folder.


_________________
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!
Back to top
View user's profile Send private message MSN Messenger
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17024 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Wed, 23. Dec 15, 15:03    Post subject: Reply with quote Print

Third party scripts and mods not recognised by the uninstaller can survive an uninstall in the game folders, in gamesaves, in Steam cloud backup if you use it, and possibly in the virtual store on your system.

This is why we recommend a 'clean' reinstall and a fresh gamestart after removing mods as detailed at the end of this Sticky.


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
Buck_Rogers





Joined: 21 Dec 2004
Posts: 1462 on topic
Location: Aberdeenshire
Thank you for registering your game
PostPosted: Wed, 23. Dec 15, 16:30    Post subject: Reply with quote Print

Sad

I was afraid you were going to say that. I cant do a fresh restart. I would lose years worth of game play. And since my game time is now much more restricted than what it used to be, it would take a long long time to get where I am now.

So I guess I will have to fix this issue on my own


_________________
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!
Back to top
View user's profile Send private message MSN Messenger
Buck_Rogers





Joined: 21 Dec 2004
Posts: 1462 on topic
Location: Aberdeenshire
Thank you for registering your game
PostPosted: Fri, 1. Jan 16, 20:59    Post subject: Reply with quote Print

FIXED!! Very Happy

In my haste to get back to playing X3R, I neglected to check I had installed every script/mod from my collection. I ended up missing 2 of them. Embarassed So since the files were missing, I'm guessing thats what caused the freeze. I have played a couple of days without incident, so far.

Touch wood!


_________________
Buck Rogers

Vice Admiral of Shadows Haven Alliance (SHA) visit us at:
SHA Forum
Feel free to join my DID
Too often we lose sight of life's simple pleasures. Remember, when someone annoys you, it takes 42 muscles in your face to frown. But only 4 to extend your arm and slap the bugger!
Back to top
View user's profile Send private message MSN Messenger
Display posts from previous:   
Post new topic Reply to topic
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Mon, 11. Dec 17, 20:53

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2017
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.13855 seconds, sql queries = 23