EnglishGermanFrenchRussianPolishItalianSpanish
Log inRegister
 
[script] Improved Kha'ak 2: The Revenge [Updated: 2013.05.17]
Post new topic Reply to topic Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
View previous topic :: View next topic
Author Message
TechSY730





Joined: 26 Jul 2016
Posts: 57 on topic

Thank you for registering your game
modified
PostPosted: Wed, 19. Jul 17, 02:53    Post subject: Reply with quote Print

Version r9:

Bug Fixes:
* Fixes readtext issues in the settings
> Turns out I forgot to include the updated t file in my last version. Embarassed

Balance Tweaks:
* Reduced default wander chances to about 0.75x (except for huge ships, which were reduced by a factor of 3)
* Halved chance that ships will bypass population checks to suppress wandering behavior
> The defaults I had were too aggressive, leading to too much attrition and small ships wandering out alone with not much happening
* Significantly increased chances of small ships to join ships already wandering Kha'ak
> When bigger ships wander, small ships should now escort them more consistently, and small ships more "swarmy" than just going out by themselves to die
* For Kha'ak already wandering, improved responsiveness to move onto a new planet

ImprovedKhaak2_IK2_r9_TechSY730_hack.zip:
<Link removed because this is, yet again, broken... Embarassed>



Last edited by TechSY730 on Tue, 1. Aug 17, 03:24; edited 1 time in total
Back to top
View user's profile Send private message
SirDeathwalker





Joined: 06 Aug 2010
Posts: 286 on topic

Thank you for registering your game
PostPosted: Wed, 19. Jul 17, 08:49    Post subject: Reply with quote Print

Looks interesting, I had a small contribution to the original version of this (it was my idea to be able to change the ships the swarm uses)

I Encouraged him to make this mod to give me a 'random' force wreaking havoc on the verse. I like using Jorkins B5 Shadow vessels for the swarm. (Black on black crab/spider make a terrifying force (had to keep the numbers low or they became way OP), I just need a way to replace the engine sound with the 'scream' from the series)


I would like to watch this MOD to butt heads with the revamped version of Litcube's Revelation.... the battles should be epic, though the numbers will need to be tweaked upwards to make it more even.

Especially if you can get it to occur where the Terrans are Attacking ( a four-way 'purge' of a sector), would also be even more interesting if we can get the Yaki Armada to also attack at the same time (or even delayed a bit)


Glad to see this one lives...

Back to top
View user's profile Send private message
Iceciro





Joined: 23 Jul 2011
Posts: 40 on topic

Thank you for registering your game
PostPosted: Sat, 29. Jul 17, 20:54    Post subject: Reply with quote Print

Thanks for that, no more readtext issues!

Now I'm just having issues with getting my Military Transport to lay Kha'ak eggs... it just sits there with Unknown Command! in the ship commands list after I push the button.

Back to top
View user's profile Send private message
TechSY730





Joined: 26 Jul 2016
Posts: 57 on topic

Thank you for registering your game
modified
PostPosted: Tue, 1. Aug 17, 03:36    Post subject: Reply with quote Print

Version r10:

Bug fixes:
* FIXES A CRITICAL ISSUE THAT CAUSES ALL EGG LAYING SCRIPTS TO FAIL AND TERMINATE
> You NEED to use the "Reset egg laying scripts" option in the config menu to unbreak the queen and any wild Kha'ak (existing swarming Kha'ak are a lost cause, but those should cycle pretty quickly)
> I made a critical mistake in the utility script that queries ship size. (Why did XStudio's warning about uninitialized variables not catch this? Evil or Very Mad)
> The reason I didn't catch this earlier is that this "brokeness" occurs after the check for "are there any egg slots left?". This means the script idled fine until there was room to lay an egg, and then promptly died before doing so. In my current game, egg counts are almost always full.
* Fixes the player egg laying command to be represented by "Unknown command!" instead of the proper "Lay Kha'ak Eggs"
> Turns out XStudio corrupts the "command" field if it was pointing to a COMMAND type object defined in a t file (as opposed to a string), so I had to fix that using the in game editor.
>> As a side effect, some of the scripts have been marked as AP version scripts, but they should still work fine in TC

New features:
* You can now set the wild wandering chances to -1 to reset them to the defaults.

Known Issues:
* The command displayed for eggs is "Default Combat" or "Idle" or similar, not "Hatch into Kha'ak ship".
> If you go into the command console (if the game will let you for that ship type), then you will see the right command under "additional commands"
* If you reissue (with or without clearing the slot first) the "Lay Kha'ak eggs" command to your ship, you will lose all progress to your next egg.

ImprovedKhaak2_IK2_r10_TechSY730_hack.zip:
https://drive.google.com/open?id=0B80_EwCApP86dW9zeUhmZVVzSWc



Last edited by TechSY730 on Tue, 1. Aug 17, 05:19; edited 3 times in total
Back to top
View user's profile Send private message
Iceciro





Joined: 23 Jul 2011
Posts: 40 on topic

Thank you for registering your game
PostPosted: Tue, 1. Aug 17, 04:01    Post subject: Reply with quote Print

I would just like to say, thank you TechSY730 for being so response on this script for an ancient game! I really do appreciate you fixing the bugs I've tagged, you're awesome.

Back to top
View user's profile Send private message
TechSY730





Joined: 26 Jul 2016
Posts: 57 on topic

Thank you for registering your game
PostPosted: Tue, 1. Aug 17, 05:22    Post subject: Reply with quote Print

Sorry for the quick release, but just had to throw in some last minute improvements. Smile

@Iceciro No problem. I am a programmer by trade, and I like extending functionality, fixing bugs, and optimizing for fun.

Bug Fixes (from r10):
* FIXES A CRITICAL ISSUE THAT CAUSES ALL EGG LAYING SCRIPTS TO FAIL AND TERMINATE
> You NEED to use the "Reset egg laying scripts" option in the config menu to unbreak the queen and any wild Kha'ak (existing swarming Kha'ak are a lost cause, but those should cycle pretty quickly)
> I made a critical mistake in the utility script that queries ship size. (Why did XStudio's warning about uninitialized variables not catch this? Evil or Very Mad)
> The reason I didn't catch this earlier is that this "brokeness" occurs after the check for "are there any egg slots left?". This means the script idled fine until there was room to lay an egg, and then promptly died before doing so. In my current game, egg counts are almost always full.

Bug Fixes:
* Fixed a display bug in egg hatching remaining time where 1 hour left would render as "0:60" instead of "1:00"

Balance Tweaks:
* After ship has been taken down to 1 HP, you will no longer be able to progress in laying the next egg until you have repaired the ship beyond <self damage amount per tick>
> No more repairing marginally to get "free-ish" progress.
* When player Kha'ak ships hatch, they are assured to get at least some shields and weapons (1/4 of the turret's capacity, 1/3 of the shield capacity), so they aren't completely useless. (And getting Kha'ak weapons "legit" is enough of a pain as it is without total RNG)
> Exception, if the ship has only 1 shield slot (regardless of the shield's size), then there is a chance it will spawn with no shield.
> Reminder, in a previous version, I made it ships can no longer kill themselves laying eggs; this is still the case.

Known Issues:
* The command displayed for eggs is "Default Combat" or "Idle" or similar, not "Hatch into Kha'ak ship".
> If you go into the command console (if the game will let you for that ship type), then you will see the right command of "Hatch into Kha'ak ship" under "additional commands"
* If you reissue (with or without clearing the slot first) the "Lay Kha'ak eggs" command to your ship, you will lose all progress to your next egg.

ImprovedKhaak2_IK2_r11_TechSY730_hack.zip:
https://drive.google.com/open?id=0B80_EwCApP86Y2FJLU5qV2dQMEE

Back to top
View user's profile Send private message
FriendlyFirePhoenix





Joined: 14 Feb 2017
Posts: 41 on topic

Thank you for registering your game
PostPosted: Sat, 19. Aug 17, 15:55    Post subject: Reply with quote Print

Hi TechSY730 - Reporting another crash. Same cause as last time. I killed a Kha'ak laser tower medium egg and the game crashed. I killed about 5 other medium eggs earlier and there were no issues. Sector was Asteroid Belt. This was a few hours into a new game start using R11.

All the eggs I killed where there was no crash exploded in the normal way a thing dies in X3. The one that caused a crash went invisible at around the 0 - 2% health mark, my shots hit nothing for a while, then there was the expected explosion, then crash a split second later.

Must be annoying to get this report, especially as I have no real new information from last time. I'll try again a couple of times tomorrow to try and repeat it.

UPDATE: Tried again and caused a crash in the same way 3 more times. Sometimes the medium egg dies, the model stays visible for a few seconds afterwards, then crash. Some times the medium egg dies, the model stays visible for a few seconds afterwards then disappears then game keeps going.

My last run, I killed two medium eggs, the model stayed visible for a few seconds afterwards, game kept going, then two wares appeared on my radar. 2 of each ware in the two positions, Different IDs to the eggs, no name, worth no credits, S size, blank in every way, untargetable and in the exact positions the two eggs were at. I left the system heading south for a Terran plot mission, at Circle of Labour 5-10 minutes later, the game crashed.

Back to top
View user's profile Send private message
meppo





Joined: 13 Oct 2015
Posts: 24 on topic

Thank you for registering your game
PostPosted: Thu, 24. Aug 17, 13:01    Post subject: Reply with quote Print

are there any working xenon related mods for AP like this?

Back to top
View user's profile Send private message
FriendlyFirePhoenix





Joined: 14 Feb 2017
Posts: 41 on topic

Thank you for registering your game
PostPosted: Thu, 24. Aug 17, 13:28    Post subject: Reply with quote Print

@meppo I'd suggest taking a look at Military Base Response Revamp. Along with updating this script, TechSY730 has also updated that one. It has organised Xenon invasions along with invasions by all the other races.

Back to top
View user's profile Send private message
meppo





Joined: 13 Oct 2015
Posts: 24 on topic

Thank you for registering your game
PostPosted: Thu, 24. Aug 17, 22:45    Post subject: Reply with quote Print

all right, thanks
also is there a way to turn off kha'ak P2P jumping, i don't think i like it all that much

Back to top
View user's profile Send private message
meppo





Joined: 13 Oct 2015
Posts: 24 on topic

Thank you for registering your game
PostPosted: Thu, 24. Aug 17, 23:48    Post subject: Reply with quote Print

like shouldn't this have an on/off option? i actually cant tell if i turned it on or off and thousands of kha'ak just phase towards me

http://i.imgur.com/9ElwG0q.png

Back to top
View user's profile Send private message
SirDeathwalker





Joined: 06 Aug 2010
Posts: 286 on topic

Thank you for registering your game
PostPosted: Fri, 25. Aug 17, 02:03    Post subject: Reply with quote Print

there used to be a setting in game to modify that behavior in AL settings for this mod
there was one for the swarm and a separate setting for wild.
main page for the mod's AL life setting

(its one that wont become available until after second save and re-launch as I recall)

Back to top
View user's profile Send private message
meppo





Joined: 13 Oct 2015
Posts: 24 on topic

Thank you for registering your game
PostPosted: Fri, 25. Aug 17, 07:02    Post subject: Reply with quote Print

no i know that, i see the swarm stuff and wild settings, p2p jumping is just there without an on/off switch, i just dont know if i have it turned on or off

Back to top
View user's profile Send private message
SirDeathwalker





Joined: 06 Aug 2010
Posts: 286 on topic

Thank you for registering your game
PostPosted: Fri, 25. Aug 17, 13:22    Post subject: Reply with quote Print

it should say enabled or disabled next to the item swarm or wild, unless the update broke it. Clicking on the item switches it.

Back to top
View user's profile Send private message
meppo





Joined: 13 Oct 2015
Posts: 24 on topic

Thank you for registering your game
PostPosted: Fri, 25. Aug 17, 22:04    Post subject: Reply with quote Print

i guess the update broke it then. because P2P jumping says nothing when i click on it or not

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  Next
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Wed, 20. Sep 17, 07:32

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2017
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.57906 seconds, sql queries = 29