[SCRIPT] Salvage Insurance Contract V1.00 : 28/11/2009

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20579
Joined: Mon, 15. Nov 04, 00:26
x4

[SCRIPT] Salvage Insurance Contract V1.00 : 28/11/2009

Post by Cycrow » Sun, 29. Nov 09, 01:43

Ever forgot to buy salvage insurance when you go into battle and end up loosing alot of progress ?

Well sign up for a Salvage Insurance Contract and have your supply of salvage insurance topped up automatically so you will always have some available to use

:arrow: Installing
  • Image

    To install, use the plugin manager to install the spk file
:arrow: Using
  • The contract is disabled by default. To enable it, simply go into the AL Settings (Artifical Life) in the gameplay options menu and enable it

    Once its enabled, it will buy the insurance when you needed it as long as you have enough money in your account
Last edited by Cycrow on Tue, 25. Aug 15, 08:53, edited 1 time in total.

Lazerath
Posts: 762
Joined: Tue, 22. Mar 05, 07:31
xr

Post by Lazerath » Sun, 29. Nov 09, 04:35

Sweet!

Ty Cycrow!
COMPUTER SPECS
[Mobo] SABERTOOTH 990FX R2.0
[CPU] AMD FX-9370 8 Cores 4.4 - 4.7GHZ 16MB DDR3-1866
[Cooling] Corsair Hydro Series H80I CPU Cooler System
[Video] Evga 970 GTX SC 3.5Gb Ram ==> [Ram] G-Skills Ripjaws X 16GB
[Harddrive] (2) x Samsung 850 Evo 250GB SSD
[Harddrive] Samsung 840 Series 120GB SSD ==> [Harddrive] WD BLACK 1TB 64MB 7200RPM
[Disc Player] LG 14X BLU-RAY BURNER ==> [Case] Thermaltake A71 Chaser [Windows 7 Pro]

dark_matter_mobius
Posts: 19
Joined: Fri, 3. Sep 10, 21:15

Post by dark_matter_mobius » Fri, 25. Mar 11, 03:08

This script brings tears to my eyes. It's so beautiful *sniff*.

littleheadspin
Posts: 85
Joined: Mon, 28. Mar 11, 12:54
x3tc

Post by littleheadspin » Mon, 28. Mar 11, 23:16

Thanks

Ben_K
Posts: 7
Joined: Sun, 9. Mar 08, 19:37
x3tc

Post by Ben_K » Fri, 6. Jan 12, 20:14

Chaps,
i cannot get this script working for love nor money! It's been many years since I played X3:R with a ton of scripts, so I should be considered a Newbie once again.

I have downloaded the script, installed with the Plugin manager, Plugin Manager shows it as enabled. i run the game via the link within the Plugin Manager....

Script Editor is activated, I can enter the script editor. I have tried saving/reloading, saving/quitting/reloading, and I have selected the 'reint script caches' but to no avail.

I am sure it must be something obvious...
Any ideas?

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20579
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Fri, 6. Jan 12, 20:50

first thing to check is go into the script editor and view the scripts list, does it display the scripts in there ?

Ben_K
Posts: 7
Joined: Sun, 9. Mar 08, 19:37
x3tc

Post by Ben_K » Fri, 6. Jan 12, 20:54

Hi Cycrow, thanks for the quick response.

Yes, the script editor does show a list of scripts under 'Script Task Statistics'. There are quite a few though, and I cannot see anything to so with salvage etc.

Is there anything I should look for in particular?

(I own the game via Steam, by the way, in case that affects it)

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20579
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Fri, 6. Jan 12, 20:57

yeah if you go into the actual list of scripts. You should see one call al.insurancec.main

also, did you check in the AL Settings menu?

Ben_K
Posts: 7
Joined: Sun, 9. Mar 08, 19:37
x3tc

Post by Ben_K » Fri, 6. Jan 12, 21:35

No sign of al.insurancec.main

Yes, checked the AI Settings. All I have is 'Plugin Manager: Export Game Data'

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20579
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Fri, 6. Jan 12, 21:50

sounds like its not installed proper then.

u could try reinstalling it and see if that works.

also try running the plugin manager in admin mode and reinstall then.

it could be that its having problems writing to the game directory

Ben_K
Posts: 7
Joined: Sun, 9. Mar 08, 19:37
x3tc

Post by Ben_K » Fri, 6. Jan 12, 22:04

Ahhh, admin mode. Forgot to check that. I'll give it a go...

Ben_K
Posts: 7
Joined: Sun, 9. Mar 08, 19:37
x3tc

Post by Ben_K » Sat, 7. Jan 12, 14:09

Admin mode didn't help.

Having a look in the folders, both the script (spk) files are showing in the 'scripts' folder. However, the three files that should be in the 't' folder are not present. Does that matter?

Ben_K
Posts: 7
Joined: Sun, 9. Mar 08, 19:37
x3tc

Post by Ben_K » Tue, 10. Jan 12, 12:50

Anyone have any other suggestions? I just cannot get this script working. I have others working, it's just this one doesn't seem to want to activate.
:?

Cycrow
Moderator (Script&Mod)
Moderator (Script&Mod)
Posts: 20579
Joined: Mon, 15. Nov 04, 00:26
x4

Post by Cycrow » Tue, 10. Jan 12, 13:25

if the files are in the game directory, then its installed properly, so no idea why it wont be in game.

u could try running the al.plugin.insurance file manually from the script editor

Ben_K
Posts: 7
Joined: Sun, 9. Mar 08, 19:37
x3tc

Post by Ben_K » Tue, 10. Jan 12, 18:06

Thanks again Cycrow. Weirdly, although they appear in the scripts folder, they don't appear within the script editor in-game. I have tried downloading and reinstalling the SPK many times but I get the same result.

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”