Radeon Software Adrenalin Edition Graphics Driver (11 Oct 2018) - see thread..

Anything not relating to the X-Universe games (general tech talk, other games...) belongs here. Please read the rules before posting.

Moderator: Moderators for English X Forum

ncc386
Posts: 980
Joined: Mon, 26. Apr 04, 12:58

Post by ncc386 » Thu, 29. Jan 09, 18:56

I wonder how this will affect Mount&Blade (it freezes for many people) and Nexuiz (it hangs for some people).

I hope this update doesn't break L4D, FO3, or X3TC!

perpiotrredman
Posts: 239
Joined: Mon, 19. Jan 09, 18:31

Post by perpiotrredman » Thu, 29. Jan 09, 19:01

Haven't seen DAAMIT drivers break anything for a while now. They don't make much of a difference, but at least nothing has broken (for me (in a good long while (I think))).
/ Per
(Core i7 920 2.67GHz, 6GB 3chan DDR3 1066MHz, HD4870 512MB, Vista Enterprise 64)

User avatar
supakillaii
Posts: 1217
Joined: Mon, 19. Nov 07, 20:52

Post by supakillaii » Thu, 29. Jan 09, 19:32

Eh? Anyway, yay for ATI.

User avatar
BugMeister
Posts: 3757
Joined: Thu, 15. Jul 04, 04:41

Post by BugMeister » Fri, 6. Feb 09, 14:24

usual hilarity with latest ati drivers..

getting the 9.1 AGP hotfix is a laugh - first it's there - then it's not..!!

- you NVIDIA types don't get this free sideshow, shame... :D
- the whole universe is running in BETA mode - we're working on it.. beep..!! :D :thumb_up:

muppetts
Posts: 563
Joined: Fri, 10. Oct 03, 13:50

Post by muppetts » Fri, 6. Feb 09, 16:15

I have not changed since April last year, I just do not see any benefit, I have a stable driver and all the games work, why change?!
VURT The only Feathers to Fly With......

User avatar
BugMeister
Posts: 3757
Joined: Thu, 15. Jul 04, 04:41

Post by BugMeister » Sat, 7. Feb 09, 04:41

finally got it..

installs straight over the previous one, no probs
plays X3:TC really smoothly..

- which is nice.. :D :thumb_up:
- the whole universe is running in BETA mode - we're working on it.. beep..!! :D :thumb_up:

User avatar
BugMeister
Posts: 3757
Joined: Thu, 15. Jul 04, 04:41

Ati 9.7 Ccc

Post by BugMeister » Sun, 12. Jul 09, 00:40

leaked ATI 9.7 drivers here..
http://www.overclock.net/software-news/ ... eaked.html

- comes with a few design changes to CCC - works well in Win7 8)
- the whole universe is running in BETA mode - we're working on it.. beep..!! :D :thumb_up:

Mowen
Posts: 139
Joined: Fri, 7. May 04, 18:53

New ati catalyst driver (9.8)

Post by Mowen » Wed, 19. Aug 09, 12:44

Has someone already tested this new video driver on X3TC ?

Any performance improvements noticed ?
J'ai du me pencher de trop près sur le chaos de l'univers, j'ai tout pris dans la tronche. :-)

Alan Phipps
Moderator (English)
Moderator (English)
Posts: 18125
Joined: Fri, 16. Apr 04, 19:21

Post by Alan Phipps » Wed, 19. Aug 09, 14:11

Probably more for Off-Topic forum.

It works fine for me with X3TC (Vista x64) although with no noticed improvements in my game (still typically 50-70fps except near vanilla complexes). It took 10 mins to install and with a couple of Vista 'Continue?' dialogues and there was also a lot of hard drive thrashing during installation and on first restart. More so than I noticed with earlier version installs. It might just be my Anti-Virus being extra cautious mind. AMD do seem to spend a lot of time installing advertising splash screens and unwanted trial/freebies when all I want is the update!

Reading the Release Notes, the update is really just better Crossfire support so I would not have expected any real effect on X3TC for me in any case. I prefer to keep up to date, whatever the actual content though.

ncc386
Posts: 980
Joined: Mon, 26. Apr 04, 12:58

Post by ncc386 » Wed, 19. Aug 09, 20:30

I've been sticking with 9.2, myself. It was the last driver release ATI did before they started bragging about how much 'different' the new XP/Vista/Win7 hybrid drivers would be. I figured that because ATI usually breaks more than they fix, I'd play it safe and leave well-enough alone. :D

User avatar
RavenIII
Posts: 376
Joined: Thu, 20. Jan 05, 18:50

Post by RavenIII » Wed, 19. Aug 09, 22:05

My biggest problem was moving from 9.6 -> 9.7 (with CCC)... something must have borked somewhere, basically L4D (often played enough for me) was running rather slow, not necessarily framerate (around 50) but my mouse movement would lag, using the sniper rifle I would notice it more.

I tracked it down to smoke effects and similar effects which would push the card (put it this way, my HD4850 should not be struggling). Tried reverting back to 9.6 and my driver could not be found, so tried to reinstall (using Driver Sweeper too) and so on, did this to 9.5 and still had the same problem.

Eventually just gave up and reinstalled the 9.7 driver (without CCC this time) - I haven't tested it with the CCC but it all seems fine now, working at the usual 100-150fps when ingame. Now it is working I am reluctant to upgrade to 9.8, and seeing the release notes, it seems like a wise decision atm :P

muppetts
Posts: 563
Joined: Fri, 10. Oct 03, 13:50

Post by muppetts » Thu, 20. Aug 09, 10:23

I have just stuck to Driver only, CCC is a much older version as upgrading it always seems to bring a ton of issues. I tried using there overdrive app once *shudder...never doing that again.
VURT The only Feathers to Fly With......

User avatar
BugMeister
Posts: 3757
Joined: Thu, 15. Jul 04, 04:41

Post by BugMeister » Thu, 20. Aug 09, 23:39

yep, the 9.8 version runs fine on W7(64-bit)

- cheers for the heads up..

User avatar
Rednoahl
Posts: 898
Joined: Sat, 3. Jan 09, 16:48

Post by Rednoahl » Fri, 21. Aug 09, 00:24

I've had quite a marked improvement with these new drivers. For the first time I can run the game on max settings - good for my four year old rig :)
I'm sure I will have to turn them down for combat, but for now it's nice to see how the game should look

User avatar
BugMeister
Posts: 3757
Joined: Thu, 15. Jul 04, 04:41

Post by BugMeister » Sat, 12. Sep 09, 09:41

version 9.9 issued - no big surprises

...yet!!

- works well with W7 64-bit :wink:
- the whole universe is running in BETA mode - we're working on it.. beep..!! :D :thumb_up:

Post Reply

Return to “Off Topic English”