[SCRIPT] Salvage Command Suite V4.11 [29/12/2012]

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Post Reply
User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Sat, 29. Apr 17, 08:16

If I remember correctly, you have to fly right up to the ship and it will automatically claim it and trigger the next part of the mission.

If you claim it with any method that just 'makes a ship yours', you will just get the ship. If that happens, my scripts will recreate a new ship as the old one wasn't 'claimed' as far as it's concerned.

Try approaching the ship to within a few hundred meters as see if it works that way.

You should get a pop-up message once the ship is yours.

dtmullican
Posts: 25
Joined: Sat, 30. Apr 05, 10:33

Asteroid Relocation Service

Post by dtmullican » Mon, 14. Aug 17, 23:17

For those having the issue with ARS not working, here's a fix that worked for me.

In scs.library.trade, line 170, change from:

170 $MENU = create new array, arguments=$msg, $msg, null, 105, 334

to

170 $MENU = create new array, arguments=$msg, $msg, {Elysium of Light}, 105, 334

(You can change this to any sector that works for you.)

The problem seems to be some issue of jumping out of sector null after the ship is created. Possibly something to do with Advanced Jump Drive and the overrides. Not sure though, as I only started playing around with X3 scripting yesterday.

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Tue, 15. Aug 17, 19:26

FYI,

The SCS ships (ARS/MPW/etc.) are only created in the NULL sector as that is treated as 'local' to all sectors.

I think there is a "GetRandomSector within xx jumps" command you can use instead, otherwise you may have issues with the ship not having enough ecells to jump to the required sector.

dtmullican
Posts: 25
Joined: Sat, 30. Apr 05, 10:33

Post by dtmullican » Tue, 15. Aug 17, 23:00

Hmm...if that becomes an issue, the simplest way might be to just create the ship in the source asteroid sector? I don't believe there would be much visible difference to the player.

I'm thinking it has to be something with AJD/Overrides that is causing this jump out of Null sector issue, but I'm not familiar enough with X3 scripting to know for sure. It'd be interesting to find out if the people having issues with the ARS and MPW being stuck in sector Null are also running ADJ/Overrides.

lolcat
Posts: 3
Joined: Sun, 22. Oct 17, 05:44

Post by lolcat » Mon, 23. Oct 17, 03:07

Hi, I am new to the game as such.. I have installed though some mods in AP (ie/x,xrm,tcap(missions), and some other melarky. Now, if wanting to try this, I get files which will be overwritten.. I don't know if these are defaul tones or possibly have some edits form other packs.. what do I do?

(Generally, I have only added things when they don't overwrite so I am sure it works stil)....

e.g. !fight.attack.object.pck or so.. this I think is a signed so possibly defaul tone? I don't know.. what is the general advice for these things? (in xrm, I have a bunch of cargo drops in space so this would be good :D).
MARS'? incoming missile sound sounds like Marilyn Monroe farting at a cinema [not too loudly], going woo , wooo, wooo, wooo. <3

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Mon, 23. Oct 17, 07:10

Hi,

If you have enough free disk space. take a copy of the game installation folder before you install any large mod package, if you then end up having problems, you can just delete the original folder and replace it with the copy taken before.

You will have to be careful that saves after you install a mod can become reliant on the content of the mod and if that mod is later removed, the saves may stop working.

My script does have an option that will remove all SCS content, you can then save your game and restore the folder and it shouldn't break anything.

The only modifications I make to the signed script you mention is to add in the Stealth Satellites. If you install another script that also modifies this file, it will only affect that part of my scripts.

albazeus
Posts: 69
Joined: Fri, 21. Feb 14, 18:21

Post by albazeus » Sat, 9. Dec 17, 11:06

TECSG wrote:It's possible that LU uses the same ware slot as SCS (5833), unfortunately you can't just change the ware slot as they are fixed at certain prices.

You could try checking (in-game) the text stored at 17,5833 to see what name is stored there. It should be "Salvage Command Software".
Sorry, I'm a noob at this. Can you be more specific how to check it?
I have the same problem. I'm using LU on linux. Is there a way to fix it?

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Sat, 9. Dec 17, 12:13

If you go in to the folder called 't' in your X3 folder, you will find all the XML files for the installed Mods and Game files, look through the files that have L044 at the end of the name (044 for English) with an XML viewed or notepad. At the start of the files will be a section that describes the ware name(s) and slot used.

For example, in 7074-L044 is the English file for my SCS scripts. At the start of the file you will see this:

Code: Select all

<page id="17" title="Boardcomp. objects" descr="Quad line groups for ware factory pairs or twins (spoken by Boardcomputer)">
<t id="5833">Salvage Command Software</t>
<t id="5834">This suite of software installs many salvaging commands in your ship's systems.</t>
</page>
The ID (5833) is the ware slot.

If LU also has 5833 defined, there will be a conflict with SCS.

albazeus
Posts: 69
Joined: Fri, 21. Feb 14, 18:21

Post by albazeus » Sat, 9. Dec 17, 12:37

This what I had:

Code: Select all

$ grep 5833 *
7074-L007.xml:<t id="5833">{7074,9997}</t>
7074-L033.xml:<t id="5833">{7074,9997}</t>
7074-L034.xml:<t id="5833">{7074,9997}</t>
7074-L039.xml:<t id="5833">{7074,9997}</t>
7074-L042.xml:<t id="5833">{7074,9997}</t>
7074-L044.xml:<t id="5833">{7074,9997}</t>
7074-L048.xml:<t id="5833">{7074,9997}</t>
7074-L049.xml:<t id="5833">{7074,9997}</t>
I don't know what went wrong in my installation. Anyway I modified the files as you suggested but I still see "{}Unused{}" label instead of what I presume should be "Salvage Command Software"

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Mon, 11. Dec 17, 20:46

Hi,

That's what you should have, all the files are the same SCS mod, just a different language.

L044 is English, L039 is German, etc...

albazeus
Posts: 69
Joined: Fri, 21. Feb 14, 18:21

Post by albazeus » Mon, 11. Dec 17, 22:14

Mmm... I don't think so. That command searches "5833" in all the files in the current directory. That means that all these files have this line

Code: Select all

<t id="5833">{7074,9997}</t>
in them.
In your post above you said that it should be

Code: Select all

<t id="5833">Salvage Command Software</t>
Anyway I had to remove your mod because I saw strange things, like the camera drone was a M2, the MPW was a M5, the Repair Ship wasn't an Aran but a smaller one (NOT a carrier). Maybe it's my installation that is broken.

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Mon, 11. Dec 17, 23:45

{7074,9997} would resolve (in line 9997) to "Salvage Command Software".

From the sounds of your problems, there is a conflict with another mod. The best chance to find the conflict would be to remove more mods until the SCS scripts work again.

However, if you're okay with removing the SCS mod that will remove the problem.

Rekalty
Posts: 88
Joined: Thu, 18. Feb 10, 15:57

Post by Rekalty » Sun, 31. Dec 17, 00:16

Using this with Litcube's Universe breaks SCS in countless number of ways. Well all right, I'm sure you can count them, but there's a lot. I've had to just disable most features (in particular the hotkey, all though it works, the stuff that it does... well, they don't.)

Rescuing Astronauts turns them hostile, they'll still fly towards a station but will just get stuck in space near it forever, unless someone comes by and kills them, because of the whole hostile thing. (Also seems to become hostile to other factions, had an Argon ship fly by and shoot an Argon labeled astronaut.)

Having nothing marked when pressing the hotkey seems to make it salvage empty space, spawns a salvage marker on you and a small ship that will start salvaging... dark matter? it sure is working hard, not sure what exactly its doing though.

The Experimental Shuttle isn't in LU, so the Prototype is an OCV G (M7) instead. Other than that, the mission works fine.

Mobile Pirate Warehouse seems to be hostile to Pirates, at the very least. I managed to buy its different packs before it got blown up by a bunch of them.

Mobile Pirate Warehouse spawns incorrect ships (guessing LU swaps/changes stuff, seeing as the shuttle was changed as well)
Mobile Repair Ship & Salvager are Boron Coelacenth (M7), Hyperions are Argon Nova Prototypes (M3) and the ships that are supposed to protect the miners are Argon Express Advanced (TP) - Also, they spawn in empty space because they can't dock the "Mobile Mining HQ, because it's a M7 instead.

Also there's the issue about the Salvage Command Software being named {}Unused{} that has no description, far as I can tell it's because LU has a bunch of equipment that's been removed/blanked out as part of his overhaul, apparently that included the item ID you used, for whatever reason. Would have to dig into the LU files to resolve this. As well, Shirman Prototype has a {}Unused {} Goods item, that would be the Camera Drone, as well as another {}Unused {} (well, two) Installed Equipment, being the Camouflage Device (as well as the SCS)


I should be able to fix the issue about incorrect ships spawning (M7 G might be a bit OP, even if it only comes with just 4 lasers, it's a freaking tank.), I really liked the Mobile Mining HQ and Salvager, so I'll certainly see if I can correct the IDs myself.

As for the issue with astronauts and salvaging, I wouldn't have a clue where to begin with that.


Edit, found the issue with the Miner Defenders & Salvager Defenders and Mobile Mining Ship, in scs.mod.check.xml

Code: Select all

if $FN == 'INIT'
  * Check for ToTT
    set global variable: name='scs.valid.MRS' value=Mobile Mining Ship
    set global variable: name='scs.false.MRS' value=Aran 
    
    $ship = create ship: type=Aran  owner=Argon addto=null x=25000 y=0 z=25000
    $ToTT = $ship -> get ID code
    $ship ->destruct: show no explosion=[TRUE]
    
    $ToTT = get substring of $ToTT offset=1 length=2
    if $ToTT == 'M0'
      set global variable: name='scs.valid.MRS' value=Mobile Mining Ship
      set global variable: name='scs.false.MRS' value=Aran 
    end
    
    if $XTC
      $mpw.home.sector = create new array, arguments=16, 5, null, null, null
      $goner.home.sector = create new array, arguments=15, 11, null, null, null
      set global variable: name='scs.valid.MRS' value=Aran 
      set global variable: name='scs.false.MRS' value=Mobile Mining Ship
    else
      $mpw.home.sector = create new array, arguments=9, 10, null, null, null
      $goner.home.sector = create new array, arguments=14, 5, null, null, null
    end
    
    set global variable: name='mpw.home.sector' value=$mpw.home.sector
    set global variable: name='goner.home.sector' value=$goner.home.sector
    return [TRUE]
  end
For whatever reason, the game had replaced all instances of "Mobile Mining Ship" with "Coelacenth" - guessing it's because the MMS was renamed Mobile Mining Base-Ship in LU. Changed it to Aran, because they're not the same ship in LU, MMBS only has 5 docks and is a Terran ship, tried that at first and it ended up spawning some of the defenders/escorts in null space, because they weren't able to dock and teleport with the ship to the player location.

Code: Select all

  if $FN == 'Get Salvager'
    if $XTC
      $Salvager = 206
    else
      $Salvager = 328
    end
    $ship = get ware from maintype [SSTYPE_SHIP] and subtype $Salvager
    return $ship
  end
$Salvager = 328 -> Spawns Nova Prototypes, should be = 326 to spawn Hyperion instead.

Code: Select all

  if $FN == 'Get M3 Defender'
    if $XTC
      $Defender = 503
    else
      $Defender = 329
    end
    $ship = get ware from maintype [SSTYPE_SHIP] and subtype $Defender
    return $ship
  end
$Defender = 329 -> That's why it spawns Express Advanced, should be = 327 in LU.

User avatar
TR0LL
Posts: 7
Joined: Tue, 6. Jan 04, 05:12

Post by TR0LL » Thu, 8. Feb 18, 03:57

Rekalty did you get anywhere with your fixes? I would really like to use this with LU.
Image

joajoha
Posts: 37
Joined: Fri, 1. Dec 06, 14:03

Post by joajoha » Sun, 18. Feb 18, 23:46

+1 for X3LU compatibility :)

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”