[TC] Terran Campaign : Walkthrough

General discussions about the games by Egosoft including X-BTF, XT, X², X³: Reunion, X³: Terran Conflict and X³: Albion Prelude.

Moderator: Moderators for English X Forum

DaMuncha
Posts: 929
Joined: Mon, 1. Nov 10, 11:00

Post by DaMuncha » Sun, 29. Jan 12, 12:28

You would expect this to have been fixed by now, and I've screwed up my whole game because mission 6 hasnt been fixed yet. How many years has this game been out? This killed the game for me. Realy. I dont want to start the boring campaign again so theres no point playing any more.

I rescued the two Astonaughts, took them to the Orbital Defense Station and game says Mission Complete, evey time. Game Over.

pjknibbs
Posts: 28358
Joined: Wed, 6. Nov 02, 21:31

Post by pjknibbs » Sun, 29. Jan 12, 19:04

If it's saying Mission Complete, what's your problem, exactly? There's a gap between then and when you get contacted for the next mission.

Scorcher24
Posts: 135
Joined: Fri, 12. Mar 04, 18:58

Post by Scorcher24 » Mon, 5. Mar 12, 06:28

I am going crazy on the Mission where you have to plant the bug on the Elephant. I do it and I can't get away.
They kill me before.
I sent my M3 after them, but they smoke it pretty quick and me afterwards.
I changed to my Nova Attacker before planting, same result.
I even bought a Zentaur loaded with Weapons and Missiles and asked him defend me, same result. My Ship was gone before he even attacked and then I watched them destroying my Zentaur while I was in the Spacesuite.

Seriously, Egosoft, how can you send 5 deadly combat ships after the player when you expect him to sit in a defenseless freighter which goes by 99m/s???


Any input is appreciated.

whiteraider
Posts: 499
Joined: Sun, 7. Mar 04, 01:08

Post by whiteraider » Mon, 5. Mar 12, 06:43

Scorcher24 wrote:I am going crazy on the Mission where you have to plant the bug on the Elephant. I do it and I can't get away.
They kill me before.
I sent my M3 after them, but they smoke it pretty quick and me afterwards.
I changed to my Nova Attacker before planting, same result.
I even bought a Zentaur loaded with Weapons and Missiles and asked him defend me, same result. My Ship was gone before he even attacked and then I watched them destroying my Zentaur while I was in the Spacesuite.

Seriously, Egosoft, how can you send 5 deadly combat ships after the player when you expect him to sit in a defenseless freighter which goes by 99m/s???


Any input is appreciated.
Jumpdrive...
Bring back the TS Pirate Ship, I miss my liberated fleet runing around the universe :twisted:
Maybe a fleet of liberated Pirate Ship Super Freighters :roll:

"Priests Dukes Compliments... Here is ship!"
"Teladi now show you how to fight... Ship all yours! Dont kill Teladi!"

clint945
Posts: 4
Joined: Tue, 12. Jun 12, 09:26

Post by clint945 » Tue, 12. Jun 12, 09:36

Mission 3 is impossible for me due to a... Sort of bug...

A few days before i started the Terran plotline a large Kha'ak force arrived in the Circle of Labour system, i was able to ignore it and reroute my transports so that it wasn't a problem .

However, in the patrol mission, it's included the Kha'ak ships in the mission objective. Along with the usual Xenon ships...
The Xenon were not really a problem cause most of them were P's and went down like pizza at a drunken party, but the Xenon have like 3 clusters, multiple clouds of random ships (15+ per cloud) as well as 1 destroyer and 2 carriers as far as i can make out.
It's a MASSIVE attack....

And until i can defeat ALL of that, i can't progress to the next part of the patrol.....

any tips on how i can remove those guys? or will i just have to ignore this plotline for now and raise myself an army...

mati140
Posts: 32
Joined: Thu, 15. Jan 09, 21:15

Post by mati140 » Fri, 13. Jul 12, 23:31

It's not a bug, I once got the entire Herons Nebula destroyed by 2 Kha'ak destroyers. It happens randomly. Either raise fleet or kill them with cheats.
Scorcher24 wrote:I am going crazy on the Mission where you have to plant the bug on the Elephant. I do it and I can't get away.
They kill me before.
I sent my M3 after them, but they smoke it pretty quick and me afterwards.
I changed to my Nova Attacker before planting, same result.
I even bought a Zentaur loaded with Weapons and Missiles and asked him defend me, same result. My Ship was gone before he even attacked and then I watched them destroying my Zentaur while I was in the Spacesuite.

Seriously, Egosoft, how can you send 5 deadly combat ships after the player when you expect him to sit in a defenseless freighter which goes by 99m/s???


Any input is appreciated.
I finished this mission today, my Caiman had no shields and 15% of hull (pilot jumped out at 10%, than I manually repaired it to 15% for higher speed).

You need a transporter device on board of the vessel you fly mission in. After switching to Caiman I ordered my Nova Raider (with Pearl on board) to protect me. Once I plugged the bug into Elephant I quickly transfered myself back to the Nova with transporter device and let the terraformers eat caiman, while I charged my jumpdrive.

Once the bug is planted the Caiman isn't needed, you can simply teleport to something that can survive.

Nebdeath
Posts: 3
Joined: Tue, 8. Sep 09, 08:21

Post by Nebdeath » Wed, 1. Aug 12, 05:36

Hi just finished the Terran Campaign with the most up to date version. I was able to Board and take over the Vidar with 6% of hull left on completion. I jumped the scabbard into aldrin with my main ship and there was a second scabbard (another 10 marines too) there for me to control :D I was able to overtake the Xenon ship!!! YAY!!!! I had both scabbards board. However, you don't get the Xenon ship... Booo lol. But at the end of the campaign I noticed I had a Claymore at earths Station... YAY again. The whole campaign played through start to finish without a hick-up... great guide!!!

Nebdeath
Posts: 3
Joined: Tue, 8. Sep 09, 08:21

Post by Nebdeath » Thu, 2. Aug 12, 16:57

@
mati140 did you upgrade your caimens' speed/rudder, and add the shields as the guide suggested etc? if so it should pull away and all the way to the gate almost unscathed. The ships only chase you for 7 km's or so

slevin0006
Posts: 23
Joined: Wed, 22. May 13, 01:17

Post by slevin0006 » Fri, 24. May 13, 19:49

hey,'am at the mission six where i need to buy some satellites(navigation relay i guess) i went to black hole sun in millitary post there, they suppose to make 'em but they never have in stock.i find some other places where they MAKING it, but they NEVER have when i check.is there a place i can go where i can be sure they gonna have?? o.O start to get boring traveling dozens systems an always finding some place where they suppose to make it BUT NEVER HAVE IN STOCK !!! :evil: lol really, it would be nice if u can get back to me quickly whit this, i don't wanna waste my ''gaming hours'' to do so stupid search for something i know what i have to do...

Honved
Posts: 1221
Joined: Sun, 20. Jun 10, 14:53

Post by Honved » Fri, 24. May 13, 21:05

Cloudbase SW, a long way off near Argon Prime, makes them, but there's probably a closer source. I THINK there's supposed to be a factory in Interworlds, but it usually gets deleted quickly, and another in a Teladi sector you pass through while following a Pirate Nova during an early plot mission.

Trading Stations and Military Outpost "absorb" them, not produce, so it's hard to find any spares for sale.

BBare
Posts: 1
Joined: Thu, 28. Jan 10, 20:06

Post by BBare » Wed, 4. Sep 13, 19:18

But what about the mission where you have to hack the #café ship? I did the first hack but the second one is beating me like I owe it money.

Mousse9
Posts: 367
Joined: Mon, 5. Aug 13, 23:16

Post by Mousse9 » Wed, 4. Sep 13, 20:44

I cheated. I wrote down all the numbers and the schematic, saved, and then went online to a sudoku solver to do it for me. :P

Xavien
Posts: 3
Joined: Sun, 22. Sep 13, 19:19

Post by Xavien » Mon, 23. Sep 13, 21:21

Seems for me mission 7 is bugged when im suppose to protect the boarding parties nothing happens the mission just goes on and on and on and doesnt update

oliverpc
Posts: 5
Joined: Fri, 21. Mar 14, 17:35

Post by oliverpc » Fri, 21. Mar 14, 17:55

Hi, I am a fan of this game, but I have trouble in the mission 6 where I need to find the jumpdrive freighter, I cant find it, where is it? and what do I do when i find It?

thanks for your reply

User avatar
TTD
Posts: 10913
Joined: Sun, 6. Jul 08, 10:29

Post by TTD » Sat, 22. Mar 14, 00:06

Use a triplex scanner. The ships in question will be highlight above the normal list.There are three of them.

Post Reply

Return to “X Trilogy Universe”