EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
How to disable ffdshow
Post new topic Reply to topic Goto page 1, 2, 3  Next
View previous topic :: View next topic
Author Message
Carlo the Curious





Joined: 05 Mar 2007
Posts: 15622 on topic
Location: London, UK
Thank you for registering your game
modified
PostPosted: Mon, 20. Oct 08, 01:59    Post subject: How to disable ffdshow Reply with quote Print

X3TC doesn't like the ffdshow codecs, so if you have it installed (on its own or as part of a codec pack) you need to either uninstall it, or exclude X3TC from the programs that use it.

First you need to run the ffdshow Audio decoder configuration utility:

    If you installed ffdshow on its own then it should be in Start menu/Programs/ffdshow.

    If you installed it as part of a different codec pack it may be listed under the codec pack (e.g. CCCP or Vista Codecs).

    You might also be able to access it directly from the Run menu (windows key + R):
    'C:\WINDOWS\system32\rundll32.exe ffdshow.ax,configureAudio' or
    'C:\Windows\SysWOW64\rundll32.exe ffdshow.ax,configureAudio'

    Depending on your media player version and how you installed ffdshow, you may be able to access it via Windows Media Player, menu > Tools > Options, DVD, Advanced.

    Failing that, run a file search for ffdshow.

In the DirectShow control tab there's a section called "Don't use ffdshow in:". Make sure the adjacent box is checked and add x3tc.exe to the list of programs (you can do this via the Edit button or just type it in the box):


Hit 'Ok' once you're done.

In some versions of ffdshow the exclusion list is under 'Info and debug':


Now you need to run the ffdshow Video decoder configuration utility and do the same thing.

Your X3:Terran Conflict should now be ffdshow-free!



EDIT: Added comments by Greyward, Spamas and Wolf-R1.
EDIT2: Added WMP method (courtesy of Terre).
Edit3: Replaced outdated image links (old links: #1, #2). X2-Illuminatus



Last edited by Carlo the Curious on Sat, 27. Jul 13, 16:14; edited 10 times in total
Back to top
View user's profile Send private message Visit poster's website
Greyward





Joined: 08 Jun 2005
Posts: 32 on topic

Thank you for registering your game
PostPosted: Mon, 20. Oct 08, 15:36    Post subject: Reply with quote Print

First off, I'd like to thank you Carlo cause this definitely helped! But second, I'd like to point out that for net hounds like me who've downloaded codec packs, ffdshow might not be in the directory you mentioned; in fact, you may not even know you have it!

So if anyone out there is having audio hitches (I was experiencing a "jump" in video and audio every five or six seconds; at very regular intervals) and you've downloaded a lot of codecs or codec packs or are simply not sure of what you have, I recommend running a search for ffdshow.

Back to top
View user's profile Send private message
Spamas



MEDALMEDAL

Joined: 05 Feb 2005
Posts: 56 on topic

Thank you for registering your game
PostPosted: Tue, 21. Oct 08, 02:27    Post subject: Reply with quote Print

Thanks for this little bit of info, I found it very handy. My system however is setup slightly differently perhaps due to a different version perhaps because of the codec pack CCCP.

Firstly, FDD show can be found in programs > CCCP > (filters) > FDD show audio codec config

Secodly, I believe the version of FDD show I'm using is slightly older than yours, so program excemptions are not under "Directshow Control" but under "Info & debug" in the debug section. Hope others find this helpful.

[edit]My system is a mess, so I've ended up uninstalling all my old codec packs and installing the newest version. However the above should still be vaild for users of an old FDD show version.

Back to top
View user's profile Send private message
Wolf-R1





Joined: 27 Jul 2006



PostPosted: Tue, 21. Oct 08, 21:47    Post subject: Reply with quote Print

Thanks for this bit of info. My system gets a bit of video lag on occasion and this may help resolve it.

My settings were found here:

Start > All Programs > Vista Codecs > 64Bit Tools

Back to top
View user's profile Send private message
DrwHem





Joined: 11 Nov 2007
Posts: 576 on topic

Thank you for registering your game
PostPosted: Sun, 14. Dec 08, 05:22    Post subject: Reply with quote Print

I was unable to find my ffdshow files so when i did a search for it all i got were 3 programs...they were do not use ffdshow, set MPG@ to use ffd show, and use ffdshow. i clicked do not use ffd show but nothing happened except a little vista circle. did i turn this off?

Back to top
View user's profile Send private message
Terre
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 19 Dec 2005
Posts: 7037 on topic

Thank you for registering your game
PostPosted: Mon, 22. Dec 08, 12:46    Post subject: Reply with quote Print

Media Player Classic (either standalone or part of the K-Lite codec pack)
Play > Filters > fddshow Audio/Video decoder

Back to top
View user's profile Send private message
Dungeoncrawler





Joined: 07 Dec 2003
Posts: 1066 on topic
Location: Cincy, OH-USA
Thank you for registering your game
PostPosted: Wed, 24. Dec 08, 04:32    Post subject: Reply with quote Print

I'm showing a few nero codecs associated with quicktime (not installed on my pc) in my DX log. How do I go about getting rid of these?

Dc

Back to top
View user's profile Send private message
eladan





Joined: 07 Jan 2006
Posts: 5307 on topic
Location: Sunshine Coast, Australia
Thank you for registering your game
PostPosted: Tue, 30. Dec 08, 10:39    Post subject: Reply with quote Print

Dungeoncrawler wrote:
I'm showing a few nero codecs associated with quicktime (not installed on my pc) in my DX log.

Confused

You might have to post the relevant part and explain what you mean - the only Nero codecs I'm aware of are installed with the Nero suite. AFAIK, the only way to remove them is to remove Nero.

Back to top
View user's profile Send private message
Chealec



MEDALMEDAL

Joined: 20 Aug 2006
Posts: 1209 on topic

Thank you for registering your game
PostPosted: Sun, 4. Jan 09, 04:48    Post subject: Reply with quote Print

oh.... my.... god....

I wish I'd found this earlier - I was only looking to see if there were any issues on frame rate that I didn't know about because I was just flying through Ore Belt (a bad system anyway) and there was a Paranid M7 fighting a Plutarch M7 and a few fighters with PBGs. Frame rate completely splattered (talking 1 frame every 4 seconds levels of bad) and I had to get to the Terracorp HQ to buy a new jumpdrive.

Followed the instructions, disabled FFD Show for X3tc.exe and decided to see what kind of difference it made. Gave it a decent work out by attacking the Plutarch HQ in Ore Belt with an M2, an M1 and it's fighter wing of 40 Nova Raiders... and it was perfectly playable, chugged a little teeeeeeny bit when the Plutarch HQ blew up, but that was it! Very Happy

ME SO HAPPY!


_________________


... old skool
Back to top
View user's profile Send private message
Crustacean Soup





Joined: 21 Dec 2008
Posts: 9 on topic
Location: Winnipeg, Manitoba, Canada
Thank you for registering your game
PostPosted: Sun, 11. Jan 09, 03:49    Post subject: Reply with quote Print

I'm not having any great issues leaving ffdshow on for audio, and music sounds absolutely horrific without it (possibly related to whatever has been previously notice with x64 Vista and Realtek audio chips). ffdshow and video certainly causes instability, though.

Back to top
View user's profile Send private message
TemplarThano





Joined: 31 Dec 2008



PostPosted: Wed, 14. Jan 09, 18:29    Post subject: Reply with quote Print

My FFdshow doesnt have the option to Disable it for specific programs Sad i just have the "multiple ffdshow instances" dropdown menu. So if i chose "none - Disabled" will that do as a workaround? Confused

Back to top
View user's profile Send private message
WarpedcowOwnzU



MEDALMEDALMEDAL

Joined: 08 Sep 2005

Location: Minnesota, United States of America

PostPosted: Fri, 16. Jan 09, 23:29    Post subject: Reply with quote Print

TemplarThano wrote:
My FFdshow doesnt have the option to Disable it for specific programs Sad i just have the "multiple ffdshow instances" dropdown menu. So if i chose "none - Disabled" will that do as a workaround? Confused


You must have a VERY OLD version of ffdshow. You should get the latest FFDSHOW Tryouts from here:
http://ffdshow-tryout.sourceforge.net/

That will let you disable it for specific programs. It even comes with a list built in of various games and apps.


_________________
www.trackpedia.com
ASUS P5Q Pro - Intel Core 2 Quad Q9550 @ 3.4GHZ - ATI Radeon 4870 - 4GB OCZ Reaper DDR2 1066 - Windows Server 2008 64bit - 2x500GB in RAID1
#1 in X3TC Ships Destroyed
Back to top
View user's profile Send private message Visit poster's website AIM Address
Carlo the Curious





Joined: 05 Mar 2007
Posts: 15622 on topic
Location: London, UK
Thank you for registering your game
PostPosted: Tue, 20. Jan 09, 22:01    Post subject: Reply with quote Print

Crustacean Soup wrote:
I'm not having any great issues leaving ffdshow on for audio, and music sounds absolutely horrific without it (possibly related to whatever has been previously notice with x64 Vista and Realtek audio chips). ffdshow and video certainly causes instability, though.

Discussed here.

The 'official' stance is still that it should be disabled for TC.

Back to top
View user's profile Send private message Visit poster's website
pelador





Joined: 06 Nov 2002
Posts: 1230 on topic
Location: UK
Thank you for registering your game
PostPosted: Sun, 1. Feb 09, 16:04    Post subject: Reply with quote Print

Quick question: but is it likley i may not have ffdshow installed?

I've done a non-indexed search and didnt find it.

Its a new PC and as far as I can remember I havent specifically downloaded any extra codecs but am using Realtex HD Audio manager.


_________________
X3TC:V2.1M

Dedicated Assistant Drones (DAD); Pirate Fence; Player Workshops; Convert Passenger to Marine
Back to top
View user's profile Send private message Send e-mail MSN Messenger
CBJ
EGOSOFT
EGOSOFT



Joined: 29 Apr 2003
Posts: 35868 on topic

Thank you for registering your game
PostPosted: Sun, 1. Feb 09, 17:22    Post subject: Reply with quote Print

If you were to post a DXDiag report then we'd be able to tell you. Or you could just check it yourself.

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic Goto page 1, 2, 3  Next
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Tue, 21. Aug 18, 11:53

All times are GMT + 2 Hours

[ Disclaimer / Impressum ] | [ Privacy Policy / Datenschutz ]

Board Security

Copyright © EGOSOFT 1989-2018
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.10237 seconds, sql queries = 29