EnglishGermanFrenchRussianPolishItalianSpanish
Log inRegister
 
Gameplay Bugs and Issues List Tech Support Summission Discussion.
Post new topic This topic is locked: you cannot edit posts or make replies. Goto page 1, 2, 3, 4, 5, 6  Next
View previous topic :: View next topic
Author Message
apricotslice





Joined: 16 May 2004
Posts: 13627 on topic
Location: In the Hunter Legacy Universe
Thank you for registering your game
modified
PostPosted: Fri, 25. Aug 06, 14:07    Post subject: Gameplay Bugs and Issues List Tech Support Summission Discussion. Reply with quote Print

The submission to Tech Support is now available here.
http://circleofatlantis.com/X3forum/viewtopic.php?p=83#83

The submission to Tech Support has now been made.

--------------------

The release of the new script pack has unleashed a new wave of complaints about the gameplay bugs still in the game and the lack of action on them. Namely this thread http://forum2.egosoft.com/viewtopic.php?t=151566.

To this end, after advise from CBJ, I am going to recreate the bugs and issues list thread, but this time, its purpose is to compile a list of actual gameplay bugs that are considered essential to be fixed in order that game play is not compromised. I call these "Game killer" bugs. While not specifically of that nature, any problems with egosoft ships such as the rear turrent on the orca, can be included, since these should be fixed imo.

This list will then be compiled into a submission to tech support for the devs to consider actioning.

Please read the old thread first, especially the full OP.

http://forum2.egosoft.com/viewtopic.php?t=137858

Please make a submission here in this thread for any bug or issue you consider a major problem to the game.

NOTE : Nothing from the old bugs list is being automatically included in the new one, only the ones I added to it myself. If you want something on the old list included, you must make a new submission here.

Please be as concise as possible, giving the exact nature of the bug/issue, how and where it occurs and any situation required to trigger it, and if you have one, a suggested way of fixing it.

If you submit an issue that has already been dismissed by CBJ in the original thread, you will need to justify its inclusion.

This thread is not for argument, it for SUBMISSIONS. You are free to add information to another persons submission, but please to not start any arguments here.

As submissions are made, I will compile them as I see ones which I think should be included.

Please do not include links to existing discussions. If a good description of a problem already exists here, please quote it into this thread, with the name of the author attached if it wasnt your words.

I thank you in advance for your support and hope that this process leads to a submission that will allow the devs to identify and fix the gameplay bugs that affect us the most.

Included so far :

1. Bug : Autopilot suicide, player ship.
2. Bug : Autopilot Speeds.
3. Bug : Autopilot for TL/M1/M2
4. Bug : Ships sideswiping ships and stations while undocking.
5. Bug : Auto-pilot after collision
6. Issue : Tractor Beam Forges are removed by the God Engine before the player can find the forges or has a ship that can mount one.
7. Bug : Collect Wares in Sector command.
8. Bug : XI mission spawning
9. Bug/Issue : Ships destroyed by God-Engine removing Station.
10. Bug : Model problems in ships. Orca (rear turrent, side turrent), Caiman (Bridge). Demeter model wrong ? More detail needed on these problems please
11. Bug : Hull damage to stations by enemy ships cannot be repaired.
12. Bug : Tractor Beam range is not long enough.
13. Bug : When you add a new station to a complex, all the prices the player has set get reset to default values.
14. Issue : Remove homebase ability missing. (Fixed in Bonus Pack).
15. Bug : OOS Lasertowers.
16. Issue : Please LOSE Susie. She is driving everyone nuts !
17. Bugs : Boring Boron Start.
18. Bug : Convoy Mission in Ore Belt.
19. Issue : IS Mobile Mining.
20. Plea : Re-allow TS/TP ships to dock with TL and M1.
21. Bug : Disappearing ships


_________________
Apricot Mapping Services HQ
CLICK HERE for X3 Handbook; TC and AP Guides, Mods, Scripts & Downloads


Last edited by apricotslice on Thu, 31. Aug 06, 07:10; edited 12 times in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website
jlehtone



MEDALMEDALMEDAL

Joined: 23 Apr 2005
Posts: 16730 on topic
Location: GalNet BBS
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 14:19    Post subject: Reply with quote Print

This is already mentioned in the old OP, and is not necessarily a "game stopper", at least for all of us:

The Tractor Beam Forges will eventually disappear from the game and so do all the produced Tractor Beams. This may very well happen before the player has resources to obtain one. Particularly, the player may not foresee the need of the Beam in time.

Back to top
View user's profile Send private message
apricotslice





Joined: 16 May 2004
Posts: 13627 on topic
Location: In the Hunter Legacy Universe
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 14:22    Post subject: Reply with quote Print

jlehtone wrote:
This is already mentioned in the old OP, and is not necessarily a "game stopper", at least for all of us:

The Tractor Beam Forges will eventually disappear from the game and so do all the produced Tractor Beams. This may very well happen before the player has resources to obtain one. Particularly, the player may not foresee the need of the Beam in time.


I agree. The player should be able to find one when they finally are able to afford one and have the ship to use it, and thats well into the game. Difficult to find is one thing, unobtainable is a gameplay issue.


_________________
Apricot Mapping Services HQ
CLICK HERE for X3 Handbook; TC and AP Guides, Mods, Scripts & Downloads
Back to top
View user's profile Send private message Send e-mail Visit poster's website
apricotslice





Joined: 16 May 2004
Posts: 13627 on topic
Location: In the Hunter Legacy Universe
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 15:13    Post subject: Reply with quote Print

Bug : Autopilot suicide, player ship.

Senario :
When the autopilot is engaged, when an object, like a roid or station is in direct line between the ship position and the target destination point, the ship will crash into the obstacle. 98% guarenteed.

The ship proceeds directly toward the obstacle at full speed. At the last instant, the ap recognises that a collision is imminent and initiates a 90 degree course change.

At full speed, inertia carries the ship into collision. Game over.

Problems :
The avoidance is recognised far too late. The evasion is far too radical. Inertia is ignored in the avoidance taken.

Solution :
When the AP is engaged, it should recognise a collision will occur on the direct course. A course correction of say 25 degrees is applied before the ship even begins to move (may need more or less, but without knowing the existing coding, its hard to advise what will work best). This is then checked for collision, until a course that will not result in a collision is selected. Then the ship begins to move under AP control. After which, normal course checking for collision and destination should detect the needed change in course once the obstacle is cleared. The ship moves around the main obstacle in a sort of arc, rather than trying to avoid it at the last second.

Extra :
AI controlled ships should also use the same logic.


_________________
Apricot Mapping Services HQ
CLICK HERE for X3 Handbook; TC and AP Guides, Mods, Scripts & Downloads
Back to top
View user's profile Send private message Send e-mail Visit poster's website
apricotslice





Joined: 16 May 2004
Posts: 13627 on topic
Location: In the Hunter Legacy Universe
Thank you for registering your game
modified
PostPosted: Fri, 25. Aug 06, 15:16    Post subject: Reply with quote Print

Bug : Autopilot Speeds.

As far as I can tell, the speed used for autopilot avoidance of obstacles is hardcoded, not using the actual max speed of each individual ship.

The faster the ship, the more likely it will collide with something. Its as if the avoidance is being activated far too late because the speed of the ship is not what the avoidance coding expects it to be and so the ship is closer to an obstacle by the time avoidance happens, than the code thinks the ship should be. Result is collision, because the avoidance is triggered too late.


_________________
Apricot Mapping Services HQ
CLICK HERE for X3 Handbook; TC and AP Guides, Mods, Scripts & Downloads


Last edited by apricotslice on Fri, 25. Aug 06, 15:37; edited 1 time in total
Back to top
View user's profile Send private message Send e-mail Visit poster's website
apricotslice





Joined: 16 May 2004
Posts: 13627 on topic
Location: In the Hunter Legacy Universe
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 15:24    Post subject: Reply with quote Print

Bug : Autopilot for TL/M1/M2

The autopilot makes no distinction for the size of a vessel and its ability to navigate an asteroid feild.

Anyone who has watched a Mammoth navigate from the north to south gates of CBSW knows how torturous the route is for a big ship.

I've sat in ore belt and told a mammoth to move 500 meters from a gate and watched it do a long round the sector route to get there, to avoid a lot of roids it didnt even need to go anywhere near. In most cases, the Mammoth is destroyed.

The procedure for moving a big ship should be different than for small ones.

The main problem is that the TL/M1/M2 proceeds at full speed the same as any other ship, and relies on the AP to avoid collisions. And it cant cope.

The procedure for moving a large ship should be :

Select a course free of obstacles, turn the ship while stopped, move the ship to a safe point, stop, find a new course, move the ship at an appropriate speed, stop, find, move, stop, find move etc.

TL/M1/M2 have no ability to turn and should not be turning at full speed in the middle of an asteroid field or near stations. All menouvering must be made while stopped.

As this code seems to exist to align with a gate, or a docking port, it should be possible to get the AP to use it always.


_________________
Apricot Mapping Services HQ
CLICK HERE for X3 Handbook; TC and AP Guides, Mods, Scripts & Downloads
Back to top
View user's profile Send private message Send e-mail Visit poster's website
apricotslice





Joined: 16 May 2004
Posts: 13627 on topic
Location: In the Hunter Legacy Universe
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 15:32    Post subject: Reply with quote Print

Bug : Ships sideswiping ships and stations while undocking.

While partially fixed in 1.4, ships still hit stations and other ships while undocking from the external docking ports.

Several of the capital ships have been reported to always hit the station on departure. If IS, ship is destroyed.

Obviously, some aspect of the models is not being handled properly.

I'm not sure which ships are involved so would appreciate someone listing them here.

Part of the problem is ships going to full speed ahead, too soon. Or they rotate too close to the docking port and hit things because the model is longer than the the gap allowed for them to turn in.

All ships should back out of the docking arms to the start of the docking lights, and then the AP takes over and begins to turn the ship to travel. Speed is not applied to the ship until the direction of travel away from the station has been achieved, and confirmed as not being a collision course.

The player ship should reverse at full reverse speed, until the player manually changes the direction and speed. (this seems to happen in 1.4, but not 100% of the time). Joystick overrides are suspected of causing player collisions, but not enough investigation has occured to figure if this is the problem.


_________________
Apricot Mapping Services HQ
CLICK HERE for X3 Handbook; TC and AP Guides, Mods, Scripts & Downloads
Back to top
View user's profile Send private message Send e-mail Visit poster's website
jlehtone



MEDALMEDALMEDAL

Joined: 23 Apr 2005
Posts: 16730 on topic
Location: GalNet BBS
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 15:36    Post subject: Reply with quote Print

Autopilot on "collect object from space" operation.

Symptom: Ship misses the object, turns 360, and is in same position than before. Endless loop.

Proposed solution: Stop, turn on target, approach slowly. Or whatever suits the other autopilot modifications.

Back to top
View user's profile Send private message
apricotslice





Joined: 16 May 2004
Posts: 13627 on topic
Location: In the Hunter Legacy Universe
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 15:44    Post subject: Reply with quote Print

jlehtone wrote:
Autopilot on "collect object from space" operation.

Symptom: Ship misses the object, turns 360, and is in same position than before. Endless loop.

Proposed solution: Stop, turn on target, approach slowly. Or whatever suits the other autopilot modifications.


Speed is usually a factor here. The ap moves the ship at full speed, and so misses on the first pickup, and then tries to reallign itself on the target at full speed. Eventually it may or may not, slow down enough to align correctly. If it doesnt slow, it never moves far enough away to properly align at the speed the ship is moving.

If the ship misses the target on the first pass, it should stop, realign then move slower to pick up. Most pickups should be under 100, yet faster ships use top speed all the time.

The X2 code worked perfectly. Why is the X3 code different ?


_________________
Apricot Mapping Services HQ
CLICK HERE for X3 Handbook; TC and AP Guides, Mods, Scripts & Downloads
Back to top
View user's profile Send private message Send e-mail Visit poster's website
apogee



MEDALMEDALMEDAL

Joined: 22 Jul 2004
Posts: 1098 on topic
Location: Location Location
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 15:51    Post subject: Reply with quote Print

1) Re the ships sideswiping from docking ports (@apricotslice above)

Can we have something done about the "double" docking clamps on equimpent docks where 2 large ships dock. on undocking you are either destroyed or ejected 3k away from a station. Either stop 2 large ships sharing one of the double points or replace the bay with the standard 5 clamp model.

2) The message "Target is now in firing range" and the reticule changes based on the range of any installed weapon, i think this should occur when a target comes into range of active weapons only. e.g. if you have a mixture of appc and bhept on a dragon, and only the bhept weapon group is active on the ship, then you get this message at about 4.2k, far outside the range of a bhept. (minor fault)

3) Disappearing ships (this could be already posted in one of the original threads). Whilst i have never had a capped ship disappear (many people have and this is a bug in itself), i have seen pirate ships just disappear from a oos secor map. This should not happen.

4) XI mission spawning, ok this may be debatable because i have exploited this flaw myself, but its a bug none the less.

Back to top
View user's profile Send private message
moggy2



MEDALMEDAL

Joined: 06 Nov 2002
Posts: 4588 on topic
Location: Montréal
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 16:46    Post subject: Reply with quote Print

re: cargo scooping
Quote:
The X2 code worked perfectly. Why is the X3 code different ?


the ship slides sideways as it's turning in X3. What happens is the ship turns to face the target, slips sideways and misses it.
It needs to approach from further away so the slide has finished and it can fly straight at the target. I've made the same mistake myself a couple of times.


_________________

RSS Feed : Submit News Article : Download Scripts : Image Galleries
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
leloa





Joined: 19 Jul 2006
Posts: 503 on topic
Location: here
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 17:05    Post subject: Reply with quote Print

bug:systems that lost many stations dont make new stations

Back to top
View user's profile Send private message
jlehtone



MEDALMEDALMEDAL

Joined: 23 Apr 2005
Posts: 16730 on topic
Location: GalNet BBS
Thank you for registering your game
PostPosted: Fri, 25. Aug 06, 17:12    Post subject: Reply with quote Print

apogee wrote:
4) XI mission spawning, ok this may be debatable because i have exploited this flaw myself, but its a bug none the less.

IMO, the "realistic" solution would be to expire the message on any boards that have it the moment one copy is accepted anywhere.

However, I assume that the XI script simply adds the message to BBS when invasion is 'active' and you dock at valid stations. Thus it may not 'know' which BBS actually have a copy. Maybe a solution would be to add the message on dock and expire it already on undock? It would reappear if one redocks anywhere, as long as the mission remains 'active'.

Back to top
View user's profile Send private message
apricotslice





Joined: 16 May 2004
Posts: 13627 on topic
Location: In the Hunter Legacy Universe
Thank you for registering your game
PostPosted: Sat, 26. Aug 06, 12:23    Post subject: Reply with quote Print

Can anyone confirm that the rear turrents of all Orca's in the game do not fire ?


_________________
Apricot Mapping Services HQ
CLICK HERE for X3 Handbook; TC and AP Guides, Mods, Scripts & Downloads
Back to top
View user's profile Send private message Send e-mail Visit poster's website
MeGrand





Joined: 31 Jul 2006
Posts: 38 on topic

Thank you for registering your game
PostPosted: Sat, 26. Aug 06, 12:52    Post subject: Reply with quote Print

Player controlled ones certainly don't

OSS they seem to

IS - unsure (sorry)

note also one of the side turrets fails for orcas, not just the rear


Also i suspect your on a hideing to nothing on the pathfinding issues, its been a bugbear for as long as thier have been computer games, interesting to note though that were currently at the paramecium level of navgation, wonder when we'll move up the tree

personal bug bear:-

where'd shortcut X go for exchange freight?


_________________
All the right letters, just not nesacarily in the right otder
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic This topic is locked: you cannot edit posts or make replies. Goto page 1, 2, 3, 4, 5, 6  Next
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Thu, 25. May 17, 04:55

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2017
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.67290 seconds, sql queries = 29