[HELP] Question re "save=false" in content.xml

The place to discuss scripting and game modifications for X Rebirth.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Post Reply
SweetDaggerfall
Posts: 5
Joined: Sun, 17. Feb 19, 10:56
xr

[HELP] Question re "save=false" in content.xml

Post by SweetDaggerfall » Tue, 19. Feb 19, 13:06

I've looked around a few modding guides and done a general search but not found anything useful to this question.

Q: Why not add "save=false" to all mods in their 'content.xml' file?

I'm wondering why this is not a default standard for all mods? Or why it might vary depending on mod type? What bought this question up for me was seeing a comment in a thread on Nexus under an authors mod where a user requested they add it to their content.xml, and i'd seen that request a few times in comments sections under mods.

So what is the purpose of having this comment and why would you not have it by choice (not having stuff in your save game unless very neccesary would seem like a good idea)?

Say for example i wanted to go through my list of mods and 'add' this entry, would that be a bad idea in general? And just for completeness sake here is my current list of mods (some will already have the 'save=false' flag added) minus the 2 Egosoft DLC:

5km scan range
Exploration Light
ISE
Log Everything
Capital Ship Bridge
StationAnnouncements
Navpath Fix
Nebulawolf's Eye Mod - Crystal Blue
Nebulawolf's Yisha Face Mod
Nebulawolf's Hair Mod - Black
Build Titurel
Stronger Ship hulls L/XL
Titurel Engine Fix Standalone
No Highway Music
Realistic Highways
No you Shut Up Yisha!
RecycleAnyStation
Relation Talks
RS_Physics_ASSIST
Show Skills
Epic External Shields
XR_Nebulas
XR_Planets
Yisha_Technician

So IF adding the 'save=false' flag can be done to any mod, i'd be tempted to go through that lot and add the line to the various mods 'content.xml' file. Anyone have good advise on this flag and the do's and don't of it?

Thanks in advance :)

SweetDaggerfall
Posts: 5
Joined: Sun, 17. Feb 19, 10:56
xr

Re: [HELP] Question re "save=false" in content.xml

Post by SweetDaggerfall » Wed, 20. Feb 19, 10:20

A quick update.

So it turns out only 3 of the mods in my current mod list did not have the 'save=false' flag (or 'save=0' as some put it as).

RS_Physics_ASSIST
No You Shut Up Yisha!
Realistic Highways

So i went and added the flag to those and started a new game. So far everything is working as expected, fingers crossed.

AR_Starfighter
Posts: 64
Joined: Thu, 6. Jun 19, 06:02

Re: [HELP] Question re "save=false" in content.xml

Post by AR_Starfighter » Thu, 20. Jun 19, 06:10

I'm very new at modding. I'v learned a few things about the save option. Some mods need them, some don't. Some use save when they don't need to.

For example, i'm planning a future mod to add a new ware - slaves. You get a mission rescue slaves from a trade ship (illegal). If you exit mid-mission, that info needs to be in the saved file for next time.

5k scan range changes one variable. Nothing needs to be saved. You to understand how the mod works to know if save info in 'context.xml' is needed.


I did that for one of my mods. It works fine. Can't recell which one.

An engineer mod from github. However....

Using save editor to remove this mod from a save. Then reloading the save. The message showing what component is being repaired got corrupted. Using the save editor doesn't always work. I had to go back about 5 days in saves to get a clean copy.

Post Reply

Return to “X Rebirth - Scripts and Modding”