[mod] X3 - RESURRECTION MOD (New graphic mod)

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Post Reply
x3-AmModer
Posts: 119
Joined: Fri, 16. Jun 17, 22:17

Post by x3-AmModer » Fri, 1. Jun 18, 03:34

I DID IT !!! :x3:


1 ) Reworked main menu scene - done
2 ) Support for all languages ​​in the main menu - done
3 ) Changes of the interface and GUI - done
4 ) Trying to change the star in Terran sectors and other suns- done
5 ) Changes of textures for Borons and Splits - done
6 ) Edit some textures for asteroids - done
7 ) Changes of hazes for planets - done
8 ) Edit all textures for stars - done
9 ) Edit all dust textures - done
10 ) Completely reworked all nebulae textures - done
11 ) Changing some frames in Main Menu - done
12 ) Changes of interface and GUI for Compatibility Packs - done
13) Finishing process -> Create some new loadscreens, testing, assembly - done


I can say :-) the mod will be ready for download today...

My new official webpage: www.x3-resurrection.wgz.cz


I hope there will be minimal bugs, because I reworked around 500 textures... :D

x3-AmModer
Posts: 119
Joined: Fri, 16. Jun 17, 22:17

Post by x3-AmModer » Fri, 1. Jun 18, 23:34

IMPORTANT MESSAGE



NEW VERSION 3.0. OF X3 - RESURRECTION WAS RELEASED



You can download it on my web:

_________________________________________________________




Image



_________________________________________________________

TomRobinson
Posts: 185
Joined: Thu, 7. Feb 08, 23:07

Post by TomRobinson » Sat, 2. Jun 18, 03:30

Will this work with Mayhem with the LU compatibility patch?
Do Hippos Eat Giraffes?

x3-AmModer
Posts: 119
Joined: Fri, 16. Jun 17, 22:17

Post by x3-AmModer » Sat, 2. Jun 18, 17:34

TomRobinson wrote:Will this work with Mayhem with the LU compatibility patch?
Yes, of course :-) ...

Mayhem do not change any textures.

TomRobinson
Posts: 185
Joined: Thu, 7. Feb 08, 23:07

Post by TomRobinson » Sat, 2. Jun 18, 22:09

x3-AmModer wrote:
TomRobinson wrote:Will this work with Mayhem with the LU compatibility patch?
Yes, of course :-) ...

Mayhem do not change any textures.
Thanks man, this looks excellent!
Do Hippos Eat Giraffes?

x3-AmModer
Posts: 119
Joined: Fri, 16. Jun 17, 22:17

Post by x3-AmModer » Thu, 21. Jun 18, 01:00

And the last cherry on the cake... :wink:

If you want, you can use this icon:



Image

...click on the picture... link

michtoen
Posts: 38
Joined: Mon, 22. May 06, 20:09

Post by michtoen » Wed, 11. Jul 18, 22:18

I used your mod as visual core for my LxXRM modding package.

https://forum.egosoft.com/viewtopic.php?t=399184

People have still to download it normal, i just added a bat unzipper and installer , to make it work smooth.

I added the Pure Hud too and the result is really wonderful, it comes with XRM and TCAP and all and it really works like a charm.

The selection and credits screen at start looks really cool, its really proofs the 3.5.

BlackArchon
Posts: 940
Joined: Wed, 4. Feb 04, 18:37

Post by BlackArchon » Sat, 14. Jul 18, 10:07

Is there a change log? I'm interested in the changes from 2.1 to 3.0. :)

x3-AmModer
Posts: 119
Joined: Fri, 16. Jun 17, 22:17

Post by x3-AmModer » Sat, 14. Jul 18, 14:30

BlackArchon wrote:Is there a change log? I'm interested in the changes from 2.1 to 3.0. :)
Yes, maybe the first post on this page (n.11) could be used like a change log.

Good day.... :-)

x3-AmModer
Posts: 119
Joined: Fri, 16. Jun 17, 22:17

Post by x3-AmModer » Sat, 14. Jul 18, 14:33

michtoen wrote:I used your mod as visual core for my LxXRM modding package.

https://forum.egosoft.com/viewtopic.php?t=399184

People have still to download it normal, i just added a bat unzipper and installer , to make it work smooth.

I added the Pure Hud too and the result is really wonderful, it comes with XRM and TCAP and all and it really works like a charm.

The selection and credits screen at start looks really cool, its really proofs the 3.5.

Yes, ok, :-) I have no problem with that.... G.J.

steve_v
Posts: 32
Joined: Sun, 12. Jun 16, 08:39

Post by steve_v » Sat, 14. Jul 18, 18:55

FWIW, this mod crashes my game at the start screen.
Guessing you might have compressed textures that are not compatible with the linux port.
If this is the case, it probably won't run on MacOS either.

Gentoo GNU/Linux amd64, Native linux X3AP 3.3, GOG Terran War Pack.

x3-AmModer
Posts: 119
Joined: Fri, 16. Jun 17, 22:17

Post by x3-AmModer » Sat, 14. Jul 18, 22:29

steve_v wrote:FWIW, this mod crashes my game at the start screen.
Guessing you might have compressed textures that are not compatible with the linux port.
If this is the case, it probably won't run on MacOS either.

Gentoo GNU/Linux amd64, Native linux X3AP 3.3, GOG Terran War Pack.
Sorry, I haven't Linux, I can't test it and repair it. But maybe we can do it together. Write on my e-mail and I will send you instructions.....

See you

michtoen
Posts: 38
Joined: Mon, 22. May 06, 20:09

Post by michtoen » Sat, 14. Jul 18, 22:48

I have no linux game ready here, just server consoles. Alot, in fact, but that will not help.

Aynway, i will update the LxXRM mod if you both can check it out.

x3-AmModer
Posts: 119
Joined: Fri, 16. Jun 17, 22:17

Post by x3-AmModer » Sun, 15. Jul 18, 22:20

michtoen wrote:I have no linux game ready here, just server consoles. Alot, in fact, but that will not help.

Aynway, i will update the LxXRM mod if you both can check it out.
This will be probably only Linux problem. He can't start the game with my mod. I have no idea what can make the problem.

From testing this mod: I flew through all sectors in original x3AP and found only one sector (probably bad written by Egosoft) with background problem. No patches are planed. All supported mods and original game seems to be fine...

But till now I have no answer on my e-mail... Still waiting...

dreamer2008
Posts: 203
Joined: Sat, 24. Dec 11, 12:14

Post by dreamer2008 » Mon, 16. Jul 18, 09:17

This mod looks awesome, downloading now, and thank you for making it!

A few questions: 1. if I have both Litube's and IEX installed with the IEX LU patch, how do I install the compatibility packs? Do I copy both of them and install after all the other files? 2. Also, can I install and play mid game, or do I have to start a new game? 3. And finally, Mayhem 2.5 will have a custom IE + IEX background, so will the patches for LU and IEX still work?
Image

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”