[SCRIPT] Salvage Command Suite V4.11 [29/12/2012]

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Post Reply
coreador
Posts: 16
Joined: Fri, 3. Apr 09, 20:47

Post by coreador » Wed, 21. Mar 18, 00:11

I've been using SCS v4.11 for a while now, and I really like it, but I'm running into a strange issue. I don't see any way to donate ships, even though this is covered in the manual. There is no command on my menu that says "Donate" or "Return". Is there some special condition that must be satisfied for this to show up?

coreador
Posts: 16
Joined: Fri, 3. Apr 09, 20:47

Post by coreador » Wed, 21. Mar 18, 20:56

Ok, after playing for a while I tried again and the donate option started showing up. I was able to donate successfully. But I still have no idea why the option didn't exist before. Do you have to be OOS? Because I think the only time it showed up for me was when donating an OOS ship.

User avatar
zwierzu
Posts: 129
Joined: Wed, 18. Jul 07, 17:26

Post by zwierzu » Sat, 7. Apr 18, 17:46

Excuse me but how do I activate Universal Salvager option?
Been searching through this topic but I think I'm blind - can't find any information.

AG139230
Posts: 2
Joined: Sat, 7. Apr 18, 21:24

Post by AG139230 » Sat, 7. Apr 18, 21:32

Hi,

This is a great mod, but I'm having trouble finding the MPW. I read the readme, and seached the areas it patrols, read somewhere that it looks like a Xenon J, and finally used the cheat menu. It says -MPW is in sector: Null.

So I uninstalled, reinstalled (didn't finish uninstalling just went back to game as per instructions and have tried rebooting SCS and MPW Script. Still nothing.

Hoping for some help, as just started the X3 universe and the game and this mod tick's all the boxes.

:)
Edit: Should mention I'm running the Star Wars Mod, and can't for the life of me find the South gate in Loomanckstrat's Legacy.

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Mon, 21. May 18, 18:50

Hi,

Apologies for the delay, stopped gettign messages from the forum again...

@AG139230,

Try the "Reboot MPW script" in the Cheat/Troubleshooting menu, that should respawn the MPW.

Once it's rebooted the script, check the MPW information command in the same menu to see what sector it's in.

If it's still sector: Null, the MPW isn't jumping in to the X-Universe for some reason, possibly a mod has moved some sectors.

Let me know how you get on and I'll see if I can help if you still have issues.

@zwierzu,

Not sure if the Universal Salvager option is in your version, you should be able to request salvagers from the MPW, including the Area Salvage if that's in the last version I released.

@coreador,

You should be able to select 'Return this ship to...' and then specify a race from the command menu of the ship you wish to return. It might be reliant on you having the SCS software installed on the ship you are in (can't remember off the top of my head).

@everyone else...

Will have a bit of time on my hands for the next few weeks, will try to work on LU compatability...

michtoen
Posts: 38
Joined: Mon, 22. May 06, 20:09

Post by michtoen » Sun, 8. Jul 18, 16:32

I have here 2 fixes:

Firt one will make SCS compatible with the Missile Safety (v1.12) from Gazz.
https://forum.egosoft.com/viewtopic.php?t=238860

Its an easy fix. you can now install both scripts in any order, as long you install my fix at last. Its an easy 3 liner including the stealth saltellites to gazz script.
Note, that when you installed in the past SCS over gazz script, you had overwritten an important part of it.

Here is the download.
http://ks4003297.ip-142-4-209.net/unres ... _patch.zip

Second, i changed some key parts of SCS to make it less cheaty (in my opinion and ensure it fits better with other scripts).

- i removed the free floating Salvage Command Software from start
- i removed the free bonus ships (the script overs in the settings some similiar anyway)
- i removed the repair ship calls from the hotkeys, that was a source of misclicks (ship can be called normal in the commands)

- i included a fix for the spacefly problem (i think it should work).
Read about it here: https://forum.egosoft.com/viewtopic.php?t=398200
Anyway, a more experienced scripter should give it a look.

- finally, i included the System Override Software as required when using "claim ship..." or "claim all".

The last change will make the software in line with the salavage commands script again and reverts the fact that this script make the System Override Sofrware and the Signature Scrambler complete useless.

So, all will work as usual now, but for claiming big ships and use the claim parts you have to buy the system override software again and the scrambler, if you want be on the safe side again.

Here is the download:
http://ks4003297.ip-142-4-209.net/unres ... _patch.zip

TechSY730
Posts: 103
Joined: Tue, 26. Jul 16, 02:51

Post by TechSY730 » Wed, 1. Aug 18, 19:24

michtoen wrote: - i removed the free bonus ships (the script overs in the settings some similiar anyway)
Does this mean that the script no longer spawns claimable ships periodically? If so, what does the "Spawn attempt timer" option do in the settings now (or perhaps, what did it ever do)?

user1679
Posts: 16
Joined: Fri, 20. Jul 18, 23:20

Post by user1679 » Tue, 21. Aug 18, 06:04

Is it possible to add an option: "Collect all LEGAL wares in sector"

so the computer can avoid illegal things like space flies, space fuel, etc?

I have to eject them and shoot them or the script will just pick them up
again. When salvaging in certain Argon sectors, I get scanned by the
police a lot.

michtoen
Posts: 38
Joined: Mon, 22. May 06, 20:09

Post by michtoen » Wed, 22. Aug 18, 12:54

TechSY730 wrote:
michtoen wrote: - i removed the free bonus ships (the script overs in the settings some similiar anyway)
Does this mean that the script no longer spawns claimable ships periodically? If so, what does the "Spawn attempt timer" option do in the settings now (or perhaps, what did it ever do)?
No, in fact both things are 2 different parts.

When installed the script spawns some claimable ships as "start bonus", thats the part i deactivated.

The option to enable and spawn ships is a different part and not touched, use it as you wish.

I assume that parts, including the floating software at start, are parts added to make this mod more interesting as it was developed but it comes with a massive cheating feeling, so i disabled all that start bonus stuff.

The script itself is so good, it really not needs it anyway.

user1679
Posts: 16
Joined: Fri, 20. Jul 18, 23:20

Post by user1679 » Sun, 2. Sep 18, 07:39

Slight bug with SCS 4.11:

When I rename my Caiman Hauler, set autopilot to "notify when complete" and then use SCS to "Collect wares in sector", I get an empty message from "unknown" when it is finished.

When I first salvaged the ship the message worked fine. It just seems to have a problem when the ship is renamed.

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Sun, 2. Sep 18, 10:16

Hi user1679,

If you rename a ship with a coloured name, some messages (for that ship) may subsequently appear blank.

Depending on how you look at it, it's either X3 not being able to display coloured ship names properly, or that I forgot to strip the colour codes from the messages before it's displayed (depends who's routines are displaying the message).

If you have colourised the ship's name, change it back to the default colour and see if that resolves the issue.

dispostableatheist
Posts: 190
Joined: Sun, 23. Jan 11, 14:28

Post by dispostableatheist » Thu, 6. Sep 18, 16:57

Is there a LU (not mayhem) compatible version somewhere?

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Thu, 6. Sep 18, 17:09

Hi dispostableatheist,

Not yet, unfortunately LU changes so many things in the game it breaks a lot of the SCS scripts.

SCS can be used in LU, but there may be some weird (although not too serious) things happen!

If anyone running LU wants to post any problems they see, I will see if I can get around to sorting some of them out.

user1679
Posts: 16
Joined: Fri, 20. Jul 18, 23:20

Post by user1679 » Fri, 7. Sep 18, 22:24

TECSG wrote:Hi user1679,

If you rename a ship with a coloured name, some messages (for that ship) may subsequently appear blank.

Depending on how you look at it, it's either X3 not being able to display coloured ship names properly, or that I forgot to strip the colour codes from the messages before it's displayed (depends who's routines are displaying the message).

If you have colourised the ship's name, change it back to the default colour and see if that resolves the issue.
I didn't colorize the names beyond what the script does as default (colorize names in reports). When I claimed the ship it turned green, just like all my other ships in the 'my property' screen.

User avatar
TECSG
Posts: 1567
Joined: Tue, 17. Feb 04, 23:06

Post by TECSG » Sat, 8. Sep 18, 15:12

Okay, there is an option in SCS to 'colourize names' so you can better see different classes or tasked ships, but if you haven't used that option, that's not the problem!

Let me know if you find out what was reporting the blank message, I should then be able to troubleshoot the problem.

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”