EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
Mouse stops responding
Post new topic Reply to topic
View previous topic :: View next topic
Author Message
bassettcorp





Joined: 11 Apr 2010
Posts: 4 on topic

Thank you for registering your game
PostPosted: Wed, 3. Jan 18, 19:28    Post subject: Mouse stops responding Reply with quote Print

I've recently started playing this game after getting it in the sale. my issue is that the mouse that I'm using to steer my ship stops responding at certain times until I use my arrow keys. then it works fine for a while. is there a way to get more response from my mouse? it usually happens when I get around other ships/stations and close to gates.

Back to top
View user's profile Send private message
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17203 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Wed, 3. Jan 18, 19:31    Post subject: Reply with quote Print

Which X game? This information helps us to help you.


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
bassettcorp





Joined: 11 Apr 2010
Posts: 4 on topic

Thank you for registering your game
PostPosted: Thu, 4. Jan 18, 02:04    Post subject: right sorry Reply with quote Print

Operating Sysyem: Windows 10
CPU: Intel Core i7- 3770
Graphics card: NVIDIA Quadro 600
Memory: 12.0GB
Game Version: x2: the threat
Nature of the problem: it loses the mouse controls when I get close to a station or gate making it impossible to turn the ship until I hit an arrow key on the keyboard.
Sector: every sector I've been in so far (throughout Argon)
Non plot problem
and no scripts or mods installed.

Back to top
View user's profile Send private message
kohlrak





Joined: 28 Dec 2017



PostPosted: Thu, 4. Jan 18, 03:12    Post subject: Reply with quote Print

Have you tried reoving the joystick deadzone? I'm willing to bet you're trying to only use fine movements when you're that close, and the issue becomes that if you move it too much the ship flies wildly out of control?

Back to top
View user's profile Send private message
bassettcorp





Joined: 11 Apr 2010
Posts: 4 on topic

Thank you for registering your game
PostPosted: Thu, 4. Jan 18, 03:21    Post subject: Reply with quote Print

I'm using a mouse so will the joystick dead zone effect that? and it doesn't matter how much I move the mouse the ship won't move at all I've litterally tried flailing it around wildly to get a response with no luck

Back to top
View user's profile Send private message
kohlrak





Joined: 28 Dec 2017



PostPosted: Thu, 4. Jan 18, 05:44    Post subject: Reply with quote Print

A weird design issue with the game. I'm having trouble finding the thread now, but if you open up the registry editor (regedit, which is preinstalled on windows) and do a search for "X2" you'll find an entry marked "InputJoyDeadzone" which you can set to 0. I think the launcher will reset this value if you change the controls in any way, so you 'll want to set your controls how you want them first, then set that value to 0. I'm not 100% sure if the joystick sensitivity works for the mouse or not, but you could try setting it to 0, which would for sure confirm if it does (since the mouse would stop moving the ship in X2). Obviously you'll need to close and restart X2 to see the changes.

Back to top
View user's profile Send private message
bassettcorp





Joined: 11 Apr 2010
Posts: 4 on topic

Thank you for registering your game
PostPosted: Thu, 4. Jan 18, 13:09    Post subject: Reply with quote Print

I tried the DeadZone target thing and had no luck I'm afraid however I have noticed it seems to be after I use the SETA on the ship

Back to top
View user's profile Send private message
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17203 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Thu, 4. Jan 18, 17:38    Post subject: Reply with quote Print

Try a different mouse driver, such as a default one from Microsoft if using a bespoke one from the manufacturer for your mouse - or vice-versa. Alternatively swap from a PS/2 mouse connection to a USB one - or vice versa. If these help then that will point to the current mouse driver as the cause of the issue.


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
Nanook
Moderator (English)
Moderator (English)



Joined: 15 May 2003
Posts: 25867 on topic
Location: In the X-Universe spanning two millenia
Thank you for registering your game
PostPosted: Thu, 4. Jan 18, 23:55    Post subject: Reply with quote Print

It would also be helpful to post your DXDIAG as mentioned in the thread Alan mentioned. Here's the FAQ article on how to do that.


_________________
Having an Acronym Attack? See the Ego FAQ. Also now for Terran Conflict and Albion Prelude.
NOT an Egosoft employee.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Tue, 23. Jan 18, 01:48

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2018
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 3.75511 seconds, sql queries = 23