EnglishGermanFrenchRussianPolishItalianSpanish
Log inRegister
 
X³: TC and AP - Linux support thread
Post new topic Reply to topic Goto page Previous  1, 2, 3 ... 40, 41, 42, 43  Next
View previous topic :: View next topic
Author Message
asfethan





Joined: 31 Jul 2014



PostPosted: Mon, 12. Sep 16, 18:58    Post subject: Reply with quote Print

Hi there, thanks for patch 3.1a introduction to linux platform but sadly I have to repot that issue with HUD fps drops on certain AMD systems persists on my HW combination.

Details about my system:
Code:

 - OS / debian (stretch/sid)
 - mesa / 11.2.2
 - libdrm / 2.4.70
 - GPU / 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RV730/M96-XT [Mobility Radeon HD 4670]
 - game / v3.1a build 16 (Steam version)
 - kernel / Linux gondar 4.6.0-1-amd64 #1 SMP Debian 4.6.4-1 (2016-07-18) x86_64 GNU/Linux


When I hide HUD (shift+h) the game is running smoothly but when I have HUD enabled the game is unplayable - everything is very laggy.

UPDATE 04. Oct. 2016

I have the same issue on another laptop. Again, with hidden HUD the game runs smoothly.
Code:

 - OS / debian (stretch/sid)
 - mesa / 12.0.3
 - libdrm / 2.4.70
 - GPU / 01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6730M/6770M/7690M XT]
 - game / v3.1a build 16 (Steam version)
 - kernel / Linux abaddon 4.8.0-rc8-amd64 #1 SMP Debian 4.8~rc8-1~exp1 (2016-09-26) x86_64 GNU/Linux


Back to top
View user's profile Send private message
Yggdrasill





Joined: 15 Jun 2013
Posts: 26 on topic

Thank you for registering your game
PostPosted: Sat, 19. Nov 16, 04:56    Post subject: Reply with quote Print

Quote:
• Fixed issue with menu performance on systems with particular AMD graphics hardware and driver combinations.


Now that the AMD menu issue has been fixed on Windows systems in the 3.2d update, is it possible that this can be ported? It depends somewhat on whether or not the root cause is the same I guess, but I am hopeful.

Back to top
View user's profile Send private message
Reformed_Pirate





Joined: 17 Jul 2015
Posts: 1 on topic

Thank you for registering your game
PostPosted: Mon, 21. Nov 16, 21:05    Post subject: Reply with quote Print

*** Vanilla X3AP crashes when loading save games. ***

Hi, I’m new at the forums, but have been playing the X-series since BTF.

From time to time, X3AP crashes on Debian by loading a save game. Normally I just choose an older file, but now all the save games have the issue.

Output:
Code:

SB_LoadLocation() loading story file x3story
SB_LoadGame() NextStringID: 923705089 NextArrayID: 699299889 NextTableID: 916448941 NextInstID: 1550341 NextTaskID: 148950539
======================================
SV_Load: Could not find array ID 943849472
======================================
======================================
P_Load() SE_LoadGame failed


Im playing the vanilla version + Bonus Pack on Steam. Any idea how to solve the problem?

Back to top
View user's profile Send private message
Premislaus





Joined: 25 May 2009
Posts: 2 on topic
Location: Poland
Thank you for registering your game
PostPosted: Sat, 24. Dec 16, 17:12    Post subject: Reply with quote Print

http://imgur.com/gallery/ULrir

http://i.imgur.com/vqpRhEX.png

Without HUD. Shader clock is working properly.

CPU: A6 4400m (two cores)
GPU1: Radeon HD 7520g, 512 MB DDR3
GPU2: Radeon HD 7670m, 1 GB DDR3
RAM: 6 GB DDR3
HDD: 512 GB, 5400 RPM.
Resolution: 1366x768

Software: openSUSE Tumbelweed, x86_64 Linux 4.8.14-1-default, X.Org 1.18.4 (DRI2, EXA), Mesa 13.0.2, xf86-video-ati 7.8.0-1.1, KDE 5.29.0.

http://i.imgur.com/wmrh0os.png[]

With HUD. Shader clock is not working properly.


{Images posted directly to the forums should not be greater than 640x480 or 100kb, oversize image now linked - Terre}

Back to top
View user's profile Send private message Send e-mail Visit poster's website
Akdor 1154





Joined: 19 Aug 2006
Posts: 63 on topic
Location: Victoria, Australia
Thank you for registering your game
PostPosted: Sun, 19. Mar 17, 05:05    Post subject: Reply with quote Print

Any word on the HUD performance bug? Is this likely to be addressed with the beta patch makes it to Linux?


_________________
Disregard this sentence.
Back to top
View user's profile Send private message
timon37
EGOSOFT
EGOSOFT

MEDAL

Joined: 14 Dec 2012
Posts: 329 on topic

Thank you for registering your game
PostPosted: Mon, 20. Mar 17, 11:24    Post subject: Reply with quote Print

Akdor 1154 wrote:
Any word on the HUD performance bug? Is this likely to be addressed with the beta patch makes it to Linux?


Yes, unfortunately no word on when it'll be out:(

Back to top
View user's profile Send private message
Yggdrasill





Joined: 15 Jun 2013
Posts: 26 on topic

Thank you for registering your game
PostPosted: Tue, 21. Mar 17, 12:51    Post subject: Reply with quote Print

timon37 wrote:
Yes, unfortunately no word on when it'll be out:(


Does that mean it's been fixed in internal builds?

Back to top
View user's profile Send private message
Moderato_bei_X



MEDAL

Joined: 28 Oct 2003
Posts: 20 on topic
Location: Karlsruhe, Baden-Württemberg, Germany
Thank you for registering your game
PostPosted: Wed, 22. Mar 17, 14:41    Post subject: Reply with quote Print

Having the same problem as Reformed_Pirate.

I lost countless of hours because of save files that make X3TC crash. It doesn't even make a whole lot of sense - I have 2 save files only seconds apart with one working and the other crashing the binary.

There seems to be no connection to whether the game has been manually saved or automatically. I've seen non-working automatic save files, even though a manually created save file seconds after docking worked fine and vice versa.

I have since started to save twice (in addition to autosave), hoping that one of the three save files might work if I needed to backtrack. This idea hasn't been working great so far, though, as both manual save files tend to crash if there are problems.

Just to make sure - shall I provide a working (autosaved) file and a crashing manual save file, only seconds apart to debug this?

I figure work on X3 might have stopped, given its age, redundancy and especially since this is affecting me on Linux, which has likely never been a prime time member due to the low user base.


_________________
Course.setCourse[_%e00FF00FF00FF00FFset%ei]
.byOS[4D6963726F66742057696E646F777320544520286329032313135]
00FFl_ified00FF00FF00FF{fail%re}
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Moderato_bei_X



MEDAL

Joined: 28 Oct 2003
Posts: 20 on topic
Location: Karlsruhe, Baden-Württemberg, Germany
Thank you for registering your game
PostPosted: Thu, 23. Mar 17, 15:37    Post subject: Reply with quote Print

Some more information on this: since the Windows client crashes as well when loading the broken save files, it's likely not a parsing issue. Rather, the Linux client seems to be creating corrupted save files to begin with.

So far, I haven't experienced this on Windows.


_________________
Course.setCourse[_%e00FF00FF00FF00FFset%ei]
.byOS[4D6963726F66742057696E646F777320544520286329032313135]
00FFl_ified00FF00FF00FF{fail%re}
Back to top
View user's profile Send private message Send e-mail Visit poster's website
CBJ
EGOSOFT
EGOSOFT



Joined: 29 Apr 2003
Posts: 35525 on topic

Thank you for registering your game
PostPosted: Thu, 23. Mar 17, 15:44    Post subject: Reply with quote Print

Can you upload a broken savegame somewhere so that someone can take a look at it?

Back to top
View user's profile Send private message
Moderato_bei_X



MEDAL

Joined: 28 Oct 2003
Posts: 20 on topic
Location: Karlsruhe, Baden-Württemberg, Germany
Thank you for registering your game
PostPosted: Fri, 24. Mar 17, 09:14    Post subject: Reply with quote Print

Of course.

Autosave file that works: https://ionic.de/X3TC/save-bug/X12-autosave-good.sav

Manual save file that makes both Linux and Windows client crash: https://ionic.de/X3TC/save-bug/X02-manual-bad.sav

I provide both files because they were created only seconds apart. Maybe the diff will also be useful - although I do not know the save files' internal format.


There's one thing that I did find out, though. It looks like save files are gzip-compressed, which might be what triggers this bug. My system is using zlib 1.2.11, while X3TC ships an older release (I haven't been able to find out what exact version, though.)

This shouldn't matter IF the libraries in lib/ take precedence correctly, but starting X3TC_main via testandlaunch, which is supposed to set the LD_LIBRARY_PATH env var doesn't change the occurrence of that bug.


Which is to say... check this:

Code:
# gunzip -c < X12-autosave-good.sav > X12-autosave-good.sav.uncompressed
#


but:

Code:
# gunzip -c < X02-manual-bad.sav > X02-manual-bad.sav.uncompressed

gzip: stdin: invalid compressed data--crc error

gzip: stdin: invalid compressed data--length error
#


Again - this was with my system gzip binary - I cannot test with X3TC's zlib, because you do not ship a corresponding gzip binary. Also, I have an x86_64 system with both x86_64 and x86 libraries (multilib), but no x86 gzip binary, so I cannot just preload your shipped zlib.


So, besides the X3TC's Linux client producing corrupt save files, your client doesn't seem to check whether the gzip data is actually valid. Please do that in future releases.


That's as much as I could debug. I cannot provide more information on *why* the Linux client is producing broken files.


_________________
Course.setCourse[_%e00FF00FF00FF00FFset%ei]
.byOS[4D6963726F66742057696E646F777320544520286329032313135]
00FFl_ified00FF00FF00FF{fail%re}
Back to top
View user's profile Send private message Send e-mail Visit poster's website
dv.underworld





Joined: 02 Oct 2011
Posts: 8 on topic
Location: Slovakia
Thank you for registering your game
PostPosted: Thu, 30. Mar 17, 17:53    Post subject: Reply with quote Print

Hi,

Having the same problem with X3AP as already reported by Reformed_Pirate and Moderato_bei_X:

Reformed_Pirate wrote:
*** Vanilla X3AP crashes when loading save games. ***

Hi, I’m new at the forums, but have been playing the X-series since BTF.

From time to time, X3AP crashes on Debian by loading a save game. Normally I just choose an older file, but now all the save games have the issue.

...

Im playing the vanilla version + Bonus Pack on Steam. Any idea how to solve the problem?


Moderato_bei_X wrote:
Having the same problem as Reformed_Pirate.

I lost countless of hours because of save files that make X3TC crash. It doesn't even make a whole lot of sense - I have 2 save files only seconds apart with one working and the other crashing the binary.

There seems to be no connection to whether the game has been manually saved or automatically. I've seen non-working automatic save files, even though a manually created save file seconds after docking worked fine and vice versa.

I have since started to save twice (in addition to autosave), hoping that one of the three save files might work if I needed to backtrack. This idea hasn't been working great so far, though, as both manual save files tend to crash if there are problems.

Just to make sure - shall I provide a working (autosaved) file and a crashing manual save file, only seconds apart to debug this?

I figure work on X3 might have stopped, given its age, redundancy and especially since this is affecting me on Linux, which has likely never been a prime time member due to the low user base.


Arch Linux, 4.9.18-1-lts x86_64 GNU/Linux.
Some saves work, some crash with "Segmentation fault (core dumped)".


_________________
Logic clearly dictates that the needs of the many outweigh the needs of the few.
Back to top
View user's profile Send private message
timon37
EGOSOFT
EGOSOFT

MEDAL

Joined: 14 Dec 2012
Posts: 329 on topic

Thank you for registering your game
PostPosted: Fri, 31. Mar 17, 14:47    Post subject: Reply with quote Print

Hi,
There's some great news and some not so good news.

The great news is that we recently finished setting up an automated linux/mac build system for X3 R/TC/AP.
So from now on betas/patches will be hopefully released for all platforms synchronously (though we're reserving the right to blame a "random something out of our control" if that doesn't happen).

The next linux/mac public beta will just:
- synchronize with the windows code and data changes
- update some libraries like SDL2, etc
- fix a small stack corruption that caused a crash on macos with -skipintro (the issue is there on linux as well, though it doesn't result in a crash)

So there's a very high chance that it'll fix the AMD performance issue, I just haven't been able to verify that it does.
I'm skeptical that it'll fix the savegame corruption issue, though it's not impossible.
Hopefully there are no new regressions or compatibility issues with it, then I'll be able to seriously look into fixing the remaining issues.

Back to top
View user's profile Send private message
andreihaiducul





Joined: 10 Jul 2013
Posts: 39 on topic

Thank you for registering your game
PostPosted: Thu, 20. Apr 17, 14:57    Post subject: Reply with quote Print

I got no improvement in UI performance with v3.2. It might even be worse now, or I'm just not used to it anymore as I haven't played in months. I'm playing with mesa on RV770.


_________________
openEMSui: an open source implementation of the UI component in LU's EMS.
Back to top
View user's profile Send private message
Akdor 1154





Joined: 19 Aug 2006
Posts: 63 on topic
Location: Victoria, Australia
Thank you for registering your game
PostPosted: Thu, 20. Apr 17, 15:09    Post subject: Reply with quote Print

Yup, still performance issues here (and on a clean install of Ubuntu 16.10), mesa as well.


_________________
Disregard this sentence.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic Goto page Previous  1, 2, 3 ... 40, 41, 42, 43  Next
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Sun, 25. Jun 17, 22:49

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2017
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.51681 seconds, sql queries = 29