X-Tended -Terran Conflict V2.2 Released. [06/09/2013] (X3:AP prototype available)

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Post Reply
User avatar
Killjaeden
Posts: 5148
Joined: Sun, 3. Sep 06, 18:19
x3tc

Post by Killjaeden » Tue, 30. Aug 16, 20:30

That's great to hear :) have fun.
Image
XTC Mod Team Veteran. My current work:
Image

adb0899
Posts: 78
Joined: Tue, 4. Sep 12, 23:17
x3ap

Post by adb0899 » Wed, 12. Oct 16, 19:09

would anyone by chance have a recommended mod list in that they use with this mod?

zazie
Posts: 3481
Joined: Mon, 7. Mar 05, 15:55
x4

Post by zazie » Thu, 13. Oct 16, 13:55

most honest answer: forget it ...
The XTC-mod has its own settings of files/data. This may conflict with other settings, of the vanilla game or other mods. Even the BonusPack does not work flawlessly together with the XTC-mod.
The list of mods working with XTC is rather short.
But: why mix this awesome and inspiring mod with other ones ?

xptical
Posts: 2
Joined: Sat, 5. Dec 09, 21:20
x3ap

Post by xptical » Sat, 12. Nov 16, 21:39

About to restart X3TC (steam version 3.2d). Is this mod compatible?

zazie
Posts: 3481
Joined: Mon, 7. Mar 05, 15:55
x4

Post by zazie » Mon, 14. Nov 16, 16:32

Not at all. XTC is kind of new game, based on the X-engine and using some elements of the x-saga.

That means: technically you cannot use X3TC-savegames with XTC. Not the only but the simplest reason: the map is different, 100% (!).

For your game-play: of course, building up an empire needs about the same strategies as X3TC: freighters, fighters, stations and complexes.

But XTC offers A LOT of additional possibilities (and challenges):
- Player can own Shipyards
- Universe expands (up to 198 sectors iirc)
- Xenon and Kha'ak-Invasions
- ALL ships might bail
- foes (below a certain level) will chase your ships until destruction (of that specific ship of yours OR of the foe's ships)
- player can reengineer and reproduce Kha'ak- and Xenon-weaponry on specialized TL-ships

IMO XTC represents the ULTIMATE X3TC, for free. Fantastic work of the Devs; highly underrated in comparison to other games/mods.

I strongly recommend to install XTC on a COPY of your X3TC-installation.

User avatar
The Q
Pancake Award Winner 2017
Posts: 351
Joined: Fri, 20. Nov 09, 22:02

Post by The Q » Mon, 14. Nov 16, 17:39

xptical wrote:About to restart X3TC (steam version 3.2d). Is this mod compatible?
zazie wrote:Not at all.
zazie wrote:I strongly recommend to install XTC on a COPY of your X3TC-installation.
These two answers seem to contradict each other. If the XTC is not compatible with X3TC version 3.2d, then how can you suggest to install it over a X3TC copy? Therefore I think you mean it is compatible, but you have to start a new game, which xptical intended to do anyhow according to their initial post.
Morkonan, Emperor of the Unaffiliated Territories of the Principality of OFF-TOPIC, wrote:I have come to answer your questions! The answers are "Yes" and "Probably" as well as "No" and "Maybe", but I'm not sure in which order they should be given.
xkcd: Duty calls

zazie
Posts: 3481
Joined: Mon, 7. Mar 05, 15:55
x4

Post by zazie » Tue, 15. Nov 16, 11:46

I think the difference is semantic.

XTC must be installed over X3TC 3.2. XTC is a mod, not a stand-alone game.

But as XTC does replace a lot of the original X3TC-scripts with its owns, I recommend to install this mod on a separate "Vanilla" installation of X3TC.

Yes, you have to start a new game. Obviously, as the game starts are completely different and as any X3TC-savegame would instantly crash in XTC.

That is the sense of 'compatible' I used. And I am pretty sure that is the sense xptical meant when he/she wrote: about to restart X3TC.

More information for installing XTC in Steam: Link . Actually, I get an error message for that link.
But the entry page works

User avatar
The Q
Pancake Award Winner 2017
Posts: 351
Joined: Fri, 20. Nov 09, 22:02

Post by The Q » Tue, 15. Nov 16, 12:29

I think you did not understand what my post was about. Your reply to the question, whether the XTC is compatible to X3TC 3.2, was "not at all", which would mean under no circumstances you should install it over X3TC 3.2. (It does not really matter whether it's a copy of the game or not, when it's incompatible after all.) When in reality you meant, which you proceeded to tell, that it is infact compatible. And yes, I would argue that this is quite a big difference.

Image

Steam Installation Instructions:

Anyway, the Steam installation info is actually quite simple:
  1. Locate your Steam X3: Terran Conflict folder. This FAQ article describes where it usually is located.
  2. Copy the whole X3: Terran Conflict folder to a different directory. For example C:\games\.
  3. Download the 3.x -> 3.3 patch and install it to the just copied X3: Terran Conflict folder. For example C:\games\X3 Terran Conflict.
  4. Now download the XTC files and install them to the copied folder.
  5. Start a new game.
(The idea of the steps 1 to 3 is to create a secondary installation, which is completely independent from Steam. If you wouldn't do this, and Steam is run in online mode, it would try to repair the vanilla files which were replaced by the mod files. Thus break the mod installation. If you want to run further mod installations in parallel, you can create a third, fourth etc. installation the same way. Just keep in mind that all savegames and control profiles are saved in the same location for all games.)


Edit: Changed formatting slightly, so that the installation instructions are easier to identify and linked them in the opening post. X2-Illuminatus

Edit2: Changed Patch link to new 3.3 update. X2-Illuminatus
Morkonan, Emperor of the Unaffiliated Territories of the Principality of OFF-TOPIC, wrote:I have come to answer your questions! The answers are "Yes" and "Probably" as well as "No" and "Maybe", but I'm not sure in which order they should be given.
xkcd: Duty calls

zazie
Posts: 3481
Joined: Mon, 7. Mar 05, 15:55
x4

Post by zazie » Tue, 15. Nov 16, 14:13

My use of "compatability" is corresponding to the XTC-Team. As I said: semantic difference. You interpretation of "not at all" is your personal definition.
Extended - Terran Conflict FAQs wrote:Q10. Which mods/scripts are compatible?
A. Officially none - in particular the official Egosoft Bonus Pack in incompatible.
There is a thread discussing compatibility on the Egosoft Forums here, and a similar one by Joelnh in the Scripts and Mods Subforum here.
There are a few scattered discussions on the forums here - for example Lucike's Scripts and Mars (currently two competing threads in the user created scripts subforum here and here).
Q11. Is it savegame-compatible with Terran Conflict?
A. No
Q14. Can I play conventional Terran Conflict in the same installation?
A. No. You would need a completely separate installation. Beware that the savegames from the two different games finish up in the same place, and are liable to overwrite each other.
Source
But thanks for explaining the Steam installation of XTC to xptical.

User avatar
froger
Posts: 324
Joined: Fri, 26. Feb 10, 04:54
x4

Post by froger » Thu, 22. Dec 16, 10:32

Here is a link to megaupload just highlight it and past it

https://mega.nz/#F%21FFV2RDCL%216iKrPrNvCrEZqPFzMN0Wdg

Edit: Fixed the link and added it to the opening post. X2-Illuminatus
Image

Zircon13659
Posts: 29
Joined: Sun, 20. Jul 08, 00:07
x4

Post by Zircon13659 » Tue, 10. Jan 17, 19:34

froger wrote:Here is a link to megaupload just highlight it and past it

https://mega.nz/#F%21FFV2RDCL%216iKrPrNvCrEZqPFzMN0Wdg

Edit: Fixed the link and added it to the opening post. X2-Illuminatus
Hi,

Its not working with X3TC 3.3 :( how can i downgrade when i only have a steam version? Can sb write a small install-guide?
want to play xtended again - its one of the best games i ever have played :)

User avatar
X2-Illuminatus
Moderator (Deutsch)
Moderator (Deutsch)
Posts: 21460
Joined: Sun, 2. Apr 06, 16:38
x4

Post by X2-Illuminatus » Tue, 10. Jan 17, 19:47

X3TC 3.3 is only available as a beta version at the moment. To get back to version X3TC 3.2d, simply opt out of the beta by right clicking on the X3 Terran Conflict entry in your Steam library, opening the Properties -> Betas tab and selecting the "NONE - Opt out of all beta programs" options from the dropdown menu.

It's generally advised to move the Steam version to a different directory to prevent updates / betas from overwriting any mod files or causing other kinds of compatibility problems. A few posts above, The Q described the necessary steps. This also allows you to run two (or more) separate installations, for example one for playing the XTC and one for testing the game with the latest beta version. Additionally it's a good idea to opt-out of the beta branch, once testing is over. That way you're not surprised by any future beta versions, without having read the respective release notes / changelogs.
Die komplette X-Roman-Reihe jetzt als Kindle E-Books! (Farnhams Legende, Nopileos, X3: Yoshiko, X3: Hüter der Tore, X3: Wächter der Erde)

Neuauflage der fünf X-Romane als Taschenbuch

The official X-novels Farnham's Legend and Nopileos as Kindle e-books! (NOW also available: X3: Yoshiko!)

Zircon13659
Posts: 29
Joined: Sun, 20. Jul 08, 00:07
x4

Post by Zircon13659 » Tue, 10. Jan 17, 20:12

X2-Illuminatus wrote:X3TC 3.3 is only available as a beta version at the moment. To get back to version X3TC 3.2d, simply opt out of the beta by right clicking on the X3 Terran Conflict entry in your Steam library, opening the Properties -> Betas tab and selecting the "NONE - Opt out of all beta programs" options from the dropdown menu.

It's generally advised to move the Steam version to a different directory to prevent updates / betas from overwriting any mod files or causing other kinds of compatibility problems. A few posts above, The Q described the necessary steps. This also allows you to run two (or more) separate installations, for example one for playing the XTC and one for testing the game with the latest beta version. Additionally it's a good idea to opt-out of the beta branch, once testing is over. That way you're not surprised by any future beta versions, without having read the respective release notes / changelogs.
thanks a lot for the fast response :) i will redownload/install and test it again. Do u know some good mods for xtended? is the x3ap-tended version still working or do u recommand the x3tc version?
last time i played xtended i played the ap version of it with the bonuspack(with xtended fix) and some other mods but i have problems to find links which are not offline.

edit: its working :)
edit2: is there a way to get Lucikes scripts working for 2.2?
edit3: found this statement at page 373 about the scripts of lucikes:

"It sounds like your installation is screwed, to be honest. Also, the bonus pack is incompatible with XTC and will probably wreck things due to conflicts. Updated versions of Lucike's scripts, i.e. everything except the turbo booster, are supposedly compatible, but you have to go to his X3 script site to get the latest versions as those available here are outdated."

so i can use his scripts for 2.2? can sb confirm plz? :)

Zircon13659
Posts: 29
Joined: Sun, 20. Jul 08, 00:07
x4

Post by Zircon13659 » Thu, 12. Jan 17, 14:34

searching since 2 days for a working CAG Version for XTC 2.2a...
there is no :/

sb know a good trader script for xtc 2.2a? OK-Trader?

Any other good mods which are working for 2.2a?

zazie
Posts: 3481
Joined: Mon, 7. Mar 05, 15:55
x4

Post by zazie » Thu, 12. Jan 17, 17:09

mods with XTC 2.2a => http://forum.egosoft.com/viewtopic.php? ... 81#4632781

Lucikes Scripts in XTC is kind of Holy Grail as the XTC-team and Lucike use a completely different approach for handling the scripts, t-files and so on, but the same .

DO NOT install the BonusPack but search for Lucikes files published after the release of BP and XTC 2.2a. You find them on www.xuniversum.info

The original files work with XTC 2.2, but your installation will probably get red as Lucikes files use same command slots as XTC.

In my game I have found a way that the installation is green and the scripts work. But the text-info for CLS and CAG are corrupt, plus other small problems.
If you concentrate on CAG, EST, CLS I and II as far as I know XTC 2.2a still works fine - despite the red incompatibility warning on the loading screen.

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”