EnglishGermanFrenchRussianItalianSpanish
Log inRegister
 
[X:Btf] Graphics black and white + crashing. (Windows 8.1)
Post new topic Reply to topic Goto page Previous  1, 2
View previous topic :: View next topic
Author Message
AdamFM





Joined: 21 Jul 2016



PostPosted: Tue, 26. Jul 16, 15:27    Post subject: Reply with quote Print

Yep, it did say that. But does that necessarily mean the files needed to play X:BtF are present or uncorrupted?

I did update my graphics card drivers the other day; needless to say it didn't help.

I've reinstalled X:BtF once more and I've found that Steam does not, in fact, do a 'first time setup' when you run the game. So I don't think DirectX is installed by X:BtF? Perhaps I should reinstall DirectX completely?

Back to top
View user's profile Send private message
Alan Phipps
Moderator (English)
Moderator (English)

MEDALMEDALMEDAL

Joined: 16 Apr 2004
Posts: 17507 on topic
Location: Stonehenge, UK
Thank you for registering your game
PostPosted: Tue, 26. Jul 16, 16:14    Post subject: Reply with quote Print

I had a search of the Steam forums for X-BtF and here are a few similar discussions. See if anything stands out as being useful for you. (You may not be totally alone with this issue!)

http://steamcommunity.com/app/2840/discussions/0/540732347421688446/

http://steamcommunity.com/app/2840/discussions/0/630800446646064810/

http://steamcommunity.com/app/2840/discussions/0/846965705276825663/

http://steamcommunity.com/app/2840/discussions/0/846958724663300562/


_________________
A dog has a master; a cat has domestic staff.
Back to top
View user's profile Send private message
AdamFM





Joined: 21 Jul 2016



PostPosted: Tue, 26. Jul 16, 17:01    Post subject: Reply with quote Print

Yeah, the second and fourth links you posted are describing what's happening to me exactly too. I'm not unique at all! Perhaps the devs can take a closer look at this issue? I'm happy to be a test subject.

Some interesting stuff in this thread too, which is about getting X to run fullscreen without a visible window frame (my emphasis):

http://steamcommunity.com/app/2840/discussions/0/846965056738280642/

Quote:
Okay, I investigated a little bit further. Here is what I know (spoiler: no viable solution):

X: BtF runs on win8 in cpu rendering mode (one side effect is the frame, sometimes it can be slow too). The other mode would be DirectDraw, but win8 doesn't support it natively. If you want to you could force win8 to emulate it, but when I tried this objects had no textures (black background, white objects), so it wasn't playable.

You can either play it like it is now, or you revert to win7 (there DirectDraw runs natively). A VM with win95 up to win7 would work too (but you should at least consider running it on win98).


Back to top
View user's profile Send private message
KlausM
EGOSOFT
EGOSOFT



Joined: 06 Nov 2002
Posts: 554 on topic

Thank you for registering your game
PostPosted: Thu, 28. Jul 16, 18:35    Post subject: Reply with quote Print

Hi, as far as we can tell, it's a DirectDraw emulation issue on Windows 8/8.1, which can't be fixed by us.

When starting the game through Steam, the compatibility settings are always set to "Windows 7" and "16-bit color" automatically, so any manual changes get overwritten. To prevent that, you'd have to remove or rename the file installscript.vdf in the game folder. Feel free to do that and try compatibility with other Windows versions, but probably that won't solve your problem.

Here are a few suggestions:

- You could try disabling hardware acceleration using these instructions (that's just a wild guess though):
http://www.thewindowsclub.com/hardware-acceleration-windows-7

- If that doesn't work, try booting Windows into safe mode. Hold Shift while clicking on "Restart", this will give you additional restart options.

- Since the issue is probably limited to Windows 8/8.1, it should go away if you upgrade to Windows 10. The upgrade is still free until tomorrow...

Back to top
View user's profile Send private message
AdamFM





Joined: 21 Jul 2016



PostPosted: Fri, 29. Jul 16, 16:56    Post subject: Reply with quote Print

I renamed the installscript, and replaced the X.exe with the No Steam version available from the 1.9->2.2 patch, but after fiddling the compatibility options it gave me the same issues.

I followed the instructions but there is no 'Troubleshooting' tab on my advanced display options dialog box, so there is no option to disable hardware acceleration from within Windows. According to one Microsoft Answers thread I saw, that means my GeForce GTX 970 doesn't support hardware acceleration, but that sounds unlikely. I also looked where the instructions say to in the registry, but I couldn't find the key that it names.

I booted into Safe Mode, and this time X started in fullscreen with the visible window frame which I believe the players in the above thread complained of. However I heard nothing and X closed with the message 'Error playing video, check your display settings'.

Finally I would sooner upgrade my computer with a sharp axe than Windows 10, but that's just me.

I imagine it's time to give up... I do have another PC running Windows XP that I could dig out and try and play this on, but it's just inconvenient.

Anyway, thanks Klaus and Alan, you've been very helpful. Very Happy

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic Reply to topic Goto page Previous  1, 2
 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum
Control Panel
Login Data
The time now is Fri, 20. Apr 18, 03:12

All times are GMT + 2 Hours


Board Security

Copyright © EGOSOFT 1989-2018
Powered by phpBB © 2001, 2005 phpBB Group
Template created by Avatar & BurnIt!
Debug: page generation = 0.05954 seconds, sql queries = 19