[SCR] MARS Fire Control (v5.25 - 16.02.13)

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Moderators for English X Forum, Scripting / Modding Moderators

Post Reply
User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Sun, 4. Nov 12, 02:59

MARS Repacked for Plugin Manager

MARS v5.26 Repacked for Plugin Manager (for Vanilla TShips) for AP 3.x

MARS v5.25 repacked for Plugin Manager (for Vanilla TShips) for AP1.x-2.x

The Plugin Manager will automatically renumber the included fake patch. The fake patch has TShips modified for Repair Goblins. Both TC and AP versions are in the fake patch; in their correct folders.
  • If you install this manually (instead of using the Plugin Manager) then put the fake patch into the correct folder for your game and renumber it appropriately. See Installation Tips if you need more information about Fake Patches.


MARS for Plugin Manager for Major Mods (XRM, XTC, etc)
MARS v5.26 for major mods (XRM, XTC, etc.)
Use this version if you have a modified TShips that already includes MARS repair goblins. (v5.26 is identical to v5.25)

Important: You may have to get a modified t file from your mod's developer.
.
Last edited by DrBullwinkle on Thu, 6. Jun 13, 22:42, edited 5 times in total.

User avatar
Sabrina Bergin
Posts: 2163
Joined: Sat, 12. Apr 08, 10:53
xr

Mars weapon system./Goblins

Post by Sabrina Bergin » Thu, 8. Nov 12, 06:51

I am playing AP with Mars and Marine repairs installed;

I have two questions the first involves my attempt to sneak up and cap a Hyp/V.

as soon as I change Friend/Foe settings my Goblins launch themselves at the nearest police patrols in sector.

Any suggestions how I can disable the goblins auto launch settings whilst I cap the Hyperion ?.

Second is that since installing the above scripts I have experienced a greater than expected FPS drop any suggestions on how to rectify I'm running an Intel dual core 3.4ghz chip with four gig of ddr2 ram and an NVidia 1Gb Video card.

scripts were installed via Litecubes plug in manager.


Edit: Merged with MARS thread, as per S&M posting rules. X2-Illuminatus
When traveling pause occasionally, look back and enjoy the moment again.

User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Thu, 8. Nov 12, 07:44

In this forum you should post in the thread for the script about which you inquire. In this case: MARS Fire Control. That way, the author will see your post, other users may help, and it will help to keep the forum organized.

There is a hotkey to recall Goblins. It also disables Goblins from re-launching for several minutes. Details in the MARS manual.

Note that Goblins launched against most ships simply harass the enemy. They do not actually do any damage.

There is also a hotkey to disable MARS turrets. You may want to use that after you have stripped your target's shields.

MARS is the heavyweight turret script. Depending on which options you choose and which ships you run it on, it could be CPU-intensive. Personally, I have never had a problem with performance (I run MARS on enemy ships). Is the FPS drop noticeable? Or merely measurable? On which ships have you enabled MARS?

User avatar
Sabrina Bergin
Posts: 2163
Joined: Sat, 12. Apr 08, 10:53
xr

Post by Sabrina Bergin » Thu, 8. Nov 12, 22:04

Dr Bullwinkle;

Mars is on all M class ships ie Capitals

The FPS drop is noticable and becomes worse the longer I play.

I have tried reducing graphics loading but to no avail any suggestions w3ould be appreciated.
When traveling pause occasionally, look back and enjoy the moment again.

User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Fri, 9. Nov 12, 00:24

By "M class" do you mean military ships? Including fighters?

Is MARS enabled on all of your capital ships? Or all enemy capital ships? Or both?

Try setting MARS to run only on the player ship to test whether MARS is causing the performance problem.

Which version of Marine Repairs are you using? Tatakau's or mine?

I experienced a problem with Tatakau's version, in which multiple copies of the script would "pile up". Check the Global Tasks section of the script editor to see whether that is happening to you. Ordinarily, tasks with names including "tatakau.repair" should appear only briefly and disappear. If you see a page full of them, and they do not clear in a few seconds, then it is the pile up problem.

I believe that I fixed that problem in my version. Probably. :)

joajoha
Posts: 37
Joined: Fri, 1. Dec 06, 14:03
x4

[MOD] Battlestar Galactica AP + M.A.R.S

Post by joajoha » Wed, 14. Nov 12, 08:41

Hi.

I have edited the 7047-L044.xml file to make it compatible with the custom weapons of [Mod]Battlestar Galactica AP.

Link to thread:

http://forum.egosoft.com/viewtopic.php? ... battlestar

Link to file:

https://docs.google.com/file/d/0BxkYbRh ... 9GVUk/edit

(As far as I could read, I am allowed to modify the 7575-L044, to make it compadibel to other Mods. Let me know if I am mistaken and I will remove the file :) )


EDIT: I just now saw the FAQ section on the MARS thread, could have saved me alot of trubble :lol:

Taro8
Posts: 117
Joined: Fri, 22. Jun 07, 20:27
x3tc

Post by Taro8 » Thu, 15. Nov 12, 23:52

I have problem with readtext in AL.

In main AL in only have 0-250. Further options have 0-two thousand something. there is one very weird ID with around million something. I installed, downloaded and reinstalled mars few times, but without success.

t files are where thy should be.

Please help, this is one of the must have mods.

User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Fri, 16. Nov 12, 00:18

What problem(s) are you having? Be specific. Tell us the exact errors that you see or post screenshots.

What language do you play? Which game (TC or AP)?

Taro8
Posts: 117
Joined: Fri, 22. Jun 07, 20:27
x3tc

Post by Taro8 » Fri, 16. Nov 12, 00:32

English TC, 3.2 with XTM and some other mods.

The problem is that I dont have any MARS related text, here's what I have in AL page:

http://i.imgur.com/mxfig.jpg
http://i.imgur.com/7ozBh.jpg


Im sure this is MARS as this block of text appears only when MARS is installed.

t files from MARS are in t folder as they should be.

Osiris454
Posts: 741
Joined: Tue, 4. Jan 11, 23:03
x3tc

Post by Osiris454 » Fri, 16. Nov 12, 00:46

Could MARS be altered so that it doesn't try to use long duration (~2sec beam) beam weapons at fighters?

The PALC works fine, but a Plasma Beam Cannon won't do diddly to an M3. Contact is only maintained for a fraction of a second.

User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Fri, 16. Nov 12, 00:55

Taro8 wrote:English TC, 3.2 with XTM
Double-check your t folder for 7048-L044.xml. That is the lasers file for XTM.
Last edited by DrBullwinkle on Fri, 16. Nov 12, 01:51, edited 2 times in total.

User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Fri, 16. Nov 12, 01:17

Osiris454 wrote:Could MARS be altered so that it doesn't try to use long duration (~2sec beam) beam weapons at fighters?

The PALC works fine, but a Plasma Beam Cannon won't do diddly to an M3. Contact is only maintained for a fraction of a second.
You can disable laser switching. Or you can probably fake MARS out by editing the laser file (7047 for vanilla). You may have to experiment to find the right combination to persuade MARS to not use PBC's against fighters.

Gazz probably knows exactly how to do it. Perhaps he will chime in when he has time.

Taro8
Posts: 117
Joined: Fri, 22. Jun 07, 20:27
x3tc

Post by Taro8 » Fri, 16. Nov 12, 01:38

Those errors do not appear to be from MARS -- certainly not from properly-installed t files.

Double-check your t folder for 7048-L044.xml. That is the lasers file for XTM.
This readtext in AL appears only when I enable MARS in Plugin Manager. If I dont have MARS installed then there is no issues.

7048-L044.xml is in t folder and it appears to be fine. It has MARS related text as well as laser names (I just skimmed through).

Im not deep into X modding so I have no idea is wrong. However it appears I wasnt the only one with this problem.
Black_hole_suN wrote:i downloaded and installed MARS.... but i keep on getting Readtext blahblah on the AL menu... did i do something wrong??? im running vanilla x3tc 3.2

User avatar
DrBullwinkle
Posts: 5704
Joined: Sat, 17. Dec 11, 02:44
x3tc

Post by DrBullwinkle » Fri, 16. Nov 12, 01:57

Oh, right, those errors are from the 7046 file. MARS uses two t files.

So make sure that 7046-L044.xml is correctly installed in your t folder.

If the correct t file is in the correct folder, then you should be able to see the names in-game. Language files work pretty reliably, when installed correctly.
  • (BTW, "ReadText blah blah" is just noise. It may, or may not, be related to your issue in any way. Without the numbers it means nothing at all.)
Last edited by DrBullwinkle on Fri, 16. Nov 12, 02:41, edited 1 time in total.

Taro8
Posts: 117
Joined: Fri, 22. Jun 07, 20:27
x3tc

Post by Taro8 » Fri, 16. Nov 12, 02:10

7046-L044.xml is in t folder as well and also looks fine.

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”