3.0 and mods

The place to discuss scripting and game modifications for X³: Terran Conflict and X³: Albion Prelude.

Moderators: Scripting / Modding Moderators, Moderators for English X Forum

Post Reply
Anunnak
Posts: 30
Joined: Sat, 8. Mar 08, 12:02
x4

3.0 and mods

Post by Anunnak » Sat, 9. Oct 10, 12:15

Hi all

I'm curious as to mods and compatibility with 3.0, official answer was "there should be no problems". Each time I launch X3 with the Plug-in Manager the main screen is displayed as 2.7.1, and the launch icon as 3.0, anyone else experience this with STEAM?

I think I'll just reinstall X3tc, but, my main concern is mods and their compatibility with 3.0. Has any one had any trouble so far?

Thanks

User avatar
Cadvan
Posts: 2812
Joined: Sun, 14. Mar 04, 06:05
x4

Post by Cadvan » Sat, 9. Oct 10, 12:42

3.0 is build in a way that every mod/script wich is compatible with 2.7.1 is compatible with 3.0.

pndrev
Posts: 20
Joined: Tue, 14. Sep 10, 01:55
x3tc

Post by pndrev » Sat, 9. Oct 10, 14:11

My question is rather: After patching, should I reinstall all mods to be sure that /scripts etc. are the modded ones?

User avatar
apricotslice
Posts: 13737
Joined: Sun, 16. May 04, 13:01
x4

Post by apricotslice » Sat, 9. Oct 10, 14:40

The v3 patch installed as cat/dat 12 on my game, which I wasnt expecting since v2.7.1 installed as 12. I'd left 13 free for it, so had to renumber the previous 13 back from 14 that I'd changed it to in anticipation.

So I suggest people check their false patches before and after installing v3 to ensure they remain correctly installed.

If a mod is v2.7.1 compatible, then its v3 compatible.

The patch has some files from the previous 2 patches, but they are not changed.

User avatar
TrixX
Posts: 2022
Joined: Wed, 18. Aug 10, 14:28
x3tc

Post by TrixX » Sat, 9. Oct 10, 14:49

Technically you could combine all the CAT's from Egosoft into a big one and then have all subsequent ones as mods.

Monolithic CAT/DAT combo :D
"If you’re not prepared to be wrong, you’ll never come up with anything original."
Sir Ken Robinson

User avatar
apricotslice
Posts: 13737
Joined: Sun, 16. May 04, 13:01
x4

Post by apricotslice » Sat, 9. Oct 10, 14:53

TrixX wrote:Technically you could combine all the CAT's from Egosoft into a big one and then have all subsequent ones as mods.

Monolithic CAT/DAT combo :D
That wont work.

Egosoft have hardcoded the presence of the original cats. The first 4 at least, cannot be altered, without grave risk. (As far as I can see).

User avatar
TrixX
Posts: 2022
Joined: Wed, 18. Aug 10, 14:28
x3tc

Post by TrixX » Sat, 9. Oct 10, 15:30

Ah well, dunno why they felt the need to do that, but hey. At least this patch was a replacement of 12 so it didn't mess up CAT/DAT locations from 2.7.1 :)
"If you’re not prepared to be wrong, you’ll never come up with anything original."
Sir Ken Robinson

User avatar
Ketraar
Moderator (DevNet)
Moderator (DevNet)
Posts: 8958
Joined: Fri, 21. May 04, 17:15
x4

Post by Ketraar » Sat, 9. Oct 10, 16:44

apricotslice wrote:The v3 patch installed as cat/dat 12 on my game, which I wasnt expecting since v2.7.1 installed as 12.
The reason for it is
Huefte wrote:3.0 is build in a way that every mod/script wich is compatible with 2.7.1 is compatible with 3.0.
Note that Mods on the Disk may already use 13, it would have been a pain if 3.0 would have used 13. ;-)

MFG

Ketraar
Image

User avatar
apricotslice
Posts: 13737
Joined: Sun, 16. May 04, 13:01
x4

Post by apricotslice » Sun, 10. Oct 10, 01:08

Yes, well, I've installed it as a 13 anyway, so I can differentiate what was done in 2.7.1 if necessary. I've all the patches expanded into their own folders, so I can see exactly what was done in each, and find the latest of any file.

Post Reply

Return to “X³: Terran Conflict / Albion Prelude - Scripts and Modding”